Cisco Router NAT Overload PAT Konfigürasyonu – Cisco Router NAT konfigürasyon ayarlarının bir diğeri de NAT Overload (NAT Aşırı Yük)’tür ve PAT (Port Address Translation – Port Adres Çevirici) olarak da bilinir.
Cisco Router NAT Overload PAT Konfigürasyonu

Cisco Router NAT Overload PAT Konfigürasyonu

Cisco Router NAT Overload PAT Konfigürasyonu

Cisco yönlendirici PAT yapılandırma işlemi, Static NAT ve Dynamic NAT’a göre farklılık göstermektedir. Cisco yönlendirici Static NAT işleminde, çevrime uğrayacak Ip adresi CLI konsolunde statik olarak yapılandırılır. Dynamic NAT‘ta ise bu işlem, bir havuz sistemiyle çalışır. NAT Havuz sistemi, İnternet Servis Sağlayıcı tarafından tahsis edilen Ip adreslerinden oluşmaktadır.

Cisco yönlendirici Dinamik NAT işleminde, LAN üzerinden İnternet’e çıkacak olan bilgisayarların özel Ip adresleri Dinamik NAT işleminde havuz sisteminde boşta olan Ip adresini kullanarak genel Ip adreslerine çevrilir. İnternet’e çıkan her özel Ip adresi port numaraları ile eşleşmektedir.

Cisco Router NAT Overload PAT konfigürasyon işlemi network üzerinde uygulanan en yaygın işlemdir. Çünkü, çoğu firma ISS tarafından tahsis edilen tek bir Ip adresine sahiptir. Dolayısıyla, LAN üzerindeki tüm bilgisayarların İnternet’e çıkabilmesi için NAT Overload işlemi uygulanması en mantıklı yoldur.

Cisco yönlendirici üzerinde Statik NAT yapılandırma işlemi için, Cisco Router Static NAT Yapılandırma adlı yazıyı okuyabilirsiniz…

Cisco Router NAT Overload PAT Konfigürasyonu İçin Cisco IOS

 

Cisco Yönlendirici Üzerinde PAT Yapılandırma

Cisco yönlendirici üzerinde PAT yapılandırma işlemi Dynamic NAT ile çok benzerdir. Fakat, PAT yapılandırmasında Ip adres havuzu tanımlanmaz. Tek bir genel Ip adresine sahip olan firmalar, Cisco yönlendirici üzerinde PAT yapılandırma işlemini uygularlar.

Cisco Router NAT Overload PAT konfigürasyonu için GNS3 ve VMware Workstation programını kullanacağız.

GNS3’e VMware sanal makinaları dahil etme işlemi için, GNS3 ile VMware Workstation Bağlantısı adlı yazıyı okuyabilirsiniz…

   Adım 1

Öncelikle, GNS3 programını açınız ve yeni bir proje oluşturunuz. Daha sonra, GNS3 çalışma alanına Router, Cloud, Switch ve iki adet Host/Bilgisayar ekleyiniz. Aşağıdaki görüntüdeki gibi topoloji oluşturunuz.

Cisco Router NAT Overload PAT Konfigürasyonu

   Adım 2

Cloud ayarlarına girdikten sonra, Ethernet sekmesinde bilgisayarınızın fiziksel Ethernet’ini seçiniz ve ekleyiniz.

Cisco Router NAT Overload PAT Konfigürasyonu

   Adım 3

GNS3 programında bir Switch’e iki adet bilgisayar ekleyince bazı problemler oluşmaktadır. Bu sorunu aşağıdaki görüntüdeki gibi Switch ayarlarından bilgisayarların takılı olduğu port numaraları üzerinde değişiklik yaparak giderebilirsiniz.

Cisco Router NAT Overload PAT Konfigürasyonu

   Adım 4

VMware Workstation programının Virtual Network Editor programında VMnet3 ekleyiniz. Ip adres bloğunu ayarladıktan sonra, GNS3 çalışma alanı üzerindeki bilgisayarların ayarlarından Ethernet sekmesinden VMnet3’i seçiniz ve ayarları kaydediniz.

Cisco Router NAT Overload PAT Konfigürasyonu

   Adım 5

Cisco Router NAT Overload PAT konfigürasyonu için Cisco Router üzerinde çift tıklayınız ardından CLI komut konsolu açılacaktır. Cisco yönlendirici üzerinde PAT yapılandırma için gerekli komutları CLI konsoluna sırasıyla uygulayınız.

[code] R1# conf t
R1(config)# interface fastethernet 0/0
R1(config)# ip address 192.168.8.1 255.255.255.0
R1(config-if)# ip nat inside
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface fastethernet 0/1
R1(config-if)# ip address dhcp
R1(config-if)# ip nat outside
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# access-list 1 permit 192.168.8.0 0.0.0.255
R1(config)# ip nat inside source list 1 interface fastethernet 0/1 overload
R1(config)#exit
R1# copy running-config startup-config
[/code]

Cisco Router NAT Overload PAT Konfigürasyonu

   Adım 6

Cisco Router NAT Overload PAT konfigürasyonu için gerekli komutları uyguladıktan sonra, VMware Workstation üzerinde Windows 8.1 sanal makinadan Google DNS sunucularına bağlatıyı test edelim.

Ping işlemi başarılıdır!

Cisco Router NAT Overload PAT Konfigürasyonu

   Adım 7

Windows 10 sanal makinadan Google DNS sunucularına ping işlemi de başarılır!

Cisco Router NAT Overload PAT Konfigürasyonu

   Adım 8

Cisco Router üzerinde show ip nat translations komutunu ayrıcalıklı yapılandırma modunda uyguladığımızda, aşağıdaki görüntüde sanal makinaların İnternet’e çıkarken çevrildikleri Ip adresi ve port numaralarını görebilirsiniz.

Cisco Router NAT Overload PAT Konfigürasyonu

   Adım 9

Cisco Router üzerinde show ip nat statistics komutunu uyguladığımızda NAT işlemi ile ilgili çıktıları görebiliriz.

Cisco Router NAT Overload PAT Konfigürasyonu

   Adım 10

Cisco Router NAT Overload PAT konfigürasyonu yapılandırmasından sonra, genel Ip adreslerine çevrilen özel Ip adreslerini Cisco yönlendirici CLI üzerinden NAT tablosundan clear ip nat translations * komutu ile silebiliriz.

Cisco Router NAT Overload PAT Konfigürasyonu

Cisco Router NAT Overload PAT Konfigürasyonu Show Komutları

R1#show running-configR1#show ip nat translationsR1#show ip nat translations
R1#show running-config
Building configuration…

Current configuration : 1095 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 192.168.8.0 0.0.0.255
no cdp log mismatch duplex
!
!
control-plane
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

R1#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 192.168.1.102:1 192.168.8.5:1 8.8.8.8:1 8.8.8.8:1
tcp 192.168.1.102:49193 192.168.8.5:49193 2.17.20.139:80 2.17.20.139:80
tcp 192.168.1.102:49194 192.168.8.5:49194 2.17.20.139:80 2.17.20.139:80
tcp 192.168.1.102:49195 192.168.8.5:49195 2.22.109.171:80 2.22.109.171:80
icmp 192.168.1.102:0 192.168.8.10:1 8.8.8.8:1 8.8.8.8:0
tcp 192.168.1.102:49706 192.168.8.10:49706 23.62.98.64:80 23.62.98.64:80
tcp 192.168.1.102:49730 192.168.8.10:49730 23.62.98.64:80 23.62.98.64:80
tcp 192.168.1.102:49731 192.168.8.10:49731 23.62.98.8:80 23.62.98.8:80
tcp 192.168.1.102:49736 192.168.8.10:49736 23.62.98.8:80 23.62.98.8:80
tcp 192.168.1.102:49809 192.168.8.10:49809 173.223.11.177:80 173.223.11.177:80
tcp 192.168.1.102:49854 192.168.8.10:49854 13.107.4.50:80 13.107.4.50:80
tcp 192.168.1.102:49858 192.168.8.10:49858 23.62.98.8:80 23.62.98.8:80
tcp 192.168.1.102:49895 192.168.8.10:49895 13.107.4.50:80 13.107.4.50:80
tcp 192.168.1.102:49897 192.168.8.10:49897 13.107.4.50:80 13.107.4.50:80
tcp 192.168.1.102:49908 192.168.8.10:49908 40.77.229.91:443 40.77.229.91:443
tcp 192.168.1.102:49909 192.168.8.10:49909 40.77.229.17:443 40.77.229.17:443
tcp 192.168.1.102:49914 192.168.8.10:49914 40.77.229.10:443 40.77.229.10:443
tcp 192.168.1.102:49916 192.168.8.10:49916 40.77.226.250:443 40.77.226.250:443
tcp 192.168.1.102:49917 192.168.8.10:49917 92.123.166.179:443 92.123.166.179:443
udp 192.168.1.102:59225 192.168.8.10:59225 192.168.1.1:53 192.168.1.1:53
R1#show ip nat translations
Pro Inside global Inside local Outside local Outside global
tcp 192.168.1.102:49212 192.168.8.5:49212 151.101.194.49:80 151.101.194.49:80
R1#
R1#show ip nat
R1#show ip nat s
R1#show ip nat statistics
Total active translations: 1 (0 static, 1 dynamic; 1 extended)
Outside interfaces:
FastEthernet0/1
Inside interfaces:
FastEthernet0/0
Hits: 180715 Misses: 431
CEF Translated packets: 179908, CEF Punted packets: 2474
Expired translations: 635
Dynamic mappings:
— Inside Source
[Id: 1] access-list 1 interface FastEthernet0/1 refcount 1
Appl doors: 0
Normal doors: 0
Queued Packets: 0
R1#

Cisco yönlendirici üzerinde Dinamik NAT konfigürasyonu için, Cisco Router Dynamic NAT Yapılandırma konusunu okumanızı tavsiye ederim!

Cisco Router NAT Overload PAT Konfigürasyonu ⇒ Video

GNS3’te Cisco Router üzerinde NAT Overload PAT konfigürasyonu adımlarını gerçekleştirmek için aşağıdaki videoyu izleyebilir ve ayrıca YouTube kanalımıza abone olunuz…

  Son Söz

Cisco Router NAT Overload PAT Konfigürasyonu adlı yazımı burada noktalandırıyorum. Cisco yönlendirici üzerinde PAT yapılandırma sadece genel bir Ip adresine sahip olan ağ için yaygın olarak kullanılmaktadır.

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Router NAT Overload PAT Konfigürasyonu İlgili Yazılar

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

20 − 15 =