GNS3 Kullanarak Cisco Router Üzerinde DHCP Yapılandırma

DHCP yapılandırması sayesinde ağ üzerinde iletişim halinde olan bilgisayarlara otomatik olarak IP adresi dağıtılır ve bu sayede bilgisayarlara manuel IP adresi atamanız gerekmez.

GNS3 Kullanarak Cisco Router Üzerinde DHCP Yapılandırma

GNS3 ile Cisco Router Üzerinde DHCP Nasıl Yapılandırılır?

Cisco yönlendiricilerde DHCP‘yi yapılandırdıktan sonra, ağdaki her bir cihaza IP Adresi, Alt Ağ Maskesi, DNS Adresi, Varsayılan Ağ Geçidi ve Etki Alanı Adı otomatik olarak dağıtılır.

Fakat burada dikkat edilmesi gereken nokta, ağa bağlanan bir cihazın TCP/IP ayarları otomatik IP adresi almak için yapılandırılması gerekir.

GNS3 simülatör programını ve VMware sanal makineleri kullanarak daha gerçekçi bir ağ topolojisi oluşturarak DHCP’yi yapılandırabilir ve çalışma mantığını daha iyi anlayabilirsiniz.

   Adım 1

Öncelikle, GNS3 programını açınız ve aşağıdaki görüntüdeki gibi bir ağ tasarımı oluşturunuz. Ve çalışma alanına bir adet Cisco Router ve Switch, ve üç adet sanal makine ekleyiniz.

Sanal makinelerin bağdaştırıcı ayarlarını VMnet olarak yapılandırınız ve konfigüre ediniz.

Bir Switch'e Bağlı Üç Adet Bilgisayar ve Bir Adet Cisco Router

   Adım 2

Çalışma alanına eklediğiniz Cisco Switch’i yapılandırmanız gerekir. Aksi takdirde, ağ üzerindeki bilgisayarlar Router ile iletişim kuramayacak.

Switch’i yapılandırmak için, ayarlarını aşağıdaki resimde gösterildiği gibi değiştiriniz.

Switch EtherType Yapılandırması

   Adım 3

Router’ın üzerine çift tıklayarak CLI komut istemini açınız ve ardından aynı ağda bulunan sanal makinelere otomatik IP adresi dağıtmak için DHCP yapılandırınız.

Cisco Router’da GNS3 DHCP konfigürasyonu için CLI’da aşağıdaki komutları çalıştırınız.

R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 192.168.8.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# ip dhcp pool LAN
R1(dhcp-config)# network 192.168.8.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.8.1
R1(dhcp-config)# dns-server 192.168.8.1
R1(dhcp-config)# domain-name sysnettechsolutions.com
R1(dhcp-config)# ip dhcp excluded-address 192.168.8.1
R1(dhcp-config)# lease infinite
R1(dhcp-config)# end
R1# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R1#

 
Komut açıklamaları:

ip dhcp pool LAN: Oluşturacağınız IP havuzu için bir ad tanımlar.
network 192.168.8.0 255.255.255.0: IP adresi dağıtılacak ağı yapılandırır.
default-router 192.168.8.1: Ağdaki varsayılan ağ geçidi olan cihazı yapılandırır.
dns-server 192.168.8.1: Bilgisayarlara DNS sunucusu yapılandırır.
domain-name sysnettechsolutions.com: PC’lere domain adı atar.
ip dhcp excluded-address 192.168.8.1: Hariç tutulacak IP adresi ve adreslerini ayarlar.
lease infinite: Ağdaki PC’lere atanan bilgilerin kira süresini yapılandırır.

Gerekli komutları uyguladıktan sonra VMware üzerinde sanal makineleri çalıştırın ve TCP/IPv4 ayarlarını otomatik olarak ayarlaryınız.

IP adresini otomatik olarak yapılandırdıktan sonra sanal bilgisayarlar tüm IP bilgilerini DHCP sunucusundan alacaktır.

   Adım 4

Şimdi, bilgisayarların Router’dan aldığı TCP/IP bilgilerine göz atalım.

Windows 8.1 sanal makinede CMD’yi açınız ve ipconfig komutunu çalıştırdıktan sonra aşağıdaki görüntüdeki gibi raporlanan bilgileri inceleyiniz.

Windows 8.1 / Hostname

   Adım 5

Windows 10 sanal makine TCP/IP bilgilerini de kontrol ediniz.

Windows 10 / Hostname

   Adım 6

Aynı şekilde, Windows XP’nin de IP yapılandırmasını kontrol ediniz.

192.168.8.0 IP bloğu için yapılandırılan DHCP sunucu, ağdaki tüm sanal makinelere/bilgisayarlara başarıyla IP adresi atamıştır!

Windows XP / Hostname

Show Komutları

R1#show running-config
Building configuration...
Current configuration : 1157 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.8.1
!
ip dhcp pool LAN
network 192.168.8.0 255.255.255.0
dns-server 192.168.8.1
default-router 192.168.8.1
domain-name sysnettechsolutions.com
lease infinite
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
ip address 192.168.8.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end
R1#

 

R1#show ip dhcp ?
binding              DHCP address bindings
conflict              DHCP address conflicts
database           DHCP database agents
import               Show Imported Parameters
pool                    DHCP pools information
relay                   Miscellaneous DHCP relay information
server               Miscellaneous DHCP server information

 

R1#show ip dhcp binding
Bindings from all pools not associated with VRF:
|           IP address             Client-ID/                                  Lease expiration Type
|                                               Hardware address
|                                               User name
|           192.168.8.3         0100.5056.3a87.3f             Infinite Automatic

 

R1#show ip dhcp pool
Pool LAN :
|     Utilization mark (high/low) : 100 / 0
|     Subnet size (first/next) : 0 / 0
|     Total addresses : 254
|     Leased addresses : 1
|     Pending event : none
|     1 subnet is currently in the pool :
|     Current index IP address range Leased addresses
|     192.168.8.1 192.168.8.1 - 192.168.8.254 1

 

R1#show ip dhcp server statistics
Memory usage 23999
Address pools 1
Database agents 0
Automatic bindings 1
Manual bindings 0
Expired bindings 0
Malformed messages 0
Secure arp entries 0

Message Received
BOOTREQUEST 0
DHCPDISCOVER 104
DHCPREQUEST 7338
DHCPDECLINE 0
DHCPRELEASE 0
DHCPINFORM 0

Message Sent
BOOTREPLY 0
DHCPOFFER 104
DHCPACK 4408
DHCPNAK 0
R1#

 

Cisco Router Üzerinde DHCP Etkinleştirme ⇒ Video

Cisco Router üzerinde DHCP kullanımı için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, GNS3 programını kullanarak Cisco Router üzerinde DHCP ayarları nasıl yapılır inceledik. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


GNS3 ile Static NAT 
GNS3 ile Dynamic NAT
GNS3 ile PAT
SDM ile NAT
Router Ayarlarını Yedekleme 

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

shares
error: