Cisco Layer 2 Switch VLAN Yapılandırma – Bu yazımızda GNS3 programını kullanarak Cisco Layer 2 (Katman 2) Switch üzerinde VLAN oluşturma ve Inter-VLAN (VLAN Yönlendirme) işlemlerini gerçekleştireceğiz.
Cisco Layer 2 Switch VLAN Yapılandırma

Cisco Layer 2 Switch VLAN Yapılandırma

Cisco Layer 2 Switch VLAN Yapılandırma

GNS3 ile daha spesifik ağ tasarımları yapılmaktadır. Dynamips ile Cisco Router veya Cisco Switch ağ cihazlarının IOS imajlarını kullanarak gerçek bir ağ topolojisi oluşturabiliriz.

Önceki yazılarımızda, GNS3 Layer 2 Switch ekleme işlemini gerçekleştirmiştik. Layer 2 Switch üzerinde VLAN yapılandırma adımlarına geçmeden önce, GNS3 üzerinde Layer 2 Switch ekleme işlemini uygulamanız gerekir. GNS3 üzerinde Layer 2 Switch ekledikten sonra, VLAN yapılandırma adımlarına geçebilirsiniz.

GNS3 programında ağ tasarımı yaparken istemci bilgisayar olarak VMware Workstation sanal makinaları entegre ediyorduk. Bu yazımızda, GNS3 araçlarından VPCS (Virtual PC Simulator)‘i kullanacağız. VPCS kullanımı ile bilgisayarımızın daha fazla performanslı çalışmasını sağlayabiliriz.

Sanal makinalar bilgisayarımızda yük oluşturacaktır. Fakat farklı senaryolarda sanal makinaları da kullanmamız gerektiğini unutmayınız.

Layer 2 Switch VLAN Oluşturma ve Yönlendirme

Cisco Layer 2 Switch VLAN yapılandırma adımlarına artık geçebiliriz. Bu adımları tamamlamak için atılacak adımlar;

1. VPCS Ip Adresi Verme
2. VLAN Oluşturma
3. Switch Trunk Portların Belirlenmesi
4. Switch’ler Arasında Trunking Yapılması
5. Cisco Router Inter-VLAN (VLAN Yönlendirme) Konfigürasyonu

   Adım 1

GNS3 programını çalıştırınız ve çalışma alanına araçlar bölümünden bir adet Cisco Router ekleyiniz.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 2

Çalışma alanına Layer 2 Switch ve 2 adet VPCS ekleyiniz.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 3

Layer 2 VLAN yapılandırması için bir adet daha Layer 2 Switch ve VPCS ekleyiniz.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 4

GNS3 çalışma alanında Layer 2 Switch üzerinde sağ tuş / configure seçeneğine tıklayınız. Açılan pencerede, Cisco Layer 2 Switch için RAM miktarını arttıracağız. GNS3 programına eklediğimiz L2 Switch Qemu tabanlı olduğu için, düşük RAM miktarında boot sorunları oluşabilmektedir.

Cisco L2 Switch RAM miktarını 400 MB yapınız ve ardından Network sekmesine tıklayınız.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 5

Network sekmesinde, Switch’e arayüz eklemek için Adapters sayısını 4 yapınız.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 6

GNS3 çalışma alanında Cisco Layer 2 Switch-2 üzerinde iki arayüz kullanacağımız için 300 MB RAM miktarı belirleyebilirsiniz.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 7

Network sekmesinden 2 adet arayüz ekleyiniz.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 8

Yukarıdaki adımları gerçekleştirdikten sonra, kablolama seçeneğine tıklayınız ve ardından çalışma alanındaki ağ aygıtlarını kablolayınız.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 9

GNS3 Layer 2 Switch VLAN yapılandırma işleminde, ağ topolojisinin son durumu aşağıdaki görüntüdeki gibidir. Ağ topolojisi üzerinde VLAN’ları belirledikten sonra, VPCS’ler için Ip adreslerini not ediniz.

Cisco Switch’ler arasında Trunk bağlantı yapılması gereklidir. Bu yüzden Trunking alanı belirleyiniz. Son olarak, Cisco Router VLAN yönlendirme konfigürasyonu için Cisco Router ve Cisco Switch bağlantısıda Trunk olarak yapılandırılacaktır.

VPCS PC1’e Ip adresi atamak için üzerine çift tıklayınız.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 10

PC1’e Ip adresi atamak için aşağıdaki komutu yazınız ve Enter tuşuna basınız. Ip yapılandırmasına göz atmak için, show ip komutunu kullanabilirsiniz.

[code] ip 192.168.5.5/24 192.168.5.1
[/code]

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 11

VPCS PC2’ye Ip adresi vermek için aşağıdaki komutu uygulayınız. Burada dikkat edilmesi gereken nokta, ağ topolojisine göre adım atmaktır. PC2’yi VLAN10’a üye yapacağımız için Ip adresi farklı olacaktır.

[code] ip 192.168.10.10/24 192.168.10.1
[/code]

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 12

VLAN5’e üye yapacağımız VPCS PC3 için de Ip adresi vermek için aşağıdaki komutu çalıştırınız.

[code] ip 192.168.5.10/24 192.168.5.1
[/code]

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 13

GNS3 Layer 2 Switch VLAN yapılandırmasında, Cisco Switch’leri yapılandırmak için Layer 2 Switch-1 ve Layer 2 Switch-2 üzerine tıklayınız.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 14

Cisco Layer 2 Switch VLAN oluşturmak için aşağıdaki komutları uygulayınız.

L2 Switch-1

[code] vIOS-L2-01# conf t
vIOS-L2-01(config)# vlan 5
vIOS-L2-01(config-vlan)# name IT
vIOS-L2-01(config-vlan)# exit
vIOS-L2-01(config)# vlan 10
vIOS-L2-01(config-vlan)# name SALES
vIOS-L2-01(config-vlan)# exit
vIOS-L2-01(config)# end
vIOS-L2-01# wr
[/code]

L2 Switch-2

[code] vIOS-L2-01# conf t
vIOS-L2-01(config)# vlan 5
vIOS-L2-01(config-vlan)# name IT
vIOS-L2-01(config-vlan)# exit
vIOS-L2-01(config)# end
vIOS-L2-01# wr
[/code]

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 15

Cisco Layer 2 Switch VLAN oluşturma adımlarından sonra, L2 Switch arayüzlerini konfigüre etmemiz gereklidir. Cisco Router ve L2 Switch’e bağlı olan arayüzler Trunk olarak yapılandırılacaktır.

Layer 2 Switch’in Erişim ve Trunk arayüzlerini belirlemek ve PC’leri VLAN’lara üye yapmak için aşağıdaki komutları uygulayınız.

[code] vIOS-L2-01(config)#interface gigabitethernet 0/1
vIOS-L2-01(config-if)#switchport mode access
vIOS-L2-01(config-if)#switchport access vlan 5
vIOS-L2-01(config-if)#exit
vIOS-L2-01(config)#
vIOS-L2-01(config)#interface gigabitethernet 0/2
vIOS-L2-01(config-if)#switchport mode access
vIOS-L2-01(config-if)#switchport access vlan 10
vIOS-L2-01(config-if)#exit
vIOS-L2-01(config)#
vIOS-L2-01(config)#interface gigabitethernet 0/3
vIOS-L2-01(config-if)#switchport trunk encapsulation dot1q
vIOS-L2-01(config-if)#switchport mode trunk
vIOS-L2-01(config-if)#exit
vIOS-L2-01(config)#
vIOS-L2-01(config)#interface gigabitethernet 0/0
vIOS-L2-01(config-if)#switchport trunk encapsulation dot1q
vIOS-L2-01(config-if)#switchport mode trunk
vIOS-L2-01(config-if)#exit
vIOS-L2-01(config)#exit
[/code]

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 16

Cisco Layer 2 Switch-2 üzerinde de aynı işlemleri gerçekleştirme için aşağıdaki komutları uygulayınız.

[code] vIOS-L2-01# conf t
vIOS-L2-01(config)#interface gigabitethernet 0/1
vIOS-L2-01(config-if)#switchport mode access
vIOS-L2-01(config-if)#switchport access vlan 5
vIOS-L2-01(config-if)#exit
vIOS-L2-01(config)#
vIOS-L2-01(config)#interface gigabitethernet 0/0
vIOS-L2-01(config-if)#switchport trunk encapsulation dot1q
vIOS-L2-01(config-if)#switchport mode trunk
vIOS-L2-01(config-if)#end
vIOS-L2-01#wr
[/code]

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 17

Bu adıma kadar VPCS bilgisayarları yapılandırdık, VLAN’lar oluşturduk, PC’leri VLAN’lara atadık ve Trunking bağlantısını gerçekleştirdik.

Bu adımda ise, Cisco Router üzerinde tek bir kablo üzerinden VLAN yönlendirme işlemini yapacağız. GNS3 çalışma alanında Cisco Router üzerine tıkladıktan sonra, aşağıdaki komutları uygulayınız.

[code] R1# conf t
R1(config)#interface fastethernet 0/0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
R1(config)#interface fastethernet 0/0.5
R1(config-subif)#encapsulation dot1q 5
R1(config-subif)#ip address 19
*Mar 1 00:09:18.259: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
R1(config-subif)#ip address 192.168.5.1 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit
R1(config)#
R1(config)#interface fastethernet 0/0.10
R1(config-subif)#encapsulation dot1q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#end
R1#wr
[/code]

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 18

Cisco Layer 2 Switch VLAN yapılandırma adımlarını tamamladık. Şimdi bilgisayarlardan ping testi yapalım. PC1’den VLAN’a üye PC2’ye ping işlemi başarılıdır. VLAN’lar arası yönlendirme sorunsuz çalışmaktadır.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 19

PC2’den VLAN5’e üye olan PC’lere ping atıldığında işlemin başarılı olduğunu görebilirsiniz.

Cisco Layer 2 Switch VLAN Yapılandırma

   Adım 20

Aynı şekilde, PC3 VLAN10 ile sağlıklı bir şekilde bağlantı kurmaktadır.

Cisco Layer 2 Switch VLAN Yapılandırma

Cisco Layer 2 Switch VLAN Yapılandırma Show Komutları

PC1 Ip ConfigPC2 Ip ConfigPC3 Ip ConfigL2 Switch-1 = show vlan briefL2 Switch-2 = show vlan briefL2 Switch-1 = show running-configL2 Switch-2 = show running-configL2 Switch-1 = show interfaces trunkL2 Switch-2 = show interfaces trunkR1#show running-config

PC1> ip 192.168.5.5/24 192.168.5.1
Checking for duplicate address…
PC1 : 192.168.5.5 255.255.255.0 gateway 192.168.5.1

PC1> show ip

NAME : PC1[1] IP/MASK : 192.168.5.5/24
GATEWAY : 192.168.5.1
DNS :
MAC : 00:50:79:66:68:00
LPORT : 10003
RHOST:PORT : 127.0.0.1:10002
MTU: : 1500

PC1>

PC2> ip 192.168.10.10/24 192.168.10.1
Checking for duplicate address…
PC1 : 192.168.10.10 255.255.255.0 gateway 192.168.10.1

PC2> show ip

NAME : PC2[1] IP/MASK : 192.168.10.10/24
GATEWAY : 192.168.10.1
DNS :
MAC : 00:50:79:66:68:01
LPORT : 10005
RHOST:PORT : 127.0.0.1:10004
MTU: : 1500

PC2>

PC3> ip 192.168.5.10/24 192.168.5.1
Checking for duplicate address…
PC1 : 192.168.5.10 255.255.255.0 gateway 192.168.5.1

PC3> show ip

NAME : PC3[1] IP/MASK : 192.168.5.10/24
GATEWAY : 192.168.5.1
DNS :
MAC : 00:50:79:66:68:02
LPORT : 10007
RHOST:PORT : 127.0.0.1:10006
MTU: : 1500

PC3>

vIOS-L2-01#show vlan brief

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active
5 IT active Gi0/1
10 SALES active Gi0/2
100 VLAN100 active
200 VLAN0200 active
300 VLAN0300 active
1002 fddi-default act/unsup
1003 trcrf-default act/unsup
1004 fddinet-default act/unsup
1005 trbrf-default act/unsup

vIOS-L2-01#show vlan brief

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active
5 IT active Gi0/1
100 VLAN100 active
200 VLAN0200 active
300 VLAN0300 active
1002 fddi-default act/unsup
1003 trcrf-default act/unsup
1004 fddinet-default act/unsup
1005 trbrf-default act/unsup
vIOS-L2-01#

vIOS-L2-01#show running-config
Building configuration…

Current configuration : 5125 bytes
!
! Last configuration change at 06:26:58 UTC Mon May 15 2017
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname vIOS-L2-01
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
vtp domain CISCO-vIOS
vtp mode transparent
!
!
!
ip cef
no ipv6 cef
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 5
name IT
!
vlan 10
name SALES
!
vlan 100
name VLAN100
!
vlan 200,300
!
!
!
!
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
switchport access vlan 5
media-type rj45
negotiation auto
!
interface GigabitEthernet0/2
switchport access vlan 10
media-type rj45
negotiation auto
!
interface GigabitEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
logging synchronous
login
line vty 5 15
logging synchronous
login
!
!
end

vIOS-L2-01#

vIOS-L2-01#show running-config
Building configuration…

Current configuration : 4883 bytes
!
! Last configuration change at 06:30:23 UTC Mon May 15 2017
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname vIOS-L2-01
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
vtp domain CISCO-vIOS
vtp mode transparent
!
!
!
ip cef
no ipv6 cef
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 5
name IT
!
vlan 100
name VLAN100
!
vlan 200,300
!
!
!
interface GigabitEthernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
switchport access vlan 5
media-type rj45
negotiation auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
logging synchronous
login
line vty 5 15
logging synchronous
login
!
!
end

vIOS-L2-01#

vIOS-L2-01#show interfaces trunk

Port Mode Encapsulation Status Native vlan
Gi0/0 on 802.1q trunking 1
Gi0/3 on 802.1q trunking 1

Port Vlans allowed on trunk
Gi0/0 1-4094
Gi0/3 1-4094

Port Vlans allowed and active in management domain
Gi0/0 1,5,10,100,200,300
Gi0/3 1,5,10,100,200,300

Port Vlans in spanning tree forwarding state and not pruned
Gi0/0 1,5,10,100,200,300
Gi0/3 1,5,10,100,200,300
vIOS-L2-01#

vIOS-L2-01#show interfaces trunk

Port Mode Encapsulation Status Native vlan
Gi0/0 on 802.1q trunking 1

Port Vlans allowed on trunk
Gi0/0 1-4094

Port Vlans allowed and active in management domain
Gi0/0 1,5,100,200,300

Port Vlans in spanning tree forwarding state and not pruned
Gi0/0 1,5,100,200,300
vIOS-L2-01#

R1#show running-config
Building configuration…

Current configuration : 1149 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.5
encapsulation dot1Q 5
ip address 192.168.5.1 255.255.255.0
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

R1#

Cisco Layer 2 Switch VLAN Yapılandırma ⇒ Video

Cisco Layer 2 Switch VLAN yapılandırma ile ilgili videoyu izleyebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Cisco Layer 2 Switch VLAN Yapılandırma – GNS3 programına Layer 2 Switch entegrasonunu mutlaka yapmanız gerekmektedir. Ardından, L2 Switch VLAN konfigürasyonu adımlarına geçebilirsiniz. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Layer 2 Switch VLAN Yapılandırma İlgili Yazılar

Cisco Layer 2 Switch VLAN Yapılandırma İlgili Dosyalar

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir