How to Add Layer 3 Switch in GNS3? – We had previously installed Layer 2 Switch on GNS3. Layer 2 Switches only forward packets according to the table of MAC addresses. Layer 3 Switches also use the MAC address table and additionally do Ip routing.
How to Add Layer 3 Switch in GNS3?

How to Add Layer 3 Switch in GNS3?

How to Add Layer 3 Switch in GNS3?

The process to add Layer 3 Switch in GNS3 is almost identical to adding a Cisco Router in the GNS3 program. To perform Switching based operations with GNS3, you must follow the steps to add Layer 3 Switch in GNS3.

With Layer 3 Switches on GNS3, you can perform VLAN, 802.1Q Trunking, and InterVLAN Routing. You can do this with the use of GNS3 Layer 3 Key.

Download IOS Required to Add Layer 3 Switch in GNS3

Before the process to add Layer 3 Switch in GNS3, download the IOS software from the computer below.

 

Our Recommendation

You can purchase “Cisco Routing and Switching” from Amazon.

How to Simulate Layer3 Switch in GNS3?

We can now go through to the steps to simulate Layer 3 Switch in GNS3. Follow the steps below to add Layer 3 Switch in GNS3 after downloading the IOS from the above computer.

   Step 1

First, run the GNS3 program and click on the Edit menu.

How to Add Layer 3 Switch in GNS3?

   Step 2

From the Edit menu, click Preferences.

How to Add Layer 3 Switch in GNS3?

   Step 3

In the General Preferences window that opens, click the IOS Routers tab.

How to Add Layer 3 Switch in GNS3?

To add a Layer 2 Switch in the GNS3 network simulation program, you can read the topic called “How to Add Layer 2 Switch in GNS3?“.

   Step 4

The Layer 2 Switch we added earlier has been added from the Qemu VMs section. The process to add Layer 3 Switch in GNS3 is done from this section. In the Cisco Router template window, click the New button.

How to Add Layer 3 Switch in GNS3?

   Step 5

In the IOS Image window, select the New Image option and click the Browse button.

How to Add Layer 3 Switch in GNS3?

   Step 6

Select the IOS you downloaded from the above button and click the Open button.

How to Add Layer 3 Switch in GNS3?

   Step 7

If the GNS3 program asks you to copy IOS to the default image folder, click Yes.

How to Add Layer 3 Switch in GNS3?

   Step 8

Click Next to continue.

How to Add Layer 3 Switch in GNS3?

   Step 9

This is the most important step to add Layer 3 Switch in GNS3. You need to select “This is an EthernetSwitch Router” here. After you select this option, click Next to continue.

How to Add Layer 3 Switch in GNS3?

   Step 10

Leave the Layer 3 Switch’s RAM value as default and click Next.

How to Add Layer 3 Switch in GNS3?

   Step 11

In the Network Adapters window, select the NM-16ESW interface in Slot 0 and proceed to the next step.

How to Add Layer 3 Switch in GNS3?

   Step 12

Click the Idle-PC Finder button to select the most appropriate value for your computer’s CPU performance for the Layer 3 Switch IOS.

How to Add Layer 3 Switch in GNS3?

   Step 13

Calculating Idle-PC value…

How to Add Layer 3 Switch in GNS3?

   Step 14

In the process to add Layer 3 Switch in GNS3, the most appropriate Idle-PC value for IOS is determined. Click the OK button to continue.

How to Add Layer 3 Switch in GNS3?

   Step 15

As you can see, the process to add Layer 3 Switch in GNS3 has been completed successfully.

How to Add Layer 3 Switch in GNS3?

   Step 16

Drag and drop the Layer 3 Switch to the GNS3 workspace.

How to Add Layer 3 Switch in GNS3?

   Step 17

Create the topology as follows. Double click on Layer 3 Switch in GNS3 to test it.

How to Add Layer 3 Switch in GNS3?

   Step 18

We have finished the steps to add Layer 3 Switch in GNS3. Now, to test the switch, apply the show vlan-switch command in the CLI command interface.

Simulate Layer3 Switch in GNS3 by executing the following commands.

[code] ESW1# conf t
ESW1(config)#interface vlan 1
ESW1(config-if)#ip address 192.168.10.1 255.255.255.0
ESW1(config-if)#no shutdown
ESW1(config-if)#exit
ESW1(config)#infterface fastethernet0/0
ESW1(config-if)#no shutdown
ESW1(config-if)#exit
ESW1(config)#exit
ESW1#
[/code]

How to Add Layer 3 Switch in GNS3?

   Step 19

Configure the VPCS on GNS3 and then ping the Vlan 1 interface to test the connection as follows.

How to Add Layer 3 Switch in GNS3?

   Step 20

You can see that the process is successful when pinging the VPCS on each other. Our Layer 3 Switch is running smoothly.

How to Add Layer 3 Switch in GNS3?

To save the IOS software running on the Cisco router to the TFTP server, you can read the topic called “How to Backup Cisco IOS Image to TFTP Server?“.

Show Command Related to How to Add Layer 3 Switch in GNS3

ESW1#show running-configESW1#show ip int brESW1#show vlan-switch

ESW1#show running-config
Building configuration…

Current configuration : 2035 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname ESW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
!
!
no ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
vtp file nvram:vlan.dat

!
!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
description *** Unused for Layer2 EtherSwitch ***
!
interface FastEthernet0/1
description *** Unused for Layer2 EtherSwitch ***
shutdown
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
ip address 192.168.10.1 255.255.255.0
no ip route-cache
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
no cdp log mismatch duplex
!
!
control-plane
!
!
mgcp behavior g729-variants static-pt
!
!
banner exec ^C

***************************************************************
This is a normal Router with a SW module inside (NM-16ESW)
It has been preconfigured with hard coded speed and duplex

To create vlans use the command “vlan database” from exec mode
After creating all desired vlans use “exit” to apply the config

To view existing vlans use the command “show vlan-switch brief”

Warning: You are using an old IOS image for this router.
Please update the IOS to enable the “macro” command!
***************************************************************

^C
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

ESW1#

ESW1#show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset up up
FastEthernet0/1 unassigned YES unset administratively down down
FastEthernet0/2 unassigned YES unset up down
FastEthernet0/3 unassigned YES unset up down
FastEthernet0/4 unassigned YES unset up down
FastEthernet0/5 unassigned YES unset up down
FastEthernet0/6 unassigned YES unset up down
FastEthernet0/7 unassigned YES unset up down
FastEthernet0/8 unassigned YES unset up down
FastEthernet0/9 unassigned YES unset up down
FastEthernet0/10 unassigned YES unset up down
FastEthernet0/11 unassigned YES unset up down
FastEthernet0/12 unassigned YES unset up down
FastEthernet0/13 unassigned YES unset up down
FastEthernet0/14 unassigned YES unset up down
FastEthernet0/15 unassigned YES unset up down
Vlan1 192.168.10.1 YES manual up up
ESW1#

ESW1#show vlan-switch

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/0, Fa0/1, Fa0/2, Fa0/3
Fa0/4, Fa0/5, Fa0/6, Fa0/7
Fa0/8, Fa0/9, Fa0/10, Fa0/11
Fa0/12, Fa0/13, Fa0/14, Fa0/15
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 – – – – – 1002 1003
1002 fddi 101002 1500 – – – – – 1 1003
1003 tr 101003 1500 1005 0 – – srb 1 1002
1004 fdnet 101004 1500 – – 1 ibm – 0 0
1005 trnet 101005 1500 – – 1 ibm – 0 0

How to Add to Layer 3 Switch in GNS3 ⇒ Video

You can watch how to add Layer 3 Switch in GNS3. Also, you can subscribe to our YouTube channel…

  Final Word

How to Add Layer 3 Switch in GNS3? – In the GNS3 program, we can add a manageable Switch with this process. No such processing is required in the Cisco Packet Tracer program. In this article, we basically did a little test. Follow us for more advanced configurations.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to How to Add Layer 3 Switch in GNS3
Products Related to How to Add Layer 3 Switch in GNS3
Related Products

Leave a Reply

Your email address will not be published. Required fields are marked *

eleven − 1 =