How to Configure Static NAT on Cisco Router?

How to Configure Static NAT on Cisco Router? – The NAT operation on the Cisco Router is configured to allow computers on the Local network to access the Global network. In this article, after creating a small topology using GNS3, we will configure Static NAT on Cisco Router.
How to Configure Static NAT on Cisco Router?

How to Configure Static NAT on Cisco Router?

Before configuring Static NAT on Cisco Router, let’s briefly explain Static NAT. Static NAT operation has two terms inside and outside.

When any computer on the local network wants to access the Internet, the IP package will first access the Internet from the external interface of the Router connected to the ISP Router through the switch on the local network.

When configuring Static NAT according to the network topology, you need to define the local and external interfaces of Router. This is the most important point for Static NAT configuration on Cisco Router.

Before configuring Static NAT on Cisco Router with GNS3, create a network topology as in Step 1. Next, integrate a virtual machine on VMware Workstation into GNS3. For the network adapter in VMware virtual machine settings, select Ethernet if you are using a laptop and connect your computer to the ADSL modem otherwise you will not be able to configure Static NAT.

When using GNS3, do NAT configuration operations without selecting a WiFi card. Because the VMware virtual machine may not get the IP address from the DHCP server.

How to integrate VMware into GNS3? You can read “How to Integrate VMware with GNS3?” to answer the question…

[su_box title=”Our Recommendation” box_color=”#242424″ radius=”0″]

You can purchase “Cisco CCNA in 60 Days” from Amazon.

[/su_box]

How to Configure Static NAT in GNS3?

To configure Static NAT on Cisco Router with GNS3, follow the steps below in order.

   Step 1

Create the topology as shown the below image by opening the GNS3 for Static NAT configuration on GNS3.

How to Configure Static NAT on Cisco Router?

   Step 2

During the Static NAT configuration on Cisco Router, we will not give the Static IP address to Cisco Router’s interface. Because we will assign the IP address from DHCP to Router to better understand NAT on GNS3.

How to Configure Static NAT on Cisco Router?

   Step 3

According to the topology in the GNS3 program, you can use any virtual machine on VMware Workstation.

Configure the IP address settings of the virtual machine according to the network topology and then test the connection by pinging the FastEthernet interface of Cisco Router.

Pinging the FastEthernet 0/1 interface of Cisco Router from the Windows 10 virtual machine will succeed as follows.

How to Configure Static NAT on Cisco Router?

   Step 4

Because we used the DHCP command to assign the IP address of the FastEthernet 0/0 interface of Cisco Router, the IP address 192.168.1.103 was obtained from the DHCP server of the ADSL modem. Pinging the FastEthernet0/0 interface of Cisco Router from the Windows 10 virtual machine will succeed as follows.

How to Configure Static NAT on Cisco Router?

   Step 5

However, if we ping the Google DNS addresses from the Windows 10 virtual machine, the operation will fail.

How to Configure Static NAT on Cisco Router?

   Step 6

Now, open the Cisco Router CLI command prompt and execute the following commands to configure Static NAT.

R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address dhcp
R1(config-if)# no shutdown
R1(config-if)# ip nat outside
R1(config-if)# exit
R1(config)# interface fastethernet 0/1
R1(config-if)# ip address 192.168.8.1 255.255.255.0
R1(config-if)# ip nat inside
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# ip nat inside source static 192.168.8.10 192.168.1.50
R1(config)# ip name-server 192.168.1.1
R1(config)# ip domain-lookup
R1(config)# end
R1# copy running-config startup-config

 
When you ping the Google DNS server via Cisco Router, the result will be as follows.

How to Configure Static NAT on Cisco Router?

   Step 7

After applying the commands required to configure Static NAT on Cisco Router, if you ping the Google DNS server from Windows 10 virtual machine, you can see that the process is successful like in the following display.

How to Configure Static NAT on Cisco Router?

   Step 8

In Windows 10 Ip configuration, if you leave the DNS server section blank, the web page will not open when you type Google.com in the browser address line.

Open the IP address configuration of the Windows 10 virtual machine and type the IP address of the ADSL modem in the DNS section. If you try to access Google again, you will succeed.

How to Configure Static NAT on Cisco Router?

   Step 9

You can view Static NAT records on the Cisco Router with the show ip nat translation command. The show command outputs after accessing Google via the virtual machine is as follows.

You have seen that configuring Static NAT on Cisco Router using GNS3 is very easy. The following image shows how Static NAT works. The 192.168.8.10 IP address on the local network is translated to the 192.168.1.50 IP address on Cisco Router so that the virtual machine will access the internet.

How to Configure Static NAT on Cisco Router?

   Step 10

Occasionally, we may need to delete these NAT translations in the Cisco Router CLI console when we encounter problems in the network environment. If we want to delete the NAT records on Cisco Router, we can clear all translated Static NAT records using the clear ip nat translations * command in the Router’s privileged configuration mode.

How to Configure Static NAT on Cisco Router?

   Step 11

If you use the show ip nat translation command again in the privileged configuration mode, you will see that all NAT records are deleted as shown in the following image.

How to Configure Static NAT on Cisco Router?

   Step 12

For example, if we access Facebook.com, the Static NAT records of Cisco Router will match again.

How to Configure Static NAT on Cisco Router?

Cisco Router Static NAT Configuration Show Commands

[su_tabs active=”5″]
[su_tab title=”R1# show running-config”]

R1# show running-config
Building configuration...

Current configuration : 1050 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
ip name-server 192.168.1.1
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source static 192.168.8.10 192.168.1.50
!
no cdp log mismatch duplex
!
!
control-plane
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

[/su_tab]

[su_tab title=”R1#show ip nat statistics”]

R1#show ip nat statistics
Total active translations: 2 (1 static, 1 dynamic; 1 extended)
Outside interfaces:
FastEthernet0/0
Inside interfaces:
FastEthernet0/1
Hits: 7 Misses: 1
CEF Translated packets: 8, CEF Punted packets: 0
Expired translations: 0
Dynamic mappings:
Appl doors: 0
Normal doors: 0
Queued Packets: 0

[/su_tab]

[su_tab title=”R1#show ip nat translations”]

R1#show ip nat translations
Pro          Inside global            Inside local                       Outside local                   Outside global
icmp       192.168.1.50:1      192.168.8.10:1              8.8.8.8:1                              8.8.8.8:1
---            192.168.1.50           192.168.8.10                   ---                                             ---

[/su_tab]

[su_tab title=”R1#show ip nat translations”]

R1#show ip nat translations Pro Inside global Inside local Outside local Outside global tcp 192.168.1.50:49704 192.168.8.10:49704 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49705 192.168.8.10:49705 93.184.220.20:80 93.184.220.20:80 tcp 192.168.1.50:49706 192.168.8.10:49706 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49707 192.168.8.10:49707 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49708 192.168.8.10:49708 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49709 192.168.8.10:49709 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49710 192.168.8.10:49710 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49711 192.168.8.10:49711 31.13.92.36:443 31.13.92.36:443 tcp 192.168.1.50:49712 192.168.8.10:49712 31.13.92.36:443 31.13.92.36:443 tcp 192.168.1.50:49713 192.168.8.10:49713 93.184.220.29:80 93.184.220.29:80 tcp 192.168.1.50:49714 192.168.8.10:49714 31.13.92.36:443 31.13.92.36:443 tcp 192.168.1.50:49715 192.168.8.10:49715 31.13.92.36:443 31.13.92.36:443 tcp 192.168.1.50:49716 192.168.8.10:49716 93.184.220.29:80 93.184.220.29:80 tcp 192.168.1.50:49717 192.168.8.10:49717 31.13.93.7:443 31.13.93.7:443 tcp 192.168.1.50:49718 192.168.8.10:49718 31.13.93.7:443 31.13.93.7:443 tcp 192.168.1.50:49719 192.168.8.10:49719 31.13.93.10:443 31.13.93.10:443 tcp 192.168.1.50:49720 192.168.8.10:49720 31.13.93.10:443 31.13.93.10:443 tcp 192.168.1.50:49721 192.168.8.10:49721 207.46.101.29:80 207.46.101.29:80 udp 192.168.1.50:51647 192.168.8.10:51647 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:53083 192.168.8.10:53083 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:58578 192.168.8.10:58578 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:59312 192.168.8.10:59312 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:59671 192.168.8.10:59671 192.168.1.1:53 192.168.1.1:53 Pro Inside global Inside local Outside local Outside global udp 192.168.1.50:59896 192.168.8.10:59896 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:60946 192.168.8.10:60946 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:61739 192.168.8.10:61739 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:64596 192.168.8.10:64596 192.168.1.1:53 192.168.1.1:53 --- 192.168.1.50 192.168.8.10 --- ---

[/su_tab]

[su_tab title=”R1#show ip nat statistics”]

R1#show ip nat statistics
Total active translations: 2 (1 static, 1 dynamic; 1 extended)
Outside interfaces:
FastEthernet0/0
Inside interfaces:
FastEthernet0/1
Hits: 2735 Misses: 78
CEF Translated packets: 2699, CEF Punted packets: 227
Expired translations: 89
Dynamic mappings:
Appl doors: 0
Normal doors: 0
Queued Packets: 0
R1#

[/su_tab]
[/su_tabs]

How to Configure Static NAT on Cisco Router using GNS3? ⇒ Video

To configure Static NAT on GNS3, you can watch the video below and also subscribe to our YouTube channel to support us…

  Final Word

How to Configure Static NAT on Cisco Router in GNS3? – After completing the Cisco NAT configuration, we have looked at the show commands of Static NAT on the Cisco Router CLI console. Thanks for following us!

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to How to Configure Static NAT on Cisco Router

[su_box title=”Related Articles” box_color=”#242424″ radius=”0″]
♦ How to Configure Dynamic NAT on Cisco Router?
♦ How to Configure PAT NAT Overload on Cisco Router?
♦ How to Configure NAT with Cisco SDM on Cisco Router?
♦ How to Configure DHCP on Cisco Router in GNS3?
♦ Cisco Router SSH Configuration
[/su_box]

Products Related to How to Configure Static NAT on Cisco Router

[su_box title=”Related Products” box_color=”#242424″ radius=”0″]

[/su_box]

Articles Related to How to Configure Static NAT in GNS3

[su_box title=”Related Router IOS” box_color=”#242424″ radius=”0″]

You can download the c3725-adventerprisek9_ivs-mz.124-25a IOS image used in this article by clicking the button below.

c3725-adventerprisek9_ivs-mz.124-25a

[/su_box]

Add a Comment

Your email address will not be published. Required fields are marked *