How to Configure RIP Version 2 on Cisco Router in GNS3

In this article, we will configure the RIP Version 2 routing protocol on  Routers in the Graphical Network Simulator-3 software.

How to Configure RIP Version 2 on Cisco Router in GNS3

How to Configure RIPv2 on a Cisco Router with GNS3

RIP Version 2 (RIPv2) described in RFC 2453. This protocol version sends Multicast instead of Broadcast in routing table updates.

Multicast broadcast supports VLSM and CIDR so that different subnets can communicate with each other. It also prevents broadcast traffic by minimizing the use of private IP addresses.

In our previous articles, we have examined What is RIP Protocol and How to Configure RIP Routing. In this article, we will configure RIPv2 to communicate different networks on two Routers.

After defining the 192.168.5.0/24 network on Cisco Routers by separating it into two different networks, we will make the computers communicate on it using RIPv2.

You can also watch the GNS3 RIP V1 Configuration on our YouTube channel to configure RIP V1.

How to Configure RIPv2 in GNS3

Before proceeding with the steps to enable RIPv2 on the Cisco Router, see Using VPCS.

In this article, we will use VPCS (Virtual PC Simulator) in the RIP configuration.

Using VPCS instead of VMware virtual machine is more efficient!

   Step 1

After opening GNS3, create a new project.

Creating Projects in GNS3

   Step 2

Create the network topology for RIP V2 configuration as shown in the following image.

Network Topology with Two Cisco Routers in GNS3

   Step 3

Configure VPCSs in the GNS3 workspace according to the network topology, respectively. You can perform the following commands for VPCS PC1 IP address settings.

PC1> ip 192.168.5.5/25 192.168.5.1
Checking for duplicate address...
PC1 : 192.168.5.5 255.255.255.128 gateway 192.168.5.1

PC1> show ip

NAME : PC1[1]
IP/MASK : 192.168.5.5/25
GATEWAY : 192.168.5.1
DNS :
MAC : 00:50:79:66:68:00
LPORT : 10014
RHOST:PORT : 127.0.0.1:10015
MTU: : 1500
PC1>

 
Configuring VPCSs in GNS3

   Step 4

Configure the VPCS PC2 IP configuration.

PC2> ip 192.168.5.10/25 192.168.5.1
Checking for duplicate address...
PC1 : 192.168.5.10 255.255.255.128 gateway 192.168.5.1

PC2> show ip

NAME : PC2[1]
IP/MASK : 192.168.5.10/25
GATEWAY : 192.168.5.1
DNS :
MAC : 00:50:79:66:68:01
LPORT : 10016
RHOST:PORT : 127.0.0.1:10017
MTU: : 1500
PC2>

 
VPCS2 IP Assignment

   Step 5

Pay attention to the Subnet Mask when configuring the IP address for VPCS PC3.

PC3> ip 192.168.5.130/25 192.168.5.129
Checking for duplicate address...
PC1 : 192.168.5.130 255.255.255.128 gateway 192.168.5.129

PC3> show ip

NAME : PC3[1]
IP/MASK : 192.168.5.130/25
GATEWAY : 192.168.5.129
DNS :
MAC : 00:50:79:66:68:02
LPORT : 10018
RHOST:PORT : 127.0.0.1:10019
MTU: : 1500
PC3>

 
VPCS3 IP Assignment

   Step 6

Finally, configure the VPCS PC4 as follows.

PC4> ip 192.168.5.135/25 192.168.5.129
Checking for duplicate address...
PC1 : 192.168.5.135 255.255.255.128 gateway 192.168.5.129

PC4> show ip

NAME : PC4[1]
IP/MASK : 192.168.5.135/25
GATEWAY : 192.168.5.129
DNS :
MAC : 00:50:79:66:68:03
LPORT : 10020
RHOST:PORT : 127.0.0.1:10021
MTU: : 1500
PC4>

 
VPCS4 IP Assignment

   Step 7

Open the Cisco Router R1 CLI command prompt and configure the FastEthernet 0/0 and Serial 0/0 interfaces.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.128
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar 1 00:12:56.175: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:12:57.175: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#end
R1#

 
Check the configuration with the show ip route command on R1.

R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.5.1 YES manual up up
Serial0/0 10.1.1.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/1 unassigned YES unset administratively down down
R1#

 
show ip interface brief

   Step 8

In the same way, configure the Router R2 interfaces. Pay attention to the subnet mask of R2 in this step.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface fastethernet 0/1
R2(config-if)#ip address 192.168.5.129 255.255.255.128
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
*Mar 1 00:14:49.607: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar 1 00:14:50.607: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R2(config)#
R2(config)#interface serial 0/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#end
R2#

 
Check the interface configuration of Router R2 with the show ip interface brief command.

R2#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial0/0 unassigned YES unset administratively down down
FastEthernet0/1 192.168.5.129 YES manual up up
Serial0/1 10.1.1.2 YES manual up up
R2#

 
show ip interface brief

   Step 9

Check the connections with Ping via VPCS before activating the routing protocol.

Pinging from VPCS PC1 to Router R2 Serial interface will fail as follows.

Ping Process

   Step 10

The ping result of VPCS PC3 is as follows. On PC3, Router R1 will not be able to Ping the Serial interface.

Ping Process

   Step 11

To communicate with computers in two different locations, at the Router R1 prompt to enable RIPv2, perform the following commands.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.1.1.0
R1(config-router)#network 192.168.5.0
R1(config-router)#end
R1#

 
R1(config)#router rip

   Step 12

In the same way, enable RIPv2 on Router R2 and identify the networks to which it is connected.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.5.128
R2(config-router)#end
R2#

 
R2(config)#router rip

   Step 13

Now test the connection by pinging the VPCS PCs.

Pinging via PC1 to the R2 Serial interface will be successful. And as a result, PC1 will be able to successfully access the 192.168.5.128/25 network.

Network Testing with Ping

   Step 14

Pinging over PC3 on the remote network will also be successful as follows.

Network Testing with Ping

   Step 15

Run the show ip route command on Router R1 and browse the routing table.

show ip route

   Step 16

In the same way, execute the show ip route command on Router R2.

show ip route

   Step 17

On Router R2, execute the debug ip rip command to check the RIPv2 configuration and you will see a log as shown in the image below.

In this image, you can see that RIP V2 routing updates sent with the 224.0.09 Multicast address. You can also analyze traffic between routers better using the Wireshark program.

debug ip rip

   Step 18

You can also view the RIP V2 records on Router R2.

debug ip rip

   Step 19

You can use the Wireshark program to verify RIPv2.

Click on the Right-Click / Start Capture option on the serial link between R1 and R2 to examine the routing protocol.

Using Wireshark in GNS3

   Step 20

In the Packet Capture window, click OK.

Selecting the Interface to Analyze

   Step 21

Running the Wireshark program, you can view the RIP V2 (224.0.0.9) output from the image below.

In short, RIPv2 update packets sent between the two Routers with the Multicast address.

RIP V2 (224.0.0.9)

Show Commands

R1#show running-config
Building configuration...

Current configuration : 1106 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.128
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

 


R2#show running-config
Building configuration...

Current configuration : 1108 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.5.129 255.255.255.128
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.1.2 255.255.255.252
clock rate 2000000
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R2#

 


R1#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/30 directly connected, Serial0/0
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.2, 00:00:22, Serial0/0
192.168.5.0/25 directly connected, FastEthernet0/0
R1#

 


R2#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/30 directly connected, Serial0/1
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.1, 00:00:22, Serial0/1
192.168.5.128/25 directly connected, FastEthernet0/1
R2#

 


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/25 is directly connected, FastEthernet0/0
R 192.168.5.0/24 [120/1] via 10.1.1.2, 00:00:00, Serial0/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/0
R1#

 


R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:07, Serial0/1
C 192.168.5.128/25 is directly connected, FastEthernet0/1
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/1
R2#

 


R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar 1 00:24:22.779: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (10.1.1.1)
*Mar 1 00:24:22.779: RIP: build update entries
*Mar 1 00:24:22.779: 192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
R1#
*Mar 1 00:24:34.083: RIP: received v2 update from 10.1.1.2 on Serial0/0
*Mar 1 00:24:34.087: 192.168.5.0/24 via 0.0.0.0 in 1 hops
R1#
*Mar 1 00:24:36.891: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.5.1)
*Mar 1 00:24:36.891: RIP: build update entries
*Mar 1 00:24:36.891: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:24:36.891: 192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R1#
*Mar 1 00:24:48.759: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (10.1.1.1)
*Mar 1 00:24:48.759: RIP: build update entries
*Mar 1 00:24:48.759: 192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
R1#

 


R2#debug ip rip
RIP protocol debugging is on
R2#
*Mar 1 00:24:23.591: RIP: received v2 update from 10.1.1.1 on Serial0/1
*Mar 1 00:24:23.591: 192.168.5.0/24 via 0.0.0.0 in 1 hops
R2#
*Mar 1 00:24:33.427: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/1 (192.168.5.129)
*Mar 1 00:24:33.427: RIP: build update entries
*Mar 1 00:24:33.427: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:24:33.427: 192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R2#
*Mar 1 00:24:34.803: RIP: sending v2 update to 224.0.0.9 via Serial0/1 (10.1.1.2)
*Mar 1 00:24:34.803: RIP: build update entries
*Mar 1 00:24:34.803: 192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
R2#

 

How to Enable RIPv2 ⇒ Video

You can watch the video below to configure and verify the RIPv2 Routing protocol and also subscribe to our YouTube channel to support us!

   Final Word


In this article, we have communicated the 192.168.5.0/24 network separated by VLSM with RIPv2. If RIPv1 had used in this article, the networks here would not be able to communicate. Since version 2 of the Routing Information Protocol supports VLSM, we were able to communicate with the networks here. Thanks for following us!

   Related Articles


How to Add Router to GNS3 VM
How to Install GNS3 VM
How to Configure Port Security
How to Configure VLAN
How to Install GNS3 in Ubuntu

Add a Comment

Your email address will not be published. Required fields are marked *

shares
error: