How to Configure RIP Routing on Cisco Router in GNS3

RIP (Routing Information Protocol) is a routing protocol used to inform each other of networks that routers do not know.

How to Configure RIP Routing on Cisco Router in GNS3

How to Configure RIP (RIPv1) on a Router

The RIP routing protocol broadcasts between the routers with the address 255.255.255.255. And it also has Version 1 and Version 2 versions.

The RIPv1 broadcasts to an IP group. The other V2 version broadcasts with multicast address 224.0.0.9.

In our previous article, we discussed the Routing Information Protocol. In this article, we will enable the RIPv1 protocol on Routers in the GNS3 simulator.

How to Setup RIP in GNS3

Before configuring RIP routing protocol, create two virtual machines in VMware Workstation.

On VMware Virtual Network Editor, create VMnet, and then add Cloud to the workspace and make adjustments to integrate GNS3 and VMware virtual machines.

After you have completed the necessary steps, follow the steps below to activate RIP Version 1 (RIPv1) on the Routers.

   Step 1

First, open the GNS3 simulator and create a new project.

Creating a New Project on GNS3

   Step 2

Create a network topology for the configuration as in the following image.

A Network Topology with Two Cisco Routers

   Step 3

VMware VMnet1 is selected as the network card on the Windows 8.1 virtual machine. Here you can create and set any VMnet.

The important thing to note in this step is the IP address block of VMnets.

Windows 8.1 VMnet Settings

   Step 4

VMware Windows 10 virtual machine network card is selected as VMnet2.

Windows 10 VMnet Settings

   Step 5

In Virtual Network Editor, the IP address block of VMnet1 and VMnet2 is as follows.

After configuring the TCP/IP configuration of the virtual machines, run them.

VMware Virtual Network Editor

   Step 6

The IP address of the Windows 8.1 machine is 192.168.5.5/24.

Using ipconfig in Windows CMD

   Step 7

The IP address of the Windows 10 machine is 192.168.10.10/24.

Using ipconfig in Windows CMD

   Step 8

After setting up VMware with GNS3, open the CLI prompt of the Cisco Router R1 and configure the FastEthernet and Serial interfaces.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#do show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.5.1 YES manual up up
Serial0/0 10.1.1.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/1 unassigned YES unset administratively down down

 
Configuring the Interfaces of the Cisco Router R1

   Step 9

In the same way, configure the interfaces of the Cisco Router R2 as follows.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface fastethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial 0/1
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#do show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial0/0 unassigned YES unset administratively down down
FastEthernet0/1 192.168.10.1 YES manual up up
Serial0/1 10.1.1.2 YES manual up up
R2(config)#

 
Configuring Interfaces for Cisco Router R2

   Step 10

Before configuring the routing protocol, test the network connection by pinging the virtual computers to the Router interfaces to which they are connected.

Ping from the Windows 8.1 VM to the Fa0/0 and Serial0/0 interfaces of the Router R1 should be successful as follows.

Ping from Windows 8.1 to Windows 10

   Step 11

Test the connection by pinging the interfaces of the Cisco Router R2 to which the Windows 10 VM is connected.

Ping from Windows 10 to Windows 8.1

   Step 12

Ping from the Windows 8.1 VM to the Serial 0/1 interface of the Cisco Router R2 will fail. Because routers cannot know each other’s subnets without routing.

Ping 10.1.1.2

   Step 13

Ping from Windows 10 machine will also fail.

Ping 10.1.1.1

   Step 14

To activate RIPv1, open the CLI prompt of Router R1 and perform the following commands.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#router rip
R1(config-router)#network 10.1.1.0
R1(config-router)#network 192.168.5.0
R1(config-router)#end
R1#show ip route
Codes: C - connected, S - static, R - R-I-P, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.5.0/24 is directly connected, FastEthernet0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/0
R1#

 
R1(config)#router rip

   Step 15

Perform the following commands at the CLI prompt of Router R2.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#router rip
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.10.0
R2(config-router)#end
R2#show ip route
Codes: C - connected, S - static, R - R-I-P, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0/1
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:04, Serial0/1
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/1
R2#

 
R2(config)#router rip

   Step 16

After configuring RIPv1 on the routers, the virtual machines will be able to successfully Ping as follows.

Ping the Router's Interface

   Step 17

Pinging from Windows 10 machine will also succeed as follows.

Ping the Router's Interface

   Step 18

Check the routing records in the router R1 using the show ip rip database command.

show ip

   Step 19

In the same way, check the RIPv1 entries on Router R2.

show ip rip database

   Step 20

Execute the debug ip rip command in privileged configuration mode to review RIP Version 1 broadcast messages.

Debug ip command

   Step 21

Check RIPv1 broadcast messages on Router R2 …

255.255.255.255

Show Commands


R1#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/24 directly connected, Serial0/0
192.168.5.0/24 auto-summary
192.168.5.0/24 directly connected, FastEthernet0/0
192.168.10.0/24 auto-summary
192.168.10.0/24
[1] via 10.1.1.2, 00:00:20, Serial0/0
R1#

 


R2#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/24 directly connected, Serial0/1
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.1, 00:00:02, Serial0/1
192.168.10.0/24 auto-summary
192.168.10.0/24 directly connected, FastEthernet0/1
R2#

 


R1#debug ip rip
R-I-P protocol debugging is on
R1#
*Mar 1 00:18:36.167: R-I-P: received v1 update from 10.1.1.2 on Serial0/0
*Mar 1 00:18:36.167: 192.168.10.0 in 1 hops
R1#
*Mar 1 00:18:37.311: R-I-P: sending v1 update to 255.255.255.255 via Serial0/0 (10.1.1.1)
*Mar 1 00:18:37.311: R-I-P: build update entries
*Mar 1 00:18:37.311: network 192.168.5.0 metric 1
R1#
*Mar 1 00:18:40.159: R-I-P: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.5.1)
*Mar 1 00:18:40.159: R-I-P: build update entries
*Mar 1 00:18:40.159: network 10.0.0.0 metric 1
*Mar 1 00:18:40.159: network 192.168.10.0 metric 2
R1#
*Mar 1 00:19:03.235: R-I-P: received v1 update from 10.1.1.2 on Serial0/0
*Mar 1 00:19:03.239: 192.168.10.0 in 1 hops
R1#
*Mar 1 00:19:04.791: R-I-P: sending v1 update to 255.255.255.255 via Serial0/0 (10.1.1.1)
*Mar 1 00:19:04.791: R-I-P: build update entries
*Mar 1 00:19:04.791: network 192.168.5.0 metric 1
*Mar 1 00:19:05.731: R-I-P: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.5.1)
*Mar 1 00:19:05.731: R-I-P: build update entries
*Mar 1 00:19:05.731: network 10.0.0.0 metric 1

 


R2#debug ip rip
R-I-P protocol debugging is on
R2#
*Mar 1 00:18:31.063: R-I-P: sending v1 update to 255.255.255.255 via Serial0/1 (10.1.1.2)
*Mar 1 00:18:31.063: R-I-P: build update entries
*Mar 1 00:18:31.063: network 192.168.10.0 metric 1
R2#
*Mar 1 00:18:32.107: R-I-P: received v1 update from 10.1.1.1 on Serial0/1
*Mar 1 00:18:32.107: 192.168.5.0 in 1 hops
R2#
*Mar 1 00:18:34.803: R-I-P: sending v1 update to 255.255.255.255 via FastEthernet0/1 (192.168.10.1)
*Mar 1 00:18:34.803: R-I-P: build update entries
*Mar 1 00:18:34.803: network 10.0.0.0 metric 1
*Mar 1 00:18:34.803: network 192.168.5.0 metric 2
R2#
*Mar 1 00:18:58.323: R-I-P: sending v1 update to 255.255.255.255 via Serial0/1 (10.1.1.2)
*Mar 1 00:18:58.323: R-I-P: build update entries
*Mar 1 00:18:58.323: network 192.168.10.0 metric 1
R2#
*Mar 1 00:18:59.911: R-I-P: received v1 update from 10.1.1.1 on Serial0/1
*Mar 1 00:18:59.911: 192.168.5.0 in 1 hops
R2#
*Mar 1 00:19:04.307: R-I-P: sending v1 update to 255.255.255.255 via FastEthernet0/1 (192.168.10.1)
*Mar 1 00:19:04.307: R-I-P: build update entries
*Mar 1 00:19:04.307: network 10.0.0.0 metric 1
*Mar 1 00:19:04.307: network 192.168.5.0 metric 2
R2#

 


R1#show ip route rip
R 192.168.10.0/24 [120/1] via 10.1.1.2, 00:00:22, Serial0/0
R1#

 


R2#show ip route rip
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:06, Serial0/1
R2#

 


R1#show running-config
Building configuration...
Current configuration : 1091 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router rip
network 10.0.0.0
network 192.168.5.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

 


R2#show running-config
Building configuration...

Current configuration : 1093 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.1.2 255.255.255.0
clock rate 2000000
!
router rip
network 10.0.0.0
network 192.168.10.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end
R2#

 

How to Enable RIPv1 with GNS3 ⇒ Video

You can watch the video below for configuring and verifying RIPv1 on the Cisco Router and also subscribe to our YouTube channel to support us!

   Final Word


In this article, we have examined how to enable RIPv1 routing on Cisco Routers with Graphical Network Simulator-3 program.

The above configuration applies to RIPv1. With the RIPv2 version, you can communicate the network topologies that you have separated into subnets with VLSM. Thanks for following us!

   Related Articles


How to Configure Cisco Switch Basically
♦ Cisco Router Modes
♦ How to Add IOS to GNS3
How to Add L2 SW to GNS3
How to Add L3 SW to GNS3

Add a Comment

Your email address will not be published. Required fields are marked *

shares
error: