How to Configure Telnet in Cisco Packet Tracer?

How to Configure Telnet in Cisco Packet Tracer? – In this article, after creating a small network topology with the Cisco Packet Tracer program, we will make a Telnet connection to the Cisco Router on the local network.
How to Configure Telnet in Cisco Packet Tracer?

How to Configure Telnet in Cisco Packet Tracer?

You can easily prepare for Cisco exams using the Cisco Packet Tracer network simulator program. Using the Cisco Packet Tracer program, you can make the Telnet connection on the Cisco Router with a few commands.

The main benefit of enabling Telnet on the Cisco Router is that it does not require a permanent console connection to the Cisco Router. By this way, you can easily make a telnet connection to the Cisco Router over the LAN or WAN network.

In our previous articles, we reviewed How to Configure DHCP in Cisco Packet Tracer and How to Create a Basic Network in Cisco Packet Tracer. In this article, we will configure Telnet on the Cisco Router.

How to Enable Telnet on Cisco Router using Cisco Packet Tracer?

To configure Telnet in Cisco Packet Tracer, follow the steps below in order.

   Step 1

Add one Cisco Router, Cisco Switch, and PC to the Cisco Packet Tracer workspace. Then, cable all devices.

How to Configure Telnet in Cisco Packet Tracer?

   Step 2

For the Cisco Packet Tracer Telnet configuration, double-click Cisco Router1 to open the CLI command prompt and type No and press Enter to skip the initial configuration.

How to Configure Telnet in Cisco Packet Tracer?

   Step 3

To enable Telnet on Cisco Router, execute the following commands, respectively.

Router> enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface gigabitethernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#username cisco privilege 15 password cisco123
Router(config)#line vty 0 4
Router(config-line)#login local
Router(config-line)#privilege level 15
Router(config-line)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#wr
Building configuration...
[OK]
Router#

 
How to Configure Telnet in Cisco Packet Tracer?

   Step 4

After configuring the interfaces of Cisco Router, create a username and password for the Telnet connection. Before connecting to Cisco Router1, configure the TCP/IP configuration of Desktop1 in the workspace as follows.

How to Configure Telnet in Cisco Packet Tracer?

   Step 5

To connect to Cisco Router, click on Desktop1 and then on the Desktop tab, then click CMD Command Prompt.

At the CMD prompt, type telnet 192.168.1.1 and press Enter. After typing the username and password you created on Cisco Router, you can make a Telnet connection.

How to Configure Telnet in Cisco Packet Tracer?

   Step 6

After you connect to the Cisco Router, you can fully manage the Cisco Router. When you run the show line at the CMD command prompt, you can view the sessions on the Router.

How to Configure Telnet in Cisco Packet Tracer?

   Step 7

You can also see the sessions opened when you apply the show line command on Cisco Router.

How to Configure Telnet in Cisco Packet Tracer?

Show Running-Config Output Related to Configuring Telnet in Cisco Packet Tracer
[su_tabs active=”1″]
[su_tab title=”R1#show running-config”]

Router#show running-config
Building configuration...

Current configuration : 696 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
ip cef
no ipv6 cef
!
!
!
username cisco privilege 15 password 0 cisco123
!
!
license udi pid CISCO1941/K9 sn FTX15241Q66
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login local
privilege level 15
!
!
!
end
Router#

[/su_tab]
[/su_tabs]

[su_box title=”Our Recommendation” box_color=”#242424″ radius=”0″]

You can purchase “Cisco CCNA Book” from Amazon.

[/su_box]

How to Configure Telnet in Cisco Packet Tracer? ⇒ Video

To configure Telnet in Cisco Packet Tracer, you can watch the following video and also subscribe to our YouTube channel to support us.

  Final Word

In this article, we have reviewed how to configure Cisco Telnet connection step by step. To disable Telnet on Cisco Router, you can use the transport input ssh command (Only SSH) in line vty 0 4. Thanks for following us!

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to Configuring Telnet in Cisco Packet Tracer

[su_box title=”Related Articles” box_color=”#242424″ radius=”0″]
♦ How to Use Cisco Packet Tracer?
♦ How to Configure SSH in Cisco Packet Tracer?
♦ How to Configure VLAN on Cisco Switch?
♦ How to Configure Inter-VLAN Routing?
♦ How to Configure Static NAT in Cisco Packet Tracer?
[/su_box]

Products Related to Configuring Telnet in Cisco Packet Tracer

[su_box title=”Related Products” box_color=”#242424″ radius=”0″]

[/su_box]

Add a Comment

Your email address will not be published. Required fields are marked *