How to Configure Static NAT in Cisco Packet Tracer?

How to Configure Static NAT in Cisco Packet Tracer? – In this article, we will perform Static NAT configuration steps in the Cisco Packet Tracer network simulator program. We will connect the computers in the local network to the Internet by pairing them with Static NAT.
How to Configure Static NAT in Cisco Packet Tracer?

How to Configure Static NAT in Cisco Packet Tracer?

Static NAT translates specific IP addresses into global IP addresses. To configure Static NAT on the Cisco Router, we have to designate it as Internal network and External network according to the network design.

In the interface of Cisco Router for the local network, we must configure it as Ip NAT Inside. The Internet-connected interface of the Cisco Router is required to implement the Ip NAT Outside command.

1. Ip NAT Inside: This command specifies the interface as inside.

2. Ip NAT Outside: This command specifies the interface as outside.

Static NAT logic is only to access the specified IP addresses to the Internet. In our previous articles, we discussed information about Static NAT, Dynamic NAT, and NAT PAT.

Our Recommendation; You can purchase the book of Cisco Packet Tracer Network Simulator

How to Configure Static NAT in Cisco Router in Cisco Packet Tracer?

To configure Static NAT on Cisco Routers using Cisco Packet Tracer, follow the steps below.

   Step 1

First, open the Cisco Packet Tracer program and create the network topology as shown below. To better understand Static NAT, separate the sections of Inside and Outside and write a description.

Configure the interface that sends traffic to Internet from local network on the Cisco Router. In the following network topology, you can see the Gig0/0 interface of Cisco Router is the outside port.

How to Configure Static NAT in Cisco Packet Tracer?

   Step 2

Specify the IP blocks and click on the computers to assign the IP addresses and then configure their TCP/IP settings.

How to Configure Static NAT in Cisco Packet Tracer?

   Step 3

For the Static NAT configuration on Cisco Packet Tracer, click Router0 in the workspace and open the CLI command prompt. To configure Static NAT on the Cisco Router, execute the following commands, respectively.

Router# enable
Router(config)# interface gigabitethernet 0/0
Router(config-if)# ip address 10.0.0.1 255.255.255.252
Router(config-if)# ip nat outside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface gigabitethernet 0/1
Router(config-if)# ip address  192.168.10.1 255.255.255.0
Router(config-if)# ip nat inside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# ip nat inside source static 192.168.10.1 10.0.0.1
Router(config)# ip nat inside source static 192.168.20.1 10.0.0.1
Router(config)# end
Router# wr

 
Execute the (wr) command to save the Cisco Router Static NAT configuration. Assign the 10.0.0.2 Ip address to the Gig0/1 interface of Cisco Router0 and no shutdown the port.

How to Configure Static NAT in Cisco Packet Tracer?

   Step 4

We have completed the process to configure Static NAT in Cisco Packet Tracer. Now, ping to Router1 from the computers in the Packet Tracer workspace. Nat outputs will create on Cisco Router0.

At the Router CLI command prompt, execute the show ip nat translations command to see the NAT outputs.

How to Configure Static NAT in Cisco Packet Tracer?

How to Activate DHCP on Cisco Router in Packet Tracer? For the answer to the question, read the article called “How to Configure DHCP in Cisco Packet Tracer?“.

Show Commands Related to How to Configure Static NAT in Cisco Packet Tracer

[su_tabs active=”1″]
[su_tab title=”Router0#show ip nat translations”]

Router#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 10.0.0.1:3 192.168.10.20:3 10.0.0.2:3 10.0.0.2:3
icmp 10.0.0.1:4 192.168.10.20:4 10.0.0.2:4 10.0.0.2:4
icmp 10.0.0.1:5 192.168.10.20:5 10.0.0.2:5 10.0.0.2:5
icmp 10.0.0.1:6 192.168.10.20:6 10.0.0.2:6 10.0.0.2:6
--- 10.0.0.1 192.168.10.20 --- ---

[/su_tab]

[su_tab title=”Router0#show running-config”]

Router#show running-config
Building configuration...

Current configuration : 768 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524T6MD
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 10.0.0.1 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source static 192.168.10.10 10.0.0.1
ip nat inside source static 192.168.10.20 10.0.0.1
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

[/su_tab]

[su_tab title=”Router0#show ip nat statistics”]

Router#show ip nat statistics
Total translations: 3 (2 static, 1 dynamic, 3 extended)
Outside Interfaces: GigabitEthernet0/0
Inside Interfaces: GigabitEthernet0/1
Hits: 11 Misses: 12
Expired translations: 6
Dynamic mappings:

[/su_tab]

[su_tab title=”Router1#show running-config”]

Router#show running-config
Building configuration...

Current configuration : 619 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524B4CT
!
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 10.0.0.2 255.255.255.252
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

[/su_tab]
[/su_tabs]

How to create a VLAN on Cisco Switch? For the answer to the question, read the article called “How to Configure VLAN on Cisco Switch in Cisco Packet Tracer?“.

How to Configure Static NAT in Cisco Packet Tracer ⇒ Video

To configure Static NAT on Cisco Routers using Cisco Packet Tracer, you can watch the following video and also subscribe to our YouTube channel to support us…

  Final Word

How to Configure Static NAT in Cisco Packet Tracer? – In this article, we have configured Static NAT on Cisco Router using the Cisco Packet Tracer network simulator program to translate the Local IP addresses into the Global ISP IP addresses. Thanks for following us!

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to How to Configure Static NAT in Cisco Packet Tracer

[su_box title=”Related Articles” box_color=”#242424″ radius=”0″]
♦ How to Configure Inter-VLAN Routing in Cisco Packet Tracer?
♦ How to Configure Dynamic NAT in Cisco Packet Tracer?
♦ How to Configure NAT PAT in Cisco Packet Tracer?
♦ How to Configure Port Security in Cisco Packet Tracer?
♦ How to Copy IOS Image to TFTP Server in Cisco Packet Tracer?
[/su_box]

Products Related to How to Configure Static NAT in Cisco Packet Tracer

[su_box title=”Related Products” box_color=”#242424″ radius=”0″]

[/su_box]

Static NAT Configuration PKT File

[su_box title=”Related File” box_color=”#242424″ radius=”0″]

In this article, click the button below to download the Static NAT network project which is configured with Packet Tracer…

Download PKT File

[/su_box]

Add a Comment

Your email address will not be published. Required fields are marked *