How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer? – When configuring the Spanning Tree Protocol to prevent loops at the OSI Layer 2 layer, we also configure which Cisco Switches will be Root Bridge in our network topology.
How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer?

How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer?

When choosing Cisco switches on the network as the Root Bridge, we usually use the Priority command. In the previous article, we examined How to Configure Cisco Switch as Root Bridge in Cisco Packet Tracer. In this article, we will select the Root Bridge using the Root Primary command.

In addition to using Root Primary command, we will configure an auxiliary Root Bridge Switch when the Root Bridge Switch is not reachable. We can usually do this by changing the Priority value of a second Root Bridge Switch in the network distribution layer.

Our Recommendation

You can purchase “CCNP Switching” from Amazon.

How to Use Spanning Tree Primary Command?

Using the Cisco Packet Tracer program, we will select the Switch to be the Root Bridge by applying the Spanning Tree Vlan (Root Primary) command on a small network topology. With the Root Primary command, the Priority values of the Switches will be automatically set.

   Step 1

Open the Cisco Packet Tracer program and create a network topology as shown in the following image.

How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer?

   Step 2

Specify the Cisco Switches to be the Root Bridge and the Secondary Root Bridge.

How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer?

   Step 3

Open Switch SW1 CLI command prompt and execute the following command in config mode.

SW1>en
SW1#conf t
SW1(config)#
SW1(config)#spanning-tree vlan 1 root primary

 
How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer?

   Step 4

To verify that Switch SW1 is the root bridge, apply the show spanning-tree command on privileged mode.

SW1#show spanning-tree
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    24577
             Address     00D0.D331.E8B1
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24577  (priority 24576 sys-id-ext 1)
             Address     00D0.D331.E8B1
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/24           Desg FWD 19        128.24   P2p
Gi0/1            Desg FWD 4         128.25   P2p
Gi0/2            Desg FWD 4         128.26   P2p

SW1#

 
How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer?

As you can see from the show spanning-tree output above, the Cisco Switch SW1 is configured as a Root Bridge. We did this easily with the Spanning-Tree Vlan 1 Root Primary command without changing the Cisco Switch’s Priority value.

   Step 5

The use of the Cisco Switch Root Secondary command is also quite simple. To configure the switch you specified in the Packet Tracer network topology as Root Secondary, open the SW2 CLI command prompt and execute the following command.

SW2>en
SW2#conf t
SW2(config)#spanning-tree vlan 1 root secondary

 
How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer?

   Step 6

Run the show spanning-tree command at the Cisco Switch SW2 CLI command prompt.

SW2#show spanning-tree
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    24577
             Address     00D0.D331.E8B1
             Cost        4
             Port        25(GigabitEthernet0/1)
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    28673  (priority 28672 sys-id-ext 1)
             Address     00E0.F963.95C8
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/24           Desg FWD 19        128.24   P2p
Fa0/10           Desg FWD 19        128.10   P2p
Gi0/1            Root FWD 4         128.25   P2p
Gi0/2            Desg FWD 4         128.26   P2p

SW2#

 
How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer?

From the above display, you can see that the Cisco Switch SW2’s Priority value is set automatically.

   Step 7

When you apply for the show running-config command on both Cisco Switches configured, you can see that the priority of the switches by using the Root Primary and Root Secondary commands changed automatically.

How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer?

Show Commands Related to How to Select Root Bridge Using Root Primary Command

SW1#show running-configSW2#show running-config
SW1#show running-config
Building configuration…

Current configuration : 1109 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW1
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1 priority 24576
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
end

SW1#

SW2#show running-config
Building configuration…

Current configuration : 1109 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1 priority 28672
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
end

SW2#

How to Use Root Primary and Root Secondary in Packet Tracer? ⇒ Video

Using the Cisco Packet Tracer program, you can perform Spanning Tree Root Primary and Root Secondary configuration steps on Cisco switches by following the video below, and you can also subscribe to our YouTube channel to support us …

  Final Word 

How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer? – In this article, we examined the manual Cisco Switch Root Bridge configuration steps on the Cisco Packet Tracer. In more advanced network topologies, you need to fine-tune the Priority values of the Switches.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer
Products Related to How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer
Related Products

File Related to How to Select Root Bridge Using Root Primary Command in Cisco Packet Tracer
Related File

You can download the Packet Tracer PKT file configured in this article to your computer…

Leave a Reply

Your email address will not be published. Required fields are marked *

fourteen − 5 =