How to Configure Static Routing in Cisco Packet Tracer? – In this article, we will communicate with Static Routing the computers on two different networks using Cisco Packet Tracer.
How to Configure Static Routing in Cisco Packet Tracer?

How to Configure Static Routing in Cisco Packet Tracer?

How to Configure Static Routing in Cisco Packet Tracer?

Static Routing is a routing protocol used to establish two different subnets used on the Routers. Configuring Static Routing on Cisco Routers is simple. But it is important to you understand the logic of Static Routing.

There are 2 types of routing. These;

1. Static Routing
2. Dynamic Routing

In this article, we will explain what is Static Routing and how Static Routing works, then we will configure to communicate the computers in a small network environment.

If the network environment consists of several routers, it is recommended to use Static Routing for routing. Routers are slower in performance when configuring with Dynamic Routing. However, in a small network environment, you can use Static Routing to make Routers work more efficiently.

In the Static Routing process, you have to configure everything manually. In dynamic routes, only the connected network addresses specify and the network information share between the Routers by exchanging packets.

Static Routing is a difficult process to use in a growing network. Instead, Dynamic Routing is used by administrators.

In this article, we will outline the Static Routing configuration steps on Cisco Routers on the Cisco Packet Tracer.

Our Recommendation

You can purchase “CCNA Routing and Switching” from Amazon.

How to Configure Static Routing on Cisco Router using Cisco Packet Tracer?

We can now move on to configure Static Routing on Cisco Packet Tracer. To configure Static Routing on Cisco Routers step by step, follow the steps below.

   Step 1

Open the Cisco Packet Tracer program and create the network topology as shown in the following image. Once you have made the necessary configurations, assign IP addresses to the computers.

You can check out how to use Cisco Packet Tracer to make simple settings.

How to Configure Static Routing in Cisco Packet Tracer?

   Step 2

To configure the GigabitEthernet and Serial interfaces of Cisco Router R1, open the R1 CLI command prompt and execute the following commands.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#
R1(config)#interface gigabitethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#
R1(config)#interface serial0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#

 
How to Configure Static Routing in Cisco Packet Tracer?

   Step 3

Likewise, configure the GigabitEthernet and Serial interfaces of Cisco Router R2 by running the executing commands.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#
R2(config)#interface gigabitethernet 0/0
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R2(config-if)#exit
R2(config)#
R2(config)#interface serial 0/1/0
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
R2(config-if)#end
R2#

 
How to Configure Static Routing in Cisco Packet Tracer?

   Step 4

Before configuring Static Routing on Cisco Routers, ping from PC0 to the default gateway and the Serial interface of R1. The ping process is successful as follows.

How to Configure Static Routing in Cisco Packet Tracer?

   Step 5

Likewise, if you ping the Serial interface of Cisco Router R2 from the PC1, the ping will succeed as follows.

How to Configure Static Routing in Cisco Packet Tracer?

   Step 6

To better understand Static Routing, ping from PC0 to the R2 Serial interface and the computer on the inside network. Ping will fail as shown below.

How to Configure Static Routing in Cisco Packet Tracer?

   Step 7

In the same way, ping to the 192.168.5.0/24 network and the Serial interface of Cisco Router R1 from PC1. The ping operation will fail as shown below.

How to Configure Static Routing in Cisco Packet Tracer?

   Step 8

Ping interfaces to test connectivity between Cisco Routers. Routers will be able to communicate among themselves.

How to Configure Static Routing in Cisco Packet Tracer?

   Step 9

Pinging from R2 to R1 is also successful.

How to Configure Static Routing in Cisco Packet Tracer?

   Step 10

I hope you understand everything until this stage. Now, for the Static Routing configuration on Cisco Router R1, open the CLI command prompt and execute the following command.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ip route 192.168.10.0 255.255.255.0 10.1.1.2
R1(config)#exit
R1#

 
How to Configure Static Routing in Cisco Packet Tracer?

After configuring Static Routing on Cisco Router R1, execute the show ip route command. At the output of the Show command, you can see that the Static Routing configuration is defined in the S 192.168.10.0/24 [1/0] via 10.1.1.2 line.

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, GigabitEthernet0/0
L 192.168.5.1/32 is directly connected, GigabitEthernet0/0
<strong>S 192.168.10.0/24 [1/0] via 10.1.1.2</strong>
R1#

 
S    192.168.10.0/24 [1/0] via 10.1.1.2PC0 will reach the 192.168.10.0/24 network environment via the 10.1.1.2 IP address.

   Step 11

For Static Routing configuration on Cisco Router R2, execute the following command.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#ip route 192.168.5.0 255.255.255.0 10.1.1.1
R2(config)#
R2(config)#exit
R2#

 
How to Configure Static Routing in Cisco Packet Tracer?

Examine the output of the show ip route command on Cisco Router R2.

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/0
L 10.1.1.2/32 is directly connected, Serial0/1/0
<strong>S 192.168.5.0/24 [1/0] via 10.1.1.1</strong>
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/0
L 192.168.10.1/32 is directly connected, GigabitEthernet0/0
R2#

 
S    192.168.5.0/24 [1/0] via 10.1.1.1 PC1 will reach the 192.168.5.0/24 network environment with the 10.1.1.1 IP address.

   Step 12

After completing the steps of configuring Static Routing in Cisco Packet Tracer, test the connection by pinging to PC1 from PC0. Separate networks at two different locations communicate successfully with each other.

How to Configure Static Routing in Cisco Packet Tracer?

   Step 13

Similarly, if you ping to PC0 from PC1, you can see that there is a connection as follows.

How to Configure Static Routing in Cisco Packet Tracer?

Show Commands Related to How to Configure Static Routing in Cisco Packet Tracer

R1#show running-configR2#show running-config
R1#show running-config
Building configuration...

Current configuration : 813 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX152494BG
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.0
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.10.0 255.255.255.0 10.1.1.2
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
R1#
R2#show running-config
Building configuration...

Current configuration : 793 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524GA8Z
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.2 255.255.255.0
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.5.0 255.255.255.0 10.1.1.1
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

How to Configure Static Routing in Cisco Packet Tracer? ⇒ Video

To configure Static Routing on Cisco Routers using Cisco Packet Tracer, you can watch the following video. You can also subscribe to our YouTube channel to support us…

  Final Word

How to Configure Static Routing in Cisco Packet Tracer? – In this article, we have configured Static Routing to communicate computers on two different networks on Cisco Routers. Thanks for following us!

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure Static Routing in Cisco Packet Tracer

Products Related to How to Configure Static Routing in Cisco Packet Tracer
Related Products


File Related to How to Configure Static Routing in Cisco Packet Tracer
Related File

You can download the network topology configured in this article to your computer from the following button…

Download PKT File

Leave a Reply

Your email address will not be published. Required fields are marked *

ten − 2 =