How to Configure Static NAT in Cisco Packet Tracer? – In this article, we will perform Static NAT configuration steps in the Cisco Packet Tracer network simulator program. We will extract the computers in the local network to the Internet by pairing them with Static NAT.
How to Configure Static NAT in Cisco Packet Tracer?

How to Configure Static NAT in Cisco Packet Tracer?

How to Configure Static NAT in Cisco Packet Tracer?

Static NAT translates specific IP addresses into global IP addresses. To configure Static NAT on the Cisco Router, we have to designate it as Internal network and External network according to the network design. In the Cisco Router interface for the local network, we must configure it as Ip NAT Inside. The Internet-connected interface of the Cisco Router is required to implement the Ip NAT Outside command.

1. Ip NAT Inside: This command specifies the interface as inside.

2. Ip NAT Outside: This command specifies the interface as outside.

Static NAT logic is only to access the specified IP addresses to the Internet. In our previous articles, we gave information about Static NAT, Dynamic NAT, and NAT PAT.

Our Recommendation; You can purchase the book of Cisco Packet Tracer Network Simulator

How to Configure Static NAT in Cisco Router in Packet Tracer?

We can now pass on to how to configure static NAT on Cisco Router in Packet Tracer.

   Step 1

First, open the Packet Tracer program and create the network topology as shown below. To better understand Static NAT, separate the sections of Inside and Outside and write a description.

On the Cisco Router, configure the interface that sends traffic to the Internet to Outside. In the image below, the interface that sends traffic to the Internet is Gig0/0.

How to Configure Static NAT in Cisco Packet Tracer?

   Step 2

Specify the IP blocks and click on it to give the IP addresses to the computers and then configure the Ip Configuration.

How to Configure Static NAT in Cisco Packet Tracer?

   Step 3

For the Cisco Packet Tracer Static NAT configuration, click Router0 in the workspace and open the CLI command prompt. To configure Static NAT on the Cisco Router, apply the following commands, respectively.

Router# enable
Router(config)# interface gigabitethernet 0/0
Router(config-if)# ip address 10.0.0.1 255.255.255.252
Router(config-if)# ip nat outside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface gigabitethernet 0/1
Router(config-if)# ip address  192.168.10.1 255.255.255.0
Router(config-if)# ip nat inside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# ip nat inside source static 192.168.10.1 10.0.0.1
Router(config)# ip nat inside source static 192.168.20.1 10.0.0.1
Router(config)# end
Router# wr

Apply the (wr) command to save the Cisco Router Static NAT configuration. Give the 10.0.0.2 Ip address to the Cisco Router0 gig0/1 interface and activate the port.

How to Configure Static NAT in Cisco Packet Tracer?

   Step 4

We have completed the process to configure Static NAT in Cisco Packet Tracer. Now, ping Router1 from the computers in the Packet Tracer workspace. NAT registers will be created on Cisco Router0.

At the Router CLI command prompt, run the show ip nat translations command to see the NAT records.

How to Configure Static NAT in Cisco Packet Tracer?

How to activate DHCP on Cisco Router in Packet Tracer? For the answer to the question, read the article called “How to Configure DHCP in Cisco Packet Tracer?“.

Show Commands Related to How to Configure Static NAT in Cisco Packet Tracer

Router0#show ip nat translationsRouter0#show running-config Router0#show ip nat statistics Router1#show running-config

Router#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 10.0.0.1:3 192.168.10.20:3 10.0.0.2:3 10.0.0.2:3
icmp 10.0.0.1:4 192.168.10.20:4 10.0.0.2:4 10.0.0.2:4
icmp 10.0.0.1:5 192.168.10.20:5 10.0.0.2:5 10.0.0.2:5
icmp 10.0.0.1:6 192.168.10.20:6 10.0.0.2:6 10.0.0.2:6
— 10.0.0.1 192.168.10.20 — —

Router#show running-config
Building configuration…

Current configuration : 768 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524T6MD
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 10.0.0.1 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source static 192.168.10.10 10.0.0.1
ip nat inside source static 192.168.10.20 10.0.0.1
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

Router#show ip nat statistics
Total translations: 3 (2 static, 1 dynamic, 3 extended)
Outside Interfaces: GigabitEthernet0/0
Inside Interfaces: GigabitEthernet0/1
Hits: 11 Misses: 12
Expired translations: 6
Dynamic mappings:

Router#show running-config
Building configuration…

Current configuration : 619 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524B4CT
!
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 10.0.0.2 255.255.255.252
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

How to create a VLAN on Cisco Switch? For the answer to the question, read the article called “How to Configure VLAN on Cisco Switch in Cisco Packet Tracer?“.

How to Configure Static NAT in Cisco Packet Tracer ⇒ Video

You can follow the steps of configuring Static NAT in Cisco Packet Tracer, and you can also subscribe to our YouTube channel…

  Final Word

How to Configure Static NAT in Cisco Packet Tracer? – We have basically performed the Static NAT steps on the Packet Tracer. In the next article, we will perform the Dynamic NAT and the PAT configuration.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to How to Configure Static NAT in Cisco Packet Tracer;


Products Related to How to Configure Static NAT in Cisco Packet Tracer;

Leave a Reply

Your email address will not be published. Required fields are marked *

four × 3 =