How to Configure SSH in Cisco Packet Tracer? – SSH (Secure Shell) provides secure management of network devices. The SSH protocol establishes a secure connection to a network device to which you have access and prevents your connection from being accessed by malicious users.
How to Configure SSH in Cisco Packet Tracer?

How to Configure SSH in Cisco Packet Tracer?

How to Configure SSH in Cisco Packet Tracer?

The Cisco Packet Tracer SSH connection is a very secure protocol according to telnet connection. The SSH protocol uses the TCP 22 port by default. The default port numbers, you can change.

Before configuring the SSH connection on the Cisco Router, there are two versions of the SSH protocol. These versions are Version 1 and Version 2. SSH V2 offers a more secure connection than V1, and the most widely used version is Version 2. It is recommended that you enable SSH V2 as much as possible for remote management of Cisco network devices or other network devices.

In the process to configure SSH in Cisco Packet Tracer, Cisco Router IOS is the default and supports many features. However, in the real scenario, the Cisco Router IOS must support SSH connectivity. Otherwise, you can not configure SSH on the Cisco Router.

To enable Cisco Router SSH in the real scenario, make sure that your Cisco IOS software includes the k9 (crypto) phrase in the file name.

In the previous articles, we explained how to configure Telnet in Cisco Packet Tracer and how to connect to Cisco Router console in Cisco Packet Tracer. In this article, we will learn how to enable and configure SSH in Cisco Packet Tracer.

Our Recommendation; You can purchase the training DVD of Cisco 100-101 (ICND1) Exam created by InfiniteSkills.

How to Enable SSH on Cisco Router in Cisco Packet Tracer?

We can now pass the steps to enable SSH on the Cisco Router in the Cisco Packet Tracer. First, run the Packet Tracer program and then create a network topology as shown below.

   Step 1

In the following topology, there is a Cisco Router connected to the switch. The reason for adding the Cisco Router to the network topology is to implement the SSH connection through the Cisco Router. In short, we will make an SSH connection from the Router to the Router.

How to Configure SSH in Cisco Packet Tracer?

   Step 2

Open the CLI command prompt by clicking once on the Cisco Router, which is called SYSNETTECH, and continue by typing No to bypass the initial configuration.

How to Configure SSH in Cisco Packet Tracer?

   Step 3

In order to configure SSH in Cisco Packet Tracer, apply the following commands in order.

[code] Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname SYSNETTECH
SYSNETTECH(config)#interface gigabitethernet 0/0
SYSNETTECH(config-if)#ip address 192.168.1.1 255.255.255.0
SYSNETTECH(config-if)#no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
SYSNETTECH(config-if)#exit
SYSNETTECH(config)#ip domain name sysnettechsolutions.com
SYSNETTECH(config)#crypto key generate rsa
<span style="color: #00ff00;">The name for the keys will be: SYSNETTECH.sysnettechsolutions.com
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.
How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable…[OK] SYSNETTECH(config)#ip ssh version 2
*Mar 1 0:6:12.698: %SSH-5-ENABLED: SSH 1.99 has been enabled</span>
SYSNETTECH(config)#ip ssh time
SYSNETTECH(config)#ip ssh time-out 10
SYSNETTECH(config)#ip ssh authentication-retries 3
SYSNETTECH(config)#line vty 0 4
SYSNETTECH(config-line)#login local
SYSNETTECH(config-line)#privilege level 15
SYSNETTECH(config-line)#trans
SYSNETTECH(config-line)#transport input ssh
SYSNETTECH(config-line)#exit
SYSNETTECH(config)#username cisco privilege 15 password cisco123
SYSNETTECH(config)#end
SYSNETTECH#wr
Building configuration…
[OK] SYSNETTECH#
[/code]

How to Configure SSH in Cisco Packet Tracer?

   Step 4

After enabling SSH on the Cisco Router, configure the PC1 IP address settings as shown in the following image.

How to Configure SSH in Cisco Packet Tracer?

   Step 5

To quickly configure the interface of the Cisco Router named R1, configure the Port Status in the GigabitEthernet0/0 interface on the Config tab to On.

How to Configure SSH in Cisco Packet Tracer?

   Step 6

Open the command prompt on the PC1 computer, and then type the following command and press Enter to make an SSH connection to the Cisco Router.

[code]ssh -l cisco 192.168.1.1[/code]

-l: It means login.
Cisco: The username to be used to perform an SSH connection on the router.
192.168.1.1: Cisco Router IP address.

How to Configure SSH in Cisco Packet Tracer?

   Step 7

You will be prompted for a password if you press Enter. We had done the password as cisco123. After we entered the password, we successfully performed to configure SSH in Cisco Packet Tracer.

How to Configure SSH in Cisco Packet Tracer?

   Step 8

At the command prompt, after applying the show ssh command, we can see the running version of SSH in the following image.

How to Configure SSH in Cisco Packet Tracer?

   Step 9

In this step, you must execute the following command for the SSH connection from the Cisco Router to the Cisco Router. This command is identical to the command we connected with PC1. This step is meant to show that Router also works like any computer.

[code]ssh -l cisco 192.168.1.1[/code]

How to Configure SSH in Cisco Packet Tracer?

   Step 10

On the Cisco Packet Tracer SSH connection, type the password for the SSH connection to the router and press the Enter key.

How to Configure SSH in Cisco Packet Tracer?

   Step 11

An SSH connection successfully made from the Cisco Router to the Cisco Router.

How to Configure SSH in Cisco Packet Tracer?

For the DHCP configuration on Cisco Router in Packet Tracer, read the article called “How to Configure DHCP in Cisco Packet Tracer?“.

Show Commands Related to How to Configure SSH in Cisco Packet Tracer

SYSNETTECH#show running-configSYSNETTECH#show sshSYSNETTECH#show ip ssh

SYSNETTECH#show running-config
Building configuration…

Current configuration : 799 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SYSNETTECH
!
!
!
no ip cef
no ipv6 cef
!
!
!
username cisco privilege 15 password 0 cisco123
!
!
license udi pid CISCO1941/K9 sn FTX152488GK
!
!
ip ssh version 2
ip ssh time-out 10
ip domain-name sysnettechsolutions.com
!
!
spanning-tree mode pvst
!
!
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login local
transport input ssh
privilege level 15
!
!
end
SYSNETTECH#

SYSNETTECH#show ssh
Connection Version Mode Encryption Hmac State Username
133 1.99 IN aes128-cbc hmac-sha1 Session Started cisco
133 1.99 OUT aes128-cbc hmac-sha1 Session Started cisco
133 1.99 IN aes128-cbc hmac-sha1 Session Started cisco
133 1.99 OUT aes128-cbc hmac-sha1 Session Started cisco
%No SSHv1 server connections running.
SYSNETTECH#

SYSNETTECH#show ip ssh
SSH Enabled – version 2.0
Authentication timeout: 10 secs; Authentication retries: 3
SYSNETTECH#

How to Configure SSH in Cisco Packet Tracer ⇒ Video

You can watch how to configure ssh in Cisco Packet Tracer and subscribe to our YouTube channel…

  Final Word

How to Configure SSH in Cisco Packet Tracer? – SSH connection is always a secure protocol according to Telnet connection. Wherever possible, we recommend using the SSH protocol. Also, make sure you have the k9 (crypto) feature of your Cisco IOS in the real scenario.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to How to Configure SSH in Cisco Packet Tracer

Products Related to How to Configure SSH in Cisco Packet Tracer
Related Products

Leave a Reply

Your email address will not be published. Required fields are marked *

one × 1 =