How to Configure RIP Version 2 in Cisco Packet Tracer? – There are 2 versions of the RIP Routing protocol. RIP Version 1 makes routing table updates as Broadcast (255.255.255.255). RIP Version 2 is broadcasting Multicast.
How to Configure RIP Version 2 in Cisco Packet Tracer?

How to Configure RIP Version 2 in Cisco Packet Tracer?

How to Configure RIP Version 2 in Cisco Packet Tracer?

We reviewed the configuration of the version 1 of the RIP Routing protocol in the article called how to configure RIP Routing in Cisco Packet Tracer. In this article, we will configure the RIP Version 2 (V2).

RIP Version 2 defined in RFC 2453. You can also watch the RIP V1 configuration by watching the video…

RIP Version 2 sends the routing table updates as Multicast. RIP Version 1 does not support VLSM and CIDR. RIP Version 2 supports VLSM and CIDR.

So when configuring RIPV1, all devices need to be on the same network. There is no such requirement in RIP Version 2. With RIP V2, we can use private network addresses more efficiently.

Our Recommendation

You can purchase “Routing and Switching Complete Study Guide” from Amazon.

How to Enable RIP Version 2 on Cisco Router in Packet Tracer?

We can move on to how to enable RIP Version 2 on Cisco Router in Packet Tracer. We will configure the RIP Version 2 configuration by splitting the 192.168.5.0/24 IP block between the two Cisco Routers into 2 different networks.

For RIP Version 2 configuration, follow these steps in order.

   Step 1

Open the Cisco Packet Tracer program and create the network topology as shown in the following image. Note the IP address blocks here. IP addresses and subnet masks will be different between the two routers.

The IP block of the serial connection between the Cisco Router R1 and R2 is 10.1.1.0/30 – 255.255.255.252.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 2

Open the Cisco Router R1 CLI command prompt and configure the GigabitEthernet and Serial interfaces. You can do this by following the commands below.

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface gigabitethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.128
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#ex
R1(config)#interface serial 0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#end
R1#

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 3

Also, configure the Cisco Router R2 interfaces. Within this process, you can apply the following commands.

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface gigabitethernet 0/1
R2(config-if)#ip address 192.168.5.129 255.255.255.128
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R2(config-if)#exit
R2(config)#interface serial 0/1/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
R2(config-if)#end
R2#

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 4

Test the 192.168.5.0/25 – 255.255.255.128 network by pinging from PC1. Ping from PC1 to PC2 and R1 Serial 0/1/0 interface to test the connection.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 5

Ping process from PC1 to Cisco Router R2 Serial and GigabitEthernet interfaces will fail. Because the RIP V2 routing protocol is not enabled on Cisco Routers.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 6

Perform the above steps in the same way on PC3 of 192.168.5.128/25 network.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 7

Ping from the PC3 to the Cisco Router R1 Serial and GigabitEthernet interfaces will fail as follows.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 8

To configure RIP Version in Cisco Packet Tracer, click on Cisco Router R1 and execute the following commands at the CLI prompt.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.1.1.0
R1(config-router)#network 192.168.5.0
R1(config-router)#end
R1#

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 9

Activate RIP Version 2 on Cisco Router R2 and identify the networks connected to the Router. Here, notice the network 192.168.5.128.

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.5.128
R2(config-router)#end
R2#

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 10

After configuring RIP Version 2 on the Cisco Packet Tracer, perform the failed ping steps on PC1 again. This time the ping will succeed as follows.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 11

Provide the correctness of the connection by performing the same operations via PC3.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 12

You can examine the RIP Route records by executing the show ip route command on Router R1.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 13

Router R2 RIP Route records are as follows.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 14

To verify RIP Version 2 on Cisco Routers, you can see how routing updates make by applying the debug ip rip command.

In the image below, you can see that RIP V2 updated with 224.0.0.9 Multicast address.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 15

Cisco Router R2 routing updates are also as follows.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 16

Another way to verify RIP Version 2 is to use the show ip protocols command. Run this command on R1 and you can see that RIP Version 2 is used in the output.

How to Configure RIP Version 2 in Cisco Packet Tracer?

   Step 17

Likewise, you can also see the results by running the show ip protocols command on Router R2.

How to Configure RIP Version 2 in Cisco Packet Tracer?

Show Commands Related to How to Configure RIP Version 2 in Cisco Packet Tracer

R1#show ip routeR2#show ip routeR1#debug ip ripR2#debug ip ripR1#show ip protocolsR2#show ip protocolsR1#show running-configR2#show running-config
R1#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 3 subnets, 3 masks
R 192.168.5.0/24 [120/1] via 10.1.1.2, 00:00:26, Serial0/1/0
C 192.168.5.0/25 is directly connected, GigabitEthernet0/0
L 192.168.5.1/32 is directly connected, GigabitEthernet0/0
R1#

R2#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/1
L 10.1.1.2/32 is directly connected, Serial0/1/1
192.168.5.0/24 is variably subnetted, 3 subnets, 3 masks
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:04, Serial0/1/1
C 192.168.5.128/25 is directly connected, GigabitEthernet0/1
L 192.168.5.129/32 is directly connected, GigabitEthernet0/1
R2#

R1#debug ip rip
RIP protocol debugging is on
R1#RIP: sending v2 update to 224.0.0.9 via Serial0/1/0 (10.1.1.1)
RIP: build update entries
192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/0 (192.168.5.1)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R1#
R2#debug ip rip
RIP protocol debugging is on
R2#RIP: sending v2 update to 224.0.0.9 via Serial0/1/1 (10.1.1.2)
RIP: build update entries
192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/1 (192.168.5.129)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R2#
R1#show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 13 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/1/0 2 2
GigabitEthernet0/0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.2 120 00:00:02
Distance: (default is 120)
R1#
R2#show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 27 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/1/1 2 2
GigabitEthernet0/1 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.1 120 00:00:14
Distance: (default is 120)
R2#
R1#show running-config
Building configuration…
Current configuration : 834 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524GC61
!
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.128
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R1#
R2#show running-config
Building configuration…
Current configuration : 816 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX15241561
!
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.5.129 255.255.255.128
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 10.1.1.2 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

How to Configure RIP Version 2 in Cisco Packet Tracer? ⇒ Video

You can watch how to configure RIP Version 2 in Cisco Packet Tracer and also subscribe to our YouTube channel…

  Final Word

How to Configure RIP Version 2 in Cisco Packet Tracer? – In this article, we have implemented the RIP Version 2 configuration steps. We have seen that RIP Version 2 broadcasts Multicast (224.0.0.9).

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure RIP Version 2 in Cisco Packet Tracer

Products Related to How to Configure RIP Version 2 in Cisco Packet Tracer
Related Products

PKT File Related to How to Configure RIP Version 2 in Cisco Packet Tracer
Related PKT File

You can download the PKT file related to how to configure RIP Version 2 in Cisco Packet Tracer to your computer by clicking the button below.

Leave a Reply

Your email address will not be published. Required fields are marked *