How to Configure RIP Routing in Cisco Packet Tracer?RIP protocol is a routing protocol used in Routers. Configuring RIP routing protocol in Routers is simple and easy.
How to Configure RIP Routing in Cisco Packet Tracer?

How to Configure RIP Routing in Cisco Packet Tracer?

How to Configure RIP Routing in Cisco Packet Tracer?

RIP (Routing Information Protocol) is a widely used distance vector routing protocol supported by most routers. In other words, RIP is a Dynamic Routing Protocol.

In our previous article, we discussed that what is RIP Protocol in networking. In this article, we will implement the steps to configure RIP Routing in Cisco Packet Tracer.

To configure RIP on Cisco routers, the Router Rip command is used in global configuration mode. Then, the network addresses connected to the Cisco Router are defined for RIP in configuration mode.

Our Recommendation

You can purchase “Cisco Networking Essentials” from Amazon.

How to Configure RIP in Cisco Packet Tracer?

In this article, we will configure RIP Version 1. Follow the steps below for configuring RIP Routing on Cisco Router in the Cisco Packet Tracer.

   Step 1

Open the Cisco Packet Tracer program and create a network topology as shown in the following illustration. Assign the IP address to the computers you added to the workspace and then plug in all the devices.

Also, you can browse the use of Cisco Packet Tracer.

How to Configure RIP Routing in Cisco Packet Tracer?

   Step 2

Assign the IP address to the Serial Interface and GigabitEthernet Interface of Cisco Router R1.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface serial 0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#exit
R1(config)#interface gigabitethernet 0/1
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R1(config-if)#end
R1#

 
How to Configure RIP Routing in Cisco Packet Tracer?

   Step 3

Likewise, assign the IP addresses to the Serial Interface and GigabitEthernet Interface of Cisco Router R2.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface serial 0/1/1
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
R2(config-if)#exit
R2(config)#interface gigabitethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R2(config-if)#end
R2#

 
How to Configure RIP Routing in Cisco Packet Tracer?

   Step 4

Before configuring RIP in Cisco Packet Tracer, test the connection by pinging to the interfaces from the computers. Pinging Router R1’s GigabitEthernet and Serial Interface via PC1 will be successful.

How to Configure RIP Routing in Cisco Packet Tracer?

   Step 5

Ping to Router R2’s Serial Interface from PC1 will fail! Because no routing protocol is configured in the network environment.

How to Configure RIP Routing in Cisco Packet Tracer?

   Step 6

For RIP configuration on Cisco Router R1, apply these commands.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#network 192.168.5.0
R1(config-router)#network 10.1.1.0
R1(config-router)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#

 
How to Configure RIP Routing in Cisco Packet Tracer?

   Step 7

Likewise, apply the following commands for RIP configuration on Cisco Router R2.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#network 192.168.10.0
R2(config-router)#network 10.1.1.0
R2(config-router)#end
R2#
%SYS-5-CONFIG_I: Configured from console by console
R2#

 
How to Configure RIP Routing in Cisco Packet Tracer?

   Step 8

After completing RIP configuration on Cisco Packet Tracer, execute the show ip route command on Cisco Routers and check the output as shown in the following image.

How to Configure RIP Routing in Cisco Packet Tracer?

   Step 9

Likewise, execute the show ip route command on Cisco Router R2 to examine routing routes.

How to Configure RIP Routing in Cisco Packet Tracer?

   Step 10

After enabling RIP on Cisco Routers, pinging to the Router R2 Serial interface via PC1 and PC3 and PC4 computers will be successful as follows.

How to Configure RIP Routing in Cisco Packet Tracer?

   Step 11

Ping will be successful from 192.168.10.0/24 to 192.168.5.0/24 as well.

How to Configure RIP Routing in Cisco Packet Tracer?

   Step 12

After configuring RIP in Cisco Router, you can use the show ip protocols command on the routers to check the RIP routing protocol.

How to Configure RIP Routing in Cisco Packet Tracer?

   Step 13

The show ip protocols command on Cisco Router R2 is as follows.

How to Configure RIP Routing in Cisco Packet Tracer?

   Step 14

You can examine the other show commands on the RIP configuration on Cisco Router R1.

How to Configure RIP Routing in Cisco Packet Tracer?

   Step 15

Likewise, you can examine the same command on R2.

How to Configure RIP Routing in Cisco Packet Tracer?

Show Commands Related to How to Configure RIP Routing in Cisco Packet Tracer

R1#show ip routeR2#show ip routeR1#show ip protocolsR2#show ip protocolsR1#show running-configR2#show running-configR1#show ip rip dtbseR2#show ip rip dtbse
R1#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, GigabitEthernet0/1
L 192.168.5.1/32 is directly connected, GigabitEthernet0/1
R 192.168.10.0/24 [120/1] via 10.1.1.2, 00:00:14, Serial0/1/0

R1#

R2#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/1
L 10.1.1.2/32 is directly connected, Serial0/1/1
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:09, Serial0/1/1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/1
L 192.168.10.1/32 is directly connected, GigabitEthernet0/1

R2#

R1#show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 7 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
GigabitEthernet0/1 1 2 1
Serial0/1/0 1 2 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.2 120 00:00:00
Distance: (default is 120)
R1#
R2#show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 14 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
GigabitEthernet0/1 1 2 1
Serial0/1/1 1 2 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.10.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.1 120 00:00:01
Distance: (default is 120)
R2#
R1#show running-config
Building configuration…

Current configuration : 823 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524N07E
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.0
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
network 192.168.5.0
!
ip classless
!
ip flow-export version 9
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R1#

R2#show running-config
Building configuration…

Current configuration : 805 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15248JFW
!
!
spanning-tree mode pvst
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 10.1.1.2 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
network 192.168.10.0
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

R1#show ip rip dtbse
10.1.1.0/24 auto-summary
10.1.1.0/24 directly connected, Serial0/1/0
192.168.5.0/24 auto-summary
192.168.5.0/24 directly connected, GigabitEthernet0/1
192.168.10.0/24 auto-summary
192.168.10.0/24
[1] via 10.1.1.2, 00:00:15, Serial0/1/0
R1#
R2#show ip rip dtbse
10.1.1.0/24 auto-summary
10.1.1.0/24 directly connected, Serial0/1/1
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.1, 00:00:03, Serial0/1/1
192.168.10.0/24 auto-summary
192.168.10.0/24 directly connected, GigabitEthernet0/1
R2#

How to Configure RIP Routing in Cisco Packet Tracer? ⇒ Video

To configure RIP on Cisco Packet Tracer, you can watch the following video and also subscribe to our YouTube channel to support us…

  Final Word

How to Configure RIP Routing in Cisco Packet Tracer? – In this article, we have configured RIP Version 1 on Cisco Routers in Packet Tracer. Thanks for following us!

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure RIP Routing in Cisco Packet Tracer

Products Related to How to Configure RIP Routing in Cisco Packet Tracer
Related Products


PKT File Related to How to Configure RIP Routing in Cisco Packet Tracer
Related PKT File

You can download the Packet Tracer RIP Configuration PKT file to your computer by clicking the following button.

Download PKT

Leave a Reply

Your email address will not be published. Required fields are marked *

2 − 2 =