How to Configure PortFast on Cisco Switch in Cisco Packet Tracer? – While configuring the Spanning Tree protocol on Cisco Switches, we can achieve a slight performance boost by excluding client computers or servers from STP convergence.
How to Configure PortFast on Cisco Switch in Cisco Packet Tracer?

How to Configure PortFast on Cisco Switch in Cisco Packet Tracer?

How to Configure PortFast on Cisco Switch in Cisco Packet Tracer?

The most basic rationale for configuring PortFast on Cisco Switches is to save a 50-second down time of an end-point server without STP convergence. The server must always be online and serviced. Otherwise, the down time for a server will be the worst.

We configure the Spanning Tree Protocol to block loops that can occur while configuring Cisco Switches in Layer 2. When using the standard Spanning Tree Protocol (802.1d), we enable the PortFast, UplinkFast and BackboneFast features to improve network performance.

In this article, we will explain how to configure the PortFast on Cisco Switches in a redundancy network using the Cisco Packet Tracer program.

How to Enable PortFast in Cisco Packet Tracer?

In Cisco Packet Tracer, create a network topology as shown in the following image. Afterward Let’s examine which Switch interfaces are to be configured as PortFast.

   Step 1

You can add explanations on network topology to be more descriptive. The LenovoPC IP address is 192.168.1.10 and the Web Server is 192.168.1.100.

How to Configure PortFast on Cisco Switch in Cisco Packet Tracer?
In the above Packet Tracer network topology, Cisco Switches have redundant paths and you can see that the Root Bridge changed by changing the Priority value of SW1.

   Step 2

In addition, we have a LenovoPc client computer and a Web Server. A record has been entered for cisco.com in the DNS settings on the HTTP Server. You can do this in the following way;

How to Configure PortFast on Cisco Switch in Cisco Packet Tracer?
   Step 3

Test the connection by pinging cisco.com from the LenovoPC and then try to reach the site by typing www.cisco.com from the LenovoPC Web Browser.

How to Configure PortFast on Cisco Switch in Cisco Packet Tracer?
   Step 4

We have tested the Web Server by this name. The connection from the LenovoPC to the Web Server must always be active, so we need to enable PortFast on the FastEthernet 0/10 interfaces on SW2 and SW4. And when a cable fault occurs on the network, the STP Convergence must be completed quickly.

Therefore, we need to enable UplinkFast on SW3. Since the UplinkFast feature is not supported on the Packet Tracer, we will perform this operation later on GNS3.

After the UplinkFast feature is enabled on SW3, the Ping will continue even if there is a cable fault because PortFast is enabled in SW4 FastEthernet 0/10 interface. As a result, the connection between LenovoPC and Web Server will not be disconnected.

Our Recommendation

You can purchase “Cisco Networking for Dummies” from Amazon.

The only thing to note here is that we are evaluating the Standard Spanning Tree Protocol in this article. UplinkFast would have been enabled automatically if we enabled the Rapid STP protocol with this network topology in the Cisco Packet Tracer. Because Rapid Spanning Tree protocol combines PortFast, UplinkFast and BackboneFast features under one roof.

In the Rapid STP version, UplinkFast is enabled by default.

To Configure PortFast on Cisco Switch in Cisco Packet Tracer, apply for the following commands.

FortFast Configuration on SW2

[code] SW2# conf t
SW2(config)# interface fastethernet 0/10
SW2(config-if)# spanning-tree portfast
SW2(config-if)# end
[/code]

How to Configure PortFast on Cisco Switch in Cisco Packet Tracer?

PortFast Configuration on SW4

[code] SW4# conf t
SW4(config)# interface fastethernet 0/10
SW4(config-if)# spanning-tree portfast
SW4(config-if)# end
[/code]

How to Configure PortFast on Cisco Switch in Cisco Packet Tracer?

When we enable PortFast on the Cisco Switches above, a small warning is given to us. The above message tells us where to use the PortFast feature.

Show Commands Related to How to Enable PortFast on Cisco Switch

SW2#show running-configSW4#show running-configSW2#show spanning-treeSW4#show spanning-treeSW2#show spanning-tree detailSW4#show spanning-tree detail
SW2#show running-config
Building configuration…

Current configuration : 1097 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
spanning-tree portfast
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
end
SW2#

SW4#show running-config
Building configuration…

Current configuration : 1097 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW4
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
spanning-tree portfast
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
end
SW4#

SW2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 0001.969B.9621
Cost 4
Port 26(GigabitEthernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 00D0.5865.9D80
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20

Interface Role Sts Cost Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Gi0/1 Desg FWD 4 128.25 P2p
Gi0/2 Root FWD 4 128.26 P2p
Fa0/24 Desg FWD 19 128.24 P2p
Fa0/10 Desg FWD 19 128.10 P2p

SW2#

SW4#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 0001.969B.9621
Cost 4
Port 25(GigabitEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 00D0.D343.A8E0
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20

Interface Role Sts Cost Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/10 Desg FWD 19 128.10 P2p
Fa0/24 Altn BLK 19 128.24 P2p
Gi0/1 Root FWD 4 128.25 P2p
Gi0/2 Desg FWD 4 128.26 P2p

SW4#

SW2#show spanning-tree detail

VLAN0001 is executing the ieee compatible Spanning Tree Protocol
Bridge Identifier has priority of 32768, sysid 1, 00D0.5865.9D80
Configured hello time 2, max age 20, forward delay 15
Current root has priority 4097
Root port is 26 (GigabitEthernet0/2), cost of root path is 4
Topology change flag not set, detected flag not set
Number of topology changes 0 last change occurred 00:00:00 ago
from FastEthernet0/1
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 10 (FastEthernet0/10) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.10
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.10, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 24 (FastEthernet0/24) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.24
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.24, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 25 (GigabitEthernet0/1) of VLAN0001 is designated forwarding
Port path cost 4, Port priority 128, Port Identifier 128.25
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.25, designated path cost 4
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 26 (GigabitEthernet0/2) of VLAN0001 is root forwarding
Port path cost 4, Port priority 128, Port Identifier 128.26
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
SW2#

SW4#show spanning-tree detail

VLAN0001 is executing the ieee compatible Spanning Tree Protocol
Bridge Identifier has priority of 32768, sysid 1, 00D0.D343.A8E0
Configured hello time 2, max age 20, forward delay 15
Current root has priority 4097
Root port is 25 (GigabitEthernet0/1), cost of root path is 4
Topology change flag not set, detected flag not set
Number of topology changes 0 last change occurred 00:00:00 ago
from FastEthernet0/1
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 10 (FastEthernet0/10) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.10
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.10, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 24 (FastEthernet0/24) of VLAN0001 is alternate blocking
Port path cost 19, Port priority 128, Port Identifier 128.24
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 25 (GigabitEthernet0/1) of VLAN0001 is root forwarding
Port path cost 4, Port priority 128, Port Identifier 128.25
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 26 (GigabitEthernet0/2) of VLAN0001 is designated forwarding
Port path cost 4, Port priority 128, Port Identifier 128.26
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.26, designated path cost 4
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
SW4#

How to Configure PortFast in Cisco Packet Tracer? ⇒ Video

You can watch how to configure PortFast on Cisco Switch in Cisco Packet Tracer and you can also subscribe to our YouTube channel…

  Final Word

How to Configure PortFast on Cisco Switch in Cisco Packet Tracer? – In this article, we have implemented the PortFast configuration on Cisco Switches. Although the Cisco Packet Tracer program is a very large program, it can be useless in some cases. To understand the PortFast configuration of the Switches, you can better understand when you pull out the network cable that plugs into the client and server on the Packet Tracer. We will discuss this in more detail in the GNS3 program.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure PortFast on Cisco Switch in Cisco Packet Tracer

Products Related to How to Configure PortFast on Cisco Switch in Cisco Packet Tracer
Related Products

File Related to How to Configure PortFast on Cisco Switch in Cisco Packet Tracer
Related File

You can download the Packet Tracer PKT work file used in this article from the button below…

Leave a Reply

Your email address will not be published. Required fields are marked *

fourteen + thirteen =