How to Configure NAT PAT in Cisco Packet Tracer? – The PAT (Port Address Translation) operation uses port numbers to convert custom IP addresses to global IP addresses.
How to Configure NAT PAT in Cisco Packet Tracer?

How to Configure NAT PAT in Cisco Packet Tracer?

How to Configure NAT PAT in Cisco Packet Tracer?

The process to configure NAT PAT on Cisco Packet Tracer is the most commonly used method according to Static NAT and Dynamic NAT settings. It is usually used by home users or small businesses. ADSL Modems access the Internet with a single ISP IP address. When all the computers on the local network access the Internet with a single global IP address, NAT PAT operation is performed.

PAT is also called NAT Overloading. When a computer on the local network sends a packet to the target computer, it adds a port number next to the IP address to follow a single IP address.

PAT is enabled by default on the ADSL Router used for home use.

In the process to configure NAT PAT on Cisco Router in Packet Tracer, we will translate the private IP addresses into a single global IP address.

In the previous articles, we discussed how to configure Static NAT in Cisco Packet Tracer and how to configure Dynamic NAT in Cisco Packet Tracer. In this article, we will outline the steps for configuring Cisco Packet Tracer NAT PAT.

For the NAT PAT configuration in Packet Tracer, you can download the PKT file from the button at the bottom of the article.

Our Recommendation; You can purchase the book of CCNA Routing and Switching Complete Study.

How to Configure NAT Overload in Cisco Packet Tracer?

We can now pass on to the steps of configuring NAT Overload in Cisco Packet Tracer. Follow the steps below to configure PAT.

   Step 1

First, open the Cisco Packet Tracer program and create a topology like the one below. You can enter explanations like an IP address in the workspace. This will give you a better understanding of the network topology.

Cisco Packet Tracer NAT PAT Konfigürasyonu

   Step 2

Give IP addresses to the computers on the Packet Tracer workspace.

Cisco Packet Tracer NAT PAT Konfigürasyonu

   Step 3

For the Cisco Packet Tracer NAT PAT configuration, click Cisco Router and then click the CLI tab. Apply the following commands in order for NAT PAT configuration.

[code] Router# conf t
Router(config)# interface gigabitethernet 0/0
Router(config-if)# ip address 192.168.10.1 255.255.255.0
Router(config-if)# ip nat inside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface gigabitethernet 0/1
Router(config-if)# ip address 10.0.0.1 255.255.255.0
Router(config-if)# ip nat outside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# access-list 1 permit 192.168.10.0 0.0.0.255
Router(config)# ip nat inside source list 1 interface gigabitethernet0/1 overload
Router(config)# end
Router# wr
[/code]

Cisco Packet Tracer NAT PAT Konfigürasyonu

   Step 4

After applying the commands for configuring NAT PAT on the Cisco Router, test the connection by pinging the 10.0.0.2 IP address from the computers on the local network.

Computers on the local network have successfully connected as shown below.

Cisco Packet Tracer NAT PAT Konfigürasyonu

   Step 5

Click on Cisco Router0 and run the show ip nat translations command in privileged configuration mode.

Cisco Packet Tracer NAT PAT Konfigürasyonu

For SSH use on Cisco Routers, you can read the article called “How to Configure SSH in Cisco Packet Tracer?“.

Show Commands Related to How to Configure NAT PAT in Cisco Packet Tracer

Router0#show ip nat translations Router0#show ip nat statistics Router0#show running-config Router1#show running-config
Router0#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 10.0.0.1:1024 192.168.10.20:1 10.0.0.2:1 10.0.0.2:1024
icmp 10.0.0.1:1025 192.168.10.20:2 10.0.0.2:2 10.0.0.2:1025
icmp 10.0.0.1:1026 192.168.10.20:3 10.0.0.2:3 10.0.0.2:1026
icmp 10.0.0.1:1027 192.168.10.20:4 10.0.0.2:4 10.0.0.2:1027
icmp 10.0.0.1:2 192.168.10.10:2 10.0.0.2:2 10.0.0.2:2
icmp 10.0.0.1:3 192.168.10.10:3 10.0.0.2:3 10.0.0.2:3
icmp 10.0.0.1:4 192.168.10.10:4 10.0.0.2:4 10.0.0.2:4

Router0#show ip nat statistics
Total translations: 0 (0 static, 0 dynamic, 0 extended)
Outside Interfaces: GigabitEthernet0/1
Inside Interfaces: GigabitEthernet0/0
Hits: 7 Misses: 8
Expired translations: 8
Dynamic mappings:

Router0#show running-config
Building configuration…
Current configuration : 772 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524V4OL
!
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.0.0.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source list 1 interface GigabitEthernet0/1 overload
ip classless
!
ip flow-export version 9
!
!
access-list 1 permit 192.168.10.0 0.0.0.255
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

Router1#show running-config
Building configuration…
Current configuration : 617 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX15247004
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 10.0.0.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

For DHCP settings and commands on Cisco Routers, you can browse the article called “How to Configure DHCP in Cisco Packet Tracer?“.

How to Configure NAT PAT in Cisco Packet Tracer ⇒ Video

You can watch how to configure nat overload pat on Cisco Router in Cisco Packet Tracer and you can also subscribe to our YouTube channel…

  Final Word

How to Configure NAT PAT in Cisco Packet Tracer? – We have implemented the basic steps of NAT PAT configuration. PAT processing is the most common method. PAT uses more than 64,000 port numbers, and router addresses are very likely to be depleted.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure NAT PAT in Cisco Packet Tracer

Products Related to How to Configure NAT PAT in Cisco Packet Tracer
Related Products

File Related to How to Configure NAT PAT in Cisco Packet Tracer
Related File
By clicking on the button below, you can download the file PKT file of NAT PAT configuration to your PC…

Leave a Reply

Your email address will not be published. Required fields are marked *

three × two =