How to Configure Inter-VLAN Routing in Cisco Packet Tracer? – After creating VLANs on the Cisco Packet Tracer, we need to communicate between these VLANs. This VLAN routing process is called Inter-VLAN Routing.
How to Configure Inter-VLAN Routing in Cisco Packet Tracer?

How to Configure Inter-VLAN Routing in Cisco Packet Tracer?

How to Configure Inter-VLAN Routing in Cisco Packet Tracer?

Before proceeding with the Cisco Packet Tracer Inter-VLAN configuration steps, in the previous article, we had explained how to configure VLAN in Cisco Packet Tracer. And then we had added the Cisco Switch interfaces to VLANs. In this article, we will perform the steps for configuring Inter-VLAN Routing.

Before proceeding the steps to configure Inter-VLAN Routing in Cisco Packet Tracer, you need to read the VLAN creation from above link. You can then proceed to the Cisco Packet Tracer Inter-VLAN steps.

The Cisco Packet Tracer VLAN routing process was performed with two or more cables to the Router from the Switch with the older type of connection. In such a connection, more than one interface is used. Nowadays, we can recover these ports by creating a subinterface on the Router by pulling a single cable from the Switch to the Router. This is always a recommended condition.

Our Recommendation; You can purchase the book of Routing and Switching Essentials v6 Companion Guide.

How to Configure Inter-VLAN Routing on a Cisco Router?

After creating VLANs on Cisco Switch in Cisco Packet Tracer, we will configure on the Cisco Router to communicate these VLANs. Read absolutely the previous post, and then you can apply Inter-VLAN Routing.

   Step 1

In Cisco Packet Tracer, create a topology as shown in the following image. In the following image, VLAN configuration was done. Click Cisco Router for Inter-VLAN Routing configuration.

How to Configure Inter-VLAN Routing in Cisco Packet Tracer?

   Step 2

On the Cisco Router configuration window, click the CLI tab. Next, apply the following commands in order for Cisco Packet Tracer VLAN forwarding.

[code] Router#conf t
Router(config)# interface gigabitethernet0/0
Router(config-if)# no ip address
Router(config-if)# no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)# exit
Router(config)# interface gigabitethernet0/0.10
%LINK-5-CHANGED: Interface GigabitEthernet0/0.10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.10, changed state to up
Router(config-subif)# encapsulation dot1q 10
Router(config-subif)# ip address 192.168.10.1 255.255.255.0
Router(config-subif)# exit
Router(config)# interface gigabitethernet0/0.20
%LINK-5-CHANGED: Interface GigabitEthernet0/0.20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.20, changed state to up
Router(config-subif)# encapsulation dot1q 20
Router(config-subif)# ip address 192.168.20.1 255.255.255.0
Router(config-subif)# exit
Router(config)# interface gigabitethernet0/0.30
%LINK-5-CHANGED: Interface GigabitEthernet0/0.30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.30, changed state to up
Router(config-subif)# encapsulation dot1q 30
Router(config-subif)# ip address 192.168.30.1 255.255.255.0
Router(config-subif)# end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router# wr
Building configuration…
[OK] Router#
[/code]

How to Configure Inter-VLAN Routing in Cisco Packet Tracer?

   Step 3

After creating the subinterfaces on the Cisco Router, we can check the status of the subinterfaces by issuing the show ip  interface brief command at the CLI command prompt.

How to Configure Inter-VLAN Routing in Cisco Packet Tracer?

To configure the Cisco Router with the console connection, browse to the article called “How to Connect to Cisco Router Console in Cisco Packet Tracer?“.

   Step 4

In the Cisco Packet Tracer workspace, click PC0 and open the command prompt in the window that opens. Ping to VLAN20 and VLAN30 members from PC0. Ping will fail as shown below.

The ping operation is unsuccessful because the Cisco Switch Gig0/1 interface connected to the Cisco Router is not configured as TRUNK.

Multiple VLANs can be passed through the TRUNK port.

How to Configure Inter-VLAN Routing in Cisco Packet Tracer?

   Step 5

Click on the Cisco Switch, and then on the CLI tab, configure the GigabitEthernet0/1 interface as the TRUNK port.

[code] Switch# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface gigabitethernet 0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
Switch(config-if)# end
%SYS-5-CONFIG_I: Configured from console by console
Switch# wr
Building configuration…
[OK] [/code]

How to Configure Inter-VLAN Routing in Cisco Packet Tracer?

   Step 6

After completing the steps to configure Inter-VLAN Routing in Cisco Packet Tracer, you can see that the process is successful if you ping PCs that are members of other VLANs via PC0.

How to Configure Inter-VLAN Routing in Cisco Packet Tracer?

For the process of distributing IP addresses to two different networks with DHCP on the Cisco Router, you can read the article called “How to Configure DHCP in Cisco Packet Tracer?“.

Show Commands Related to How to Configure Inter-VLAN Routing in Cisco Packet Tracer

Router# show ip int brSwitch# show interfaces gigabitEthernet 0/1 switchportRouter#show running-configSwitch# show running-config

Router# show ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES unset up up
GigabitEthernet0/0.10 192.168.10.1 YES manual up up
GigabitEthernet0/0.20 192.168.20.1 YES manual up up
GigabitEthernet0/0.30 192.168.30.1 YES manual up up
GigabitEthernet0/1 unassigned YES unset administratively down down
Vlan1 unassigned YES unset administratively down down

Switch# show interfaces gigabitEthernet 0/1 switchport
Name: Gig0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none
Switch#

Router# show running-config
Building configuration…
Current configuration : 891 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX15243C2U
!
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

Switch# show running-config
Building configuration…
Current configuration : 1638 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0002.4ad8.4b01
ip address 192.168.10.100 255.255.255.0
!
interface Vlan20
mac-address 0002.4ad8.4b02
ip address 192.168.20.100 255.255.255.0
!
interface Vlan30
mac-address 0002.4ad8.4b03
ip address 192.168.30.100 255.255.255.0
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
Switch#

How to Configure Inter-VLAN Routing in Cisco Packet Tracer ⇒ Video

You can watch how to configure Inter-VLAN Routing on a Cisco Router in Cisco Packet Tracer and also subscribe to our YouTube channel…

  Final Word

How to Configure Inter-VLAN Routing in Cisco Packet Tracer? – After creating the VLAN on the Cisco Packet Tracer, we completed the Inter-VLAN Routing steps.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to How to Configure Inter-VLAN Routing in Cisco Packet Tracer
Products Related to How to Configure Inter-VLAN Routing in Cisco Packet Tracer
Related Products

Leave a Reply

Your email address will not be published. Required fields are marked *

3 × three =