How to Configure EIGRP in Cisco Packet Tracer? – EIGRP (Enhanced Interior Gateway Routing Protocol) is a Hybrid Protocol specific to Cisco devices only.
How to Configure EIGRP in Cisco Packet Tracer?

How to Configure EIGRP in Cisco Packet Tracer?

How to Configure EIGRP in Cisco Packet Tracer?

The EIGRP Protocol is both a Distance Vector and a Link-State routing protocol. The EIGRP protocol sends routing tables when occurring a change in the network according to RIP. RIP sends routing table updates to neighboring routers every 30 seconds.

As a result, the RIP protocol uses more network resources and creates additional overhead for the routers. EIGRP makes specific updates on a network change.

In the previous article, we discussed the EIGRP Protocol. In this article, we will configure EIGRP on Cisco Packet Tracer.

You can also watch the RIP configuration as a video.

Our Recommendation

You can purchase “Routing and Switching Complete Study Guide” from Amazon.

How to Configure EIGRP Routing in Packet Tracer?

Follow the steps for configuring EIGRP in Cisco Packet Tracer in sequence.

   Step 1

For the EIGRP configuration on the Cisco Packet Tracer, create a network topology as shown in the following image.

How to Configure EIGRP in Cisco Packet Tracer?

   Step 2

To configure the Cisco Router R1 interfaces, open the CLI command prompt. Then apply the following commands.

[code] Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface gigabitethernet0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface serial 0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
[/code]

How to Configure EIGRP in Cisco Packet Tracer?

   Step 3

To configure the Cisco Router R2 interfaces, perform the following commands at the CLI prompt.

[code] Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface gigabitethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R2(config-if)#exit
R2(config)#interface serial 0/1/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
R2(config)#
[/code]

How to Configure EIGRP in Cisco Packet Tracer?

   Step 4

Before configuring EIGRP in Cisco Packet Tracer, test the connection by pinging the Cisco Router FastEthernet0/0 and Serial0/1/0 interfaces from PC1.

How to Configure EIGRP in Cisco Packet Tracer?

   Step 5

Likewise, test the Cisco Router R2 interfaces on PC2 at 192.168.10.0/24.

How to Configure EIGRP in Cisco Packet Tracer?

   Step 6

This time, ping from the PC1 to R2 Serial0/1/1 interface and PC2. Ping will fail as follows. Because no routing protocol is configured in the network environment.

How to Configure EIGRP in Cisco Packet Tracer?

   Step 7

Ping operation from PC2 to R1 interfaces will fail.

How to Configure EIGRP in Cisco Packet Tracer?

   Step 8

For the Cisco Packet Tracer EIGRP configuration, open the Cisco Router R1 CLI command prompt and configure the following commands. The first command to enable EIGRP on the router is router eigrp (AS Number).

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#router eigrp ?
<1-65535> Autonomous system number
R1(config)#router eigrp 1
R1(config-router)#network 192.168.5.0 ?
A.B.C.D EIGRP wild card bits
<cr>
R1(config-router)#network 192.168.5.0 0.0.0.255
R1(config-router)#network 10.1.1.0 0.0.0.3
R1(config-router)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#
[/code]

How to Configure EIGRP in Cisco Packet Tracer?

   Step 9

For Cisco Router R2 EIGRP configuration, use the following commands.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#router eigrp 1
R2(config-router)#network 192.168.10.0 0.0.0.255
R2(config-router)#network 10.1.1.0 0.0.0.3
R2(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 10.1.1.1 (Serial0/1/1) is up: new adjacency
R2(config-router)#end
R2#
[/code]

How to Configure EIGRP in Cisco Packet Tracer?

   Step 10

You can use the show ip route command on Cisco Router R1 to examine the EIGRP routing table. The EIGRP routing protocol is indicated by the letter D as in the following display. And also the EIGRP metric is 90.

How to Configure EIGRP in Cisco Packet Tracer?

   Step 11

Also, run the show ip route command on Cisco Router R2 to display the EIGRP routing table.

How to Configure EIGRP in Cisco Packet Tracer?

   Step 12

With EIGRP show commands, you can test the routing protocol operation and troubleshoot. The show commands for EIGRP, for example, are as follows.

How to Configure EIGRP in Cisco Packet Tracer?

   Step 13

You can also better understand the routing protocol by running show commands on Cisco Router R2.

How to Configure EIGRP in Cisco Packet Tracer?

   Step 14

One way to troubleshoot the EIGRP protocol is to use the debug eigrp packets command. This command is often used when EIGRP is causing problems.

How to Configure EIGRP in Cisco Packet Tracer?

   Step 15

Likewise, you can view EIGRP packets on Cisco Router R2.

How to Configure EIGRP in Cisco Packet Tracer?

Show Commands Related to How to Configure EIGRP in Cisco Packet Tracer

R1#show ip routeR1#show running-configR1#show ip eigrp neighborsR1#show ip eigrp topologyR1#show ip eigrp trafficR2#show ip eigrp neighborsR2#show ip eigrp topologyR2#show ip eigrp trafficR1#debug eigrp packetsR2#debug eigrp packetsR1#show running-configR2#show running-config
R1#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, GigabitEthernet0/0
L 192.168.5.1/32 is directly connected, GigabitEthernet0/0
D 192.168.10.0/24 [90/2170112] via 10.1.1.2, 00:00:36, Serial0/1/0
R1#

R2#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/1
L 10.1.1.2/32 is directly connected, Serial0/1/1
D 192.168.5.0/24 [90/2170112] via 10.1.1.1, 00:01:03, Serial0/1/1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/1
L 192.168.10.1/32 is directly connected, GigabitEthernet0/1
R2#

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.1.2 Se0/1/0 11 01:27:25 40 1000 0 3
R1#
R1#show ip eigrp topology
IP-EIGRP Topology Table for AS 1/ID(192.168.5.1)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – Reply status

P 10.1.1.0/30, 1 successors, FD is 2169856
via Connected, Serial0/1/0
P 192.168.5.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet0/0
P 192.168.10.0/24, 1 successors, FD is 2170112
via 10.1.1.2 (2170112/2816), Serial0/1/0
R1#

R1#show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 1
Hellos sent/received: 2292/1137
Updates sent/received: 2/2
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 2/2
Input queue high water mark 1, 0 drops
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0
R1#
R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.1.1 Se0/1/1 11 01:35:21 40 1000 0 3
R2#
R2#show ip eigrp topology
IP-EIGRP Topology Table for AS 1/ID(192.168.10.1)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – Reply status

P 10.1.1.0/30, 1 successors, FD is 2169856
via Connected, Serial0/1/1
P 192.168.5.0/24, 1 successors, FD is 2170112
via 10.1.1.1 (2170112/2816), Serial0/1/1
P 192.168.10.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet0/1
R2#

R2#show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 1
Hellos sent/received: 2480/1239
Updates sent/received: 2/2
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 2/2
Input queue high water mark 1, 0 drops
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0
R2#
R1#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, ACK )
R1#
EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

R2#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, ACK )
R2#
EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

R1#show running-config
Building configuration…

Current configuration : 835 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524470E
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.5.0
network 10.1.1.0 0.0.0.3
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R1#

R2#show running-config
Building configuration…

Current configuration : 817 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX152481GS
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 10.1.1.2 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.10.0
network 10.1.1.0 0.0.0.3

!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

How to Configure EIGRP in Cisco Packet Tracer? ⇒ Video

You can watch how to configure EIGRP in Cisco Packet Tracer and you can also subscribe to our YouTube channel…

  Final Word

How to Configure EIGRP in Cisco Packet Tracer? – In this article, we have implemented the EIGRP configuration steps on the Cisco Router in the Cisco Packet Tracer. It is recommended to use the EIGRP Routing protocol for large networks. The only disadvantage of the EIGRP Routing protocol is that it is used only on Cisco devices.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure EIGRP in Cisco Packet Tracer

Articles Related to How to Configure EIGRP in Cisco Packet Tracer
Related Products

File Related to How to Configure EIGRP in Cisco Packet Tracer
Related File
EIGRP configuration PKT file used in this article you can download from the button below to your computer…

Leave a Reply

Your email address will not be published. Required fields are marked *

1 × one =