How to Configure Dynamic NAT in Cisco Packet Tracer? – Dynamic matches private IP addresses with IP addresses in the NAT pool. In this article, we will discuss the Dynamic NAT configuration in Packet Tracer.
How to Configure Dynamic NAT in Cisco Packet Tracer?

How to Configure Dynamic NAT in Cisco Packet Tracer?

How to Configure Dynamic NAT in Cisco Packet Tracer?

In a Dynamic NAT-configured Cisco Router, you need to create a pool for the IP address range purchased by the ISP. When computers on the local network go to the Internet, they use the Ip address that is idle from the Ip pool configured on the Cisco Router.

In the previous article, we discussed how to configure Static NAT in Cisco Packet Tracer. In this article, we are going to perform the step to configure Dynamic NAT in Cisco Packet Tracer.

You can download the PKT file to configure Dynamic NAT in Cisco Packet Tracer from the bottom of the article.

Our Recommendation; You can purchase the book of Packet Tracer Network Simulator.

How to Configure Dynamic NAT on Cisco Router in Packet Tracer?

We can now pass on to the steps to configure Dynamic NAT on Cisco Router in Packet Tracer.

   Step 1

Open the Cisco Packet Tracer program and create the network topology as shown in the following image.

How to Configure Dynamic NAT in Cisco Packet Tracer?

   Step 2

Configure the IP address settings of the computers in the workspace.

How to Configure Dynamic NAT in Cisco Packet Tracer?

   Step 3

For Cisco Packet Tracer Dynamic NAT configuration, click on the Cisco Router and open the CLI command prompt. Apply the following commands on the Cisco Router.

[code] Router# conf t
Router(config)# interface gigabitethernet 0/0
Router(config-if)# ip address 192.168.10.1 255.255.255.0
Router(config-if)# ip nat inside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface gigabitethernet 0/1
Router(config-if)# ip address 10.0.0.1 255.0.0.0
Router(config-if)# ip nat outside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# ip nat pool DYNAMICNAT 10.0.0.5 10.0.0.10 netmask 255.0.0.0
Router(config)# ip access-list 1 permit 192.168.10.0 0.0.0.255
Router(config)# ip nat inside source list 1 pool DYNAMICNAT
Router(config)# end
Router# wr
[/code]

How to Configure Dynamic NAT in Cisco Packet Tracer?

   Step 4

After configuring Dynamic NAT on the Cisco Router, test the connection by pinging to the 10.0.0.2 IP address from PC0. The ping operation completed successfully as shown in the following image.

How to Configure Dynamic NAT in Cisco Packet Tracer?

   Step 5

Ping will also succeed when PC1 pings Cisco Router1.

How to Configure Dynamic NAT in Cisco Packet Tracer?

   Step 6

On Cisco Router0, you can view NAT records by executing the show ip  nat translations command. As you can see in the following image, the local IP addresses translated to 10.0.0.5 and 10.0.0.6 Public IP addresses.

How to Configure Dynamic NAT in Cisco Packet Tracer?

How to install and use Packet Tracer? You can find the answer to the question in the article called “How to Use Cisco Packet Tracer Step by Step?“.

Show Commands Related to How to Configure Dynamic NAT Cisco Packet Tracer

Router0#show ip nat translationsRouter0#show running-config Router0#show ip nat statistics Router1#sho running-config

Router#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 10.0.0.5:1 192.168.10.10:1 10.0.0.2:1 10.0.0.2:1
icmp 10.0.0.5:2 192.168.10.10:2 10.0.0.2:2 10.0.0.2:2
icmp 10.0.0.5:3 192.168.10.10:3 10.0.0.2:3 10.0.0.2:3
icmp 10.0.0.5:4 192.168.10.10:4 10.0.0.2:4 10.0.0.2:4
icmp 10.0.0.5:5 192.168.10.10:5 10.0.0.2:5 10.0.0.2:5
icmp 10.0.0.5:6 192.168.10.10:6 10.0.0.2:6 10.0.0.2:6
icmp 10.0.0.5:7 192.168.10.10:7 10.0.0.2:7 10.0.0.2:7
icmp 10.0.0.5:8 192.168.10.10:8 10.0.0.2:8 10.0.0.2:8
icmp 10.0.0.6:1 192.168.10.20:1 10.0.0.2:1 10.0.0.2:1
icmp 10.0.0.6:2 192.168.10.20:2 10.0.0.2:2 10.0.0.2:2
icmp 10.0.0.6:3 192.168.10.20:3 10.0.0.2:3 10.0.0.2:3
icmp 10.0.0.6:4 192.168.10.20:4 10.0.0.2:4 10.0.0.2:4

Router#show running-config
Building configuration…

Current configuration : 806 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524A5WO
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.0.0.1 255.0.0.0
ip nat outside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat pool DYNAMICNAT 10.0.0.5 10.0.0.10 netmask 255.0.0.0
ip nat inside source list 1 pool DYNAMICNAT
ip classless
!
ip flow-export version 9
!
!
access-list 1 permit 192.168.10.0 0.0.0.255
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

Router#show ip nat statistics
Total translations: 0 (0 static, 0 dynamic, 0 extended)
Outside Interfaces: GigabitEthernet0/1
Inside Interfaces: GigabitEthernet0/0
Hits: 9 Misses: 12
Expired translations: 12
Dynamic mappings:
— Inside Source
access-list 1 pool DYNAMICNAT refCount 0
pool DYNAMICNAT: netmask 255.0.0.0
start 10.0.0.5 end 10.0.0.10
type generic, total addresses 6 , allocated 0 (0%), misses 0
Router#

Router#show running-config
Building configuration…

Current configuration : 613 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX152407TL
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 10.0.0.2 255.0.0.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
Router#

To distribute automatic IP addresses to computers on the Cisco Packet Tracer, you can read the article called “How to Configure DHCP in Cisco Packet Tracer?“.

How to Configure Dynamic NAT in Cisco Packet Tracer ⇒ Video

You can watch how to configure Dynamic NAT on Cisco Router in Packet Tracer and also subscribe to our YouTube channel…

  Final Word

How to Configure Dynamic NAT in Cisco Packet Tracer? – After creating a simple network on the Packet Tracer, we specified the IP addresses and then configured the computers and Cisco Routers. As a result, after applying Dynamic NAT commands on the Cisco router, the computers successfully reached Router1.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure Dynamic NAT in Cisco Packet Tracer

Products Related to How to Configure Dynamic NAT in Cisco Packet Tracer
Related Products

File Related to How to Configure Dynamic NAT in Cisco Packet Tracer
Related File
You can download the PKT file related to how to configure dynamic NAT in Cisco Packet Tracer to your computer by clicking the button below…

Leave a Reply

Your email address will not be published. Required fields are marked *