How to Configure DHCP in Cisco Packet Tracer? – With the Cisco Packet Tracer program, we can create network topologies and gain experience. The Cisco Packet Tracer program is a network simulator program of Cisco, as is well known.
How to Configure DHCP in Cisco Packet Tracer?

How to Configure DHCP in Cisco Packet Tracer?

How to Configure DHCP in Cisco Packet Tracer?

Before explaining how to configure DHCP in Cisco Packet Tracer, you can browse our previous articles called What is Cisco Packet Tracer and how to Cisco Packet Tracer 7 on Windows 10. Packet Tracer In the DHCP configuration and two network communication process, we will configure with only a few commands on the Cisco Router.

If you are new to the use of the Cisco Packet Tracer program, you can get information with the article called how to use Cisco Packet Tracer step by step.

We can now pass to the steps to configure DHCP in Cisco Packet Tracer. Follow the steps below.

Our Recommendation; You can purchase the Training DVD created by Infiniteskills for Cisco CCNA Routing and Switching.

How to Configure DHCP for Multiple Networks?

   Step 1

To configure DHCP on the Cisco Router, first, create a topology in the Packet Tracer program as shown below. You can create explanations for interfaces and other information on the workspace.

The following topology contains two different networks. We have 192.168.1.0/24 and 192.168.2.0/24 two different networks. For these networks, we will distribute automatic IP addresses through the Cisco Router.

Click once on Cisco Router.

How to Configure DHCP in Cisco Packet Tracer?

   Step 2

In the Router0 window, click the CLI command request tab. CLI command request allows Cisco routers to configure via commands.

On the Cisco router initial configuration screen, press the Enter key by typing No. If you choose Yes on this screen, Cisco Router will ask you step by step to make basic settings.

Since we are going to do manual processing, we apply the No command.

How to Configure DHCP in Cisco Packet Tracer?

   Step 3

Apply the following Cisco DHCP commands in order for Cisco DHCP configuration. First, you must configure Cisco Router interfaces. After activating the Cisco GigabitEthernet interfaces, follow the Cisco DHCP configuration commands.

[code] Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface gigabitethernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface gigabitethernet 0/1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
Router(config-if)#exit
Router(config)#ip dhcp pool LAN1
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.1
Router(dhcp-config)#dns-server 192.168.1.1
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 192.168.1.1
Router(config)#ip dhcp pool LAN2
Router(dhcp-config)#network 192.168.2.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.2.1
Router(dhcp-config)#dns-server 192.168.2.1
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 192.168.2.1
Router(config)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#wr
Building configuration…
[OK] Router#
[/code]

How to Configure DHCP in Cisco Packet Tracer?

   Step 4

After you apply Cisco DHCP commands, you need to set up the computers you added to the Packet Tracer workspace for the automatic IP address. To do this, click PC0 on the pop-up IP Configuration. Then activate the DHCP option for PC0 to receive an automatic IP address.

How to Configure DHCP in Cisco Packet Tracer?

   Step 5

After DHCP activated on PC0, a DHCP Request message sends on the network. In order to discover the IP address of a DHCP Server client in the network environment, the DHCP operation is completed in a short way by sending the DHCP Offer message.

How to Configure DHCP in Cisco Packet Tracer?

   Step 6

PC0 completed the IP address request by successfully receiving the IP address from the Cisco DHCP server.

How to Configure DHCP in Cisco Packet Tracer?

   Step 7

Enable the DHCP option for computers on the 192.168.2.0/24 network. After DHCP enabled on PC2, the Request message sends to IP address.

How to Configure DHCP in Cisco Packet Tracer?

   Step 8

PC2 successfully received the IP address because the Cisco Router configured the DHCP pool for the 192.168.2.0/24 network.

How to Configure DHCP in Cisco Packet Tracer?

   Step 9

Pinging from the PC0 prompt to the 2.0 network is successful as shown in the following image.

How to Configure DHCP in Cisco Packet Tracer?

   Step 10

Pinging from PC3 to the 1.0 network is also successful.

How to Configure DHCP in Cisco Packet Tracer?

   Step 11

We have completed the steps to configure DHCP in Cisco Packet Tracer. With Cisco DHCP show commands, you can see the IP addresses and MAC addresses of the computers that are assigned the IP address. We can also see IP address conflicts and DHCP pool details.

How to Configure DHCP in Cisco Packet Tracer?

   Step 12

When we apply for the show ip dhcp pool command in privileged mode on the Cisco Router, we can see the DHCP pool details as in the following image.

How to Configure DHCP in Cisco Packet Tracer?

Show Commands Related to How to Configure DHCP in Packet Tracer

Router#show ip dhcp ?Router#show ip dhcp binding Router#show ip dhcp pool

Router#show ip dhcp ?
binding DHCP address bindings
conflict DHCP address conflicts
pool DHCP pools information
relay Miscellaneous DHCP relay information

Router#show ip dhcp binding
IP address     Client-ID/                      Lease expiration    Type
Hardware address
192.168.1.2 000C.8536.A381           —                           Automatic
192.168.1.3 00E0.B0AC.5779           —                           Automatic
192.168.2.2 00E0.F7CA.7827           —                           Automatic
192.168.2.3 000A.F383.BCDE           —                           Automatic

Router#show ip dhcp pool

Pool LAN1 :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 2
Excluded addresses : 2
Pending event : none

1 subnet is currently in the pool
Current index IP address range Leased/Excluded/Total
192.168.1.1 192.168.1.1 – 192.168.1.254 2 / 2 / 254

Pool LAN2 :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 2
Excluded addresses : 2
Pending event : none

1 subnet is currently in the pool
Current index IP address range Leased/Excluded/Total
192.168.2.1 192.168.2.1 – 192.168.2.254 2 / 2 / 254
Router#

How to Configure DHCP in Cisco Packet Tracer? ⇒ Video

You can view the steps to configure DHCP in Cisco Packet Tracer as a video and also subscribe to our YouTube channel…

  Final Word

How to Configure DHCP in Cisco Packet Tracer? – After the Cisco DHCP configuration process, we deployed automatic IP addresses to the computers. We can add to the workspace on different devices and distribute automatic IP addresses.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to How to Configure DHCP in Cisco Packet Tracer

Products Related to How to Configure DHCP in Cisco Packet Tracer
Related Products

Leave a Reply

Your email address will not be published. Required fields are marked *