Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu – Cisco Packet Tracer üzerinde VLAN’lar oluşturulduktan sonra, bu VLAN’lar arasında haberleşmeyi sağlamamız gerekmektedir. Bu VLAN yönlendirme işlemine Inter-VLAN Routing denmektedir.
Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu

Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu

Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu

Cisco Packet Tracer Inter-VLAN konfigürasyonu adımlarına geçmeden önce, bir önceki Cisco Packet Tracer VLAN Konfigürasyonu adlı yazımızda VLAN oluşturma ve Cisco Switch arayüzlerini VLAN’lara üye yapma işlemlerini gerçekleştirmiştik. Bu yazımızda Inter-VLAN Routing konfigürasyonu adımlarını gerçekleştireceğiz.

Cisco Packet Tracer VLAN yönlendirme adımlarına geçmeden önce yukarıdaki bağlantıdan VLAN oluşturma konusunu okumanız gerekir. Ardından Cisco Packet Tracer VLAN yönlendirme adımlarına geçebilirsiniz.

Cisco Packet Tracer VLAN yönlendirme işlemi eski tip bağlantı şekli ile Switch’ten Router’a 2 veya daha fazla kablo ile yapılmaktaydı. Böyle bir bağlantıda birden fazla arayüz kullanılmaktadır. Günümüzde, Switch’ten Router’a tek bir kablo çekilerek Router üzerinde Subinterface oluşturarak bu portları kurtarabiliriz. Bu her zaman tavsiye edilen bir durumdur.

Cisco Router üzerinde SSH etkinleştirmek için, Cisco Packet Tracer SSH Konfigürasyonu adlı yazıyı okuyabilirsiniz…

Cisco Packet Tracer VLAN Yönlendirme

Cisco Packet Tracer Cisco Switch üzerinde VLAN’lar oluşturduktan sonra, bu VLAN’ları haberleştirmek için Cisco Router üzerinde konfigürasyon yapacağız. Bir önceki yazıyı mutlaka okuyunuz ve daha sonra VLAN yönlendirme işlemi uygulayabilirsiniz.

   Adım 1

Cisco Packet Tracer’da aşağıdaki görüntüdeki gibi bir topoloji oluşturunuz. Aşağıdaki görüntüde VLAN konfigürasyonu yapılmıştır. Inter-VLAN Routing konfigürasyonu için Cisco Router üzerine tıklayınız.

Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu

   Adım 2

Cisco Router konfigürasyon penceresinde, CLI sekmesine tıklayınız. Daha sonra Cisco Packet Tracer VLAN yönlendirme için aşağıdaki komutları sırasıyla uygulayınız.

Router#conf t
Router(config)# interface gigabitethernet0/0
Router(config-if)# no ip address
Router(config-if)# no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)# exit
Router(config)# interface gigabitethernet0/0.10
%LINK-5-CHANGED: Interface GigabitEthernet0/0.10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.10, changed state to up
Router(config-subif)# encapsulation dot1q 10
Router(config-subif)# ip address 192.168.10.1 255.255.255.0
Router(config-subif)# exit
Router(config)# interface gigabitethernet0/0.20
%LINK-5-CHANGED: Interface GigabitEthernet0/0.20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.20, changed state to up
Router(config-subif)# encapsulation dot1q 20
Router(config-subif)# ip address 192.168.20.1 255.255.255.0
Router(config-subif)# exit
Router(config)# interface gigabitethernet0/0.30
%LINK-5-CHANGED: Interface GigabitEthernet0/0.30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.30, changed state to up
Router(config-subif)# encapsulation dot1q 30
Router(config-subif)# ip address 192.168.30.1 255.255.255.0
Router(config-subif)# end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router# wr
Building configuration...
[OK]
Router#

Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu

   Adım 3

Cisco Router üzerinde Subinterface’ler oluşturduktan sonra, CLI komut isteminde show ip interface brief komutunu uygulayarak Subinterface’lerin durumunu kontrol edebiliriz.

Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu

Cisco Router’ı konsol bağlantısı ile yapılandırmak için, Cisco Packet Tracer Konsol Bağlantısı adlı yazıya göz atınız…

   Adım 4

Cisco Packet Tracer çalışma alanında PC0’a tıklayınız ve açılan pencereden komut istemini açınız. PC0’dan VLAN20 ve VLAN30’a üye olan PC’lere ping atınız. Ping işlemi aşağıdaki görüntüdeki gibi başarısız olacaktır.

Ping işleminin başarısız olmasının sebebi, Cisco Router’a bağlı olan Cisco Switch Gig0/1 arayüzünün TRUNK olarak yapılandırılmamasıdır.

TRUNK port üzerinden birden fazla VLAN’ın geçebilmesi sağlanır.

Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu

   Adım 5

Cisco Switch üzerine tıklayınız ve ardından CLI sekmesinde, GigabitEthernet0/1 arayüzünü TRUNK port olarak yapılandırınız.

Switch# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface gigabitethernet 0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
Switch(config-if)# end
%SYS-5-CONFIG_I: Configured from console by console
Switch# wr
Building configuration...
[OK]

Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu

   Adım 6

Cisco Packet Tracer VLAN yönlendirme adımlarını tamamladıktan sonra, PC0 üzerinden diğer VLAN’lara üye olan PC’lere ping attığımızda işlemin başarılı olduğunu görebilirsiniz.

Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu

Cisco Router üzerinde DHCP ile iki farklı ağa Ip adresi dağıtma işlemi için, Cisco Packet Tracer DHCP Konfigürasyonu adlı yazıyı okuyabilirsiniz…

Cisco Packet Tracer VLAN Yönlendirme Show Komutları

Router# show ip int brSwitch# show interfaces gigabitEthernet 0/1 switchportRouter#show running-configSwitch# show running-config

Router# show ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES unset up up
GigabitEthernet0/0.10 192.168.10.1 YES manual up up
GigabitEthernet0/0.20 192.168.20.1 YES manual up up
GigabitEthernet0/0.30 192.168.30.1 YES manual up up
GigabitEthernet0/1 unassigned YES unset administratively down down
Vlan1 unassigned YES unset administratively down down

Switch# show interfaces gigabitEthernet 0/1 switchport
Name: Gig0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none
Switch#

Router# show running-config
Building configuration…
Current configuration : 891 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX15243C2U
!
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

Switch# show running-config
Building configuration…
Current configuration : 1638 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0002.4ad8.4b01
ip address 192.168.10.100 255.255.255.0
!
interface Vlan20
mac-address 0002.4ad8.4b02
ip address 192.168.20.100 255.255.255.0
!
interface Vlan30
mac-address 0002.4ad8.4b03
ip address 192.168.30.100 255.255.255.0
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
Switch#

Cisco Packet Tracer VLAN Yönlendirme ⇒ Video

Cisco Packet Tracer VLAN yönlendirme ve Inter-VLAN Routing konfigürasyonu adımlarını video’yu izleyerek gerçekleştirebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz.

  Son Söz

Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu adlı yazıyı burada noktalandırıyorum. Cisco Packet Tracer üzerinde VLAN oluşturduktan sonra, VLAN yönlendirme adımlarını tamamladık. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Packet Tracer VLAN Yönlendirme | Inter-VLAN Routing Konfigürasyonu İlgili Yazılar;

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

six + 8 =