Cisco Packet Tracer VLAN Konfigürasyonu – Cisco Switch üzerinde VLAN (Sanal LAN) konfigürasyonu fiziksel ağ topolojierini mantıksal ağ topolojierine ayırmak için kullanılır. Cisco Switch üzerinde VLAN’lar yapılandırıldığında, VLAN’lar fiziksel bir ortamın sağladığı tüm fonksiyonlara sahiptir.
Cisco Packet Tracer VLAN Konfigürasyonu

Cisco Packet Tracer VLAN Konfigürasyonu

Cisco Packet Tracer VLAN Konfigürasyonu

Fiziksel bir network ortamında, belirli bir konumda bulunan kullanıcıları mantıksal olarak VLAN‘lar ile ayırabiliriz. Örneğin, genellikle muhasebe çalışanlarını aynı lokasyon içerisinde konumlandırırlar. Muhasebe çalışanları sadece bilgisayar başında işlerini yaparlar. Cisco Switch üzerinde Muhasebe VLAN’ı oluşturarak kullanıcıları bu grupta toplayabiliriz.

Gerçek senaryoda, bu işlemi yaptığımızda, kullanıcılar bu değişiklikten etkinlenmezler. Sadece, VLAN bazlı kısıtlamalar oluşturarak başka bir VLAN grubuna erişimlerini kısıtlayabiliriz. VLAN (Sanal LAN) yapılandırmasının birden çok çözümü bulunmaktadır.

Cisco sınavlarına veya kendilerini geliştirmek isteyen kişi veya kişiler, ağ simulatör programlarını kullanarak bu işlemleri kendi bilgisayarlarında test edebilirler.

Önceki yazılarımızda, Cisco Packet Tracer SSH Bağlantısı, Cisco Packet Tracer Telnet Konfigürasyonu ve Cisco Packet Tracer DHCP konfigürasyonu konularını açıklamıştık.

Bu yazımızda, Cisco Packet Tracer VLAN konfigürasyonu, Cisco Switch VLAN oluşturma, Cisco Switch VLAN yapılandırması, Cisco Switch VLAN tanımlama ve Packet Tracer Cisco Switch konfigürasyonu nasıl yapılır konularına değineceğiz.

Cisco Switch VLAN Oluşturma

Cisco Packet Tracer VLAN konfigürasyonu adımlarına artık geçebiliriz.

   Adım 1

Cisco Packet Tracer VLAN konfigürasyonu ve Cisco Switch VLAN oluşturma için öncelikle aşağıdaki görüntüdeki gibi ağ topolojisi oluşturunuz.

Cisco Packet Tracer VLAN Konfigürasyonu

   Adım 2

Cisco Switch üzerine bir kez tıklayınız ve ardından CLI sekmesine açınız.

Cisco Packet Tracer VLAN Konfigürasyonu

   Adım 3

Cisco Packet Tracer’da Cisco Switch VLAN oluşturma komutları için aşağıdaki görüntüye bakabilirsiniz. Cisco Switch VLAN oluşturmak için aşağıdaki komutları sırasıyla uygulayınız.

Switch# conf t
Switch(config)# hostname SWITCH
SWITCH(config)# vlan 10
SWITCH(config-vlan)# name VLAN10
SWITCH(config-vlan)# exit
SWITCH(config)# vlan 20
SWITCH(config-vlan)# name VLAN20
SWITCH(config-vlan)# exit
SWITCH(config)# vlan 30
SWITCH(config-vlan)# name VLAN30
SWITCH(config-vlan)# exit

Cisco Packet Tracer VLAN Konfigürasyonu

Cisco Switch VLAN oluşturma adımlarını tamamladık. Şimdi, topolojimizden yola çıkarak, yukarıdaki görüntüde gördüğünüz Fa0/1 gibi Cisco Switch arayüzlerini, oluşturduğumuz VLAN’lara atayacağız.

Cisco Switch Arayüzlerini VLAN’lara Atama

Cisco Switch arayüzlerini VLAN’lara atama işleminden sonra, istemci bilgisayarları mantıksal olarak birbirinden ayıracağız.

   Adım 1

Cisco Switch üzerinde ayrıcalıklı yapılandırma modundan, küresel yapılandırma moduna (config mode) geçiş yapınız. Ağ topolojisine göre Switch arayüzlerine bağlı olan istemci bilgisayarları VLAN’lara üye yapalım.

Kırmızı bölgedeki istemcileri VLAN10’a atamak için aşağıdaki komutları sırasıyla uygulayınız.

SWITCH# conf t
SWITCH(config)# interface fastethernet 0/1
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 10
SWITCH(config-if)# exit
SWITCH(config)# interface fastethernet 0/2
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 10
SWITCH(config-if)# exit
SWITCH(config)# end

Cisco Packet Tracer VLAN Konfigürasyonu

   Adım 2

Mavi bölgedeki istemcileri VLAN20’a atamak için aşağıdaki komutları sırasıyla uygulayınız.

SWITCH# conf t
SWITCH(config)# interface fastethernet 0/3
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 20
SWITCH(config-if)# exit
SWITCH(config)# interface fastethernet 0/4
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 20
SWITCH(config-if)# exit
SWITCH(config)# end

Cisco Packet Tracer VLAN Konfigürasyonu

   Adım 3

Yeşil bölgedeki istemcileri VLAN20’a atamak için aşağıdaki komutları sırasıyla uygulayınız.

SWITCH# conf t
SWITCH(config)# interface fastethernet 0/5
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 30
SWITCH(config-if)# exit
SWITCH(config)# interface fastethernet 0/6
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 30
SWITCH(config-if)# exit
SWITCH(config)# end

Cisco Packet Tracer VLAN Konfigürasyonu

Cisco Packet Tracer VLAN konfigürasyonu adımlarında, Cisco Switch VLAN oluşturma ve Cisco Switch arayüzlerini VLAN’lara atama işlemlerini tamamladık.

   Adım 4

Cisco Switch üzerinde ayrıcalıklı yapılandırma kipinde, show vlan komutunu uygulayarak VLAN atama işlemini görebilirsiniz.

Cisco Packet Tracer VLAN Konfigürasyonu

   Adım 5

PC0 ve PC1 istemcisi VLAN10’a atanmıştır. PC0’dan PC1’e ping attığımızda işlemin başarılı olduğunu görebilirsiniz.

Cisco Packet Tracer VLAN Konfigürasyonu

   Adım 6

PC0’dan VLAN20’ya üye olan PC2’ye ping atıldığında, ping işlemi başarısız olacaktır.

Cisco Packet Tracer VLAN Konfigürasyonu

   Adım 7

PC0’dan VLAN30’ya üye olan PC4’ye ping atıldığında da, ping işlemi başarısız olacaktır.

Cisco Packet Tracer VLAN Konfigürasyonu

VLAN’lara arası ping işlemi başarısız olmuşur. VLAN’lar arası iletişimin kurulması için Inter VLAN Routing (İç Sanal LAN Yönlendirme) yapmamız gereklidir.

Packet Tracer’da temel bir ağ nasıl oluşturulur? Sorunun cevabını Cisco Packet Tracer Basit Ağ Kurulumu adlı yazıda bulabilirsiniz…

Cisco Switch VLAN Ip Adresi Verme

Cisco Switch VLAN Ip adresi verme işlemi, oluşturulan VLAN’lara farklı Ip bloklarından yönetim Ip adresi verilmesi anlamına gelir. Oluşturulan her VLAN için yönetim Ip adresi verilebilir.

Ağ topolojimizden devam ederek, oluşturduğumuz VLAN10, VLAN20 ve VLAN30 için yönetim Ip adresleri verelim.

   Adım 1

Cisco Switch VLAN Ip adresi verme adımında, VLAN’ları yapılandırmak için aşağıdaki komutları sırasıyla uygulayınız.

SWITCH#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SWITCH(config)#interface vlan 10
SWITCH(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
SWITCH(config-if)#ip address 192.168.10.100 255.255.255.0
SWITCH(config-if)#no shutdown
SWITCH(config-if)#exit
SWITCH(config)#
SWITCH(config)#interface vlan 20
SWITCH(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
SWITCH(config-if)#ip address 192.168.20.100 255.255.255.0
SWITCH(config-if)#no shutdown
SWITCH(config-if)#exit
SWITCH(config)#
SWITCH(config)#interface vlan 30
SWITCH(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up
SWITCH(config-if)#ip address 192.168.30.100 255.255.255.0
SWITCH(config-if)#no shutdown
SWITCH(config-if)#end
SWITCH#

Cisco Packet Tracer VLAN Konfigürasyonu

   Adım 2

Cisco Switch Ip adresi verdikten sonra, Cisco Switch üzerinde VLAN arayüz ve Ip adreslerini görmek için show ip interface brief komutunu uygulayınız.

Cisco Packet Tracer VLAN Konfigürasyonu

   Adım 3

PC0’dan VLAN 10 yönetim Ip adresine (192.168.10.100) ping attığımızda işlem başarılıdır.

Cisco Packet Tracer VLAN Konfigürasyonu

   Adım 4

PC0’dan VLAN 20 ve VLAN 30 yönetim Ip adreslerine (192.168.20.100 ve 192.168.30.100) ping attığımızda işlem başarısızdır.

Cisco Packet Tracer VLAN Konfigürasyonu

   Adım 5

PC2’den VLAN 20 yönetim Ip adresine (192.168.20.100) ping attığımızda işlem başarılı olacaktır. Fakat, VLAN 30 yönetim Ip adresine (192.168.30.100) ping attığımızda işlem başarısız olacaktır.

Cisco Packet Tracer VLAN Konfigürasyonu

Cisco Packet Tracer’da konsol bağlantısı nasıl yapılır? Sorunun cevabı için, Cisco Packet Tracer Konsol Bağlantısı adlı yazıyı okuyabilirsiniz…

Cisco Packet Tracer VLAN Konfigürasyonu Show Komutları

SWITCH#show vlanSWITCH#show vlan briefSWITCH#show running-config SWITCH#show ip interface brief

SWITCH#show vlan

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24, Gig0/1, Gig0/2
10 VLAN10 active Fa0/1, Fa0/2
20 VLAN20 active Fa0/3, Fa0/4
30 VLAN30 active Fa0/5, Fa0/6
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 – – – – – 0 0
10 enet 100010 1500 – – – – – 0 0
20 enet 100020 1500 – – – – – 0 0
30 enet 100030 1500 – – – – – 0 0
1002 fddi 101002 1500 – – – – – 0 0
1003 tr 101003 1500 – – – – – 0 0
1004 fdnet 101004 1500 – – – ieee – 0 0
1005 trnet 101005 1500 – – – ibm – 0 0

Remote SPAN VLANs
——————————————————————————

Primary Secondary Type Ports
——- ——— —————– ——————————————
SWITCH#

SWITCH#show vlan brief

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24, Gig0/1, Gig0/2
10 VLAN10 active Fa0/1, Fa0/2
20 VLAN20 active Fa0/3, Fa0/4
30 VLAN30 active Fa0/5, Fa0/6
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
SWITCH#

SWITCH#show running-config
Building configuration…

Current configuration : 1351 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SWITCH
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
end
SWITCH#

SWITCH#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/1 unassigned YES manual up up
FastEthernet0/2 unassigned YES manual up up
FastEthernet0/3 unassigned YES manual up up
FastEthernet0/4 unassigned YES manual up up
FastEthernet0/5 unassigned YES manual up up
FastEthernet0/6 unassigned YES manual up up
FastEthernet0/7 unassigned YES manual down down
FastEthernet0/8 unassigned YES manual down down
FastEthernet0/9 unassigned YES manual down down
FastEthernet0/10 unassigned YES manual down down
FastEthernet0/11 unassigned YES manual down down
FastEthernet0/12 unassigned YES manual down down
FastEthernet0/13 unassigned YES manual down down
FastEthernet0/14 unassigned YES manual down down
FastEthernet0/15 unassigned YES manual down down
FastEthernet0/16 unassigned YES manual down down
FastEthernet0/17 unassigned YES manual down down
FastEthernet0/18 unassigned YES manual down down
FastEthernet0/19 unassigned YES manual down down
FastEthernet0/20 unassigned YES manual down down
FastEthernet0/21 unassigned YES manual down down
FastEthernet0/22 unassigned YES manual down down
FastEthernet0/23 unassigned YES manual down down
FastEthernet0/24 unassigned YES manual down down
GigabitEthernet0/1 unassigned YES manual up up
GigabitEthernet0/2 unassigned YES manual down down
Vlan1 unassigned YES manual administratively down down
Vlan10 192.168.10.100 YES manual up up
Vlan20 192.168.20.100 YES manual up up
Vlan30 192.168.30.100 YES manual up up

Cisco Packet Tracer VLAN Konfigürasyonu ⇒ Video

Cisco Packet Tracer VLAN konfigürasyonu, Cisco Switch VLAN Ip adresi verme Cisco Switch VLAN tanımlama adımlarını video’yu izleyerek gerçekleştirebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Cisco Packet Tracer VLAN Konfigürasyonu adlı yazımızı burada noktalandırıyorum. Cisco Packet Tracer’de Cisco Switch üzerinde VLAN oluşturmak ve yönetim VLAN’larına Ip adresleri atadık. Bir sonraki yazımızda, VLAN’lar arası iletişim konusunu işleyeceğiz. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Packet Tracer VLAN Konfigürasyonu İlgili Yazılar

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir