Cisco Packet Tracer Static Routing Konfigürasyonu

Cisco Packet Tracer Static Routing Konfigürasyonu – Bu yazımızda iki farklı lokasyondaki ağları Static Routing (Statik Yönlendirme) ile birbirleri ile haberleştireceğiz.
Cisco Packet Tracer Static Routing Konfigürasyonu

Cisco Packet Tracer Static Routing Konfigürasyonu

Cisco Packet Tracer Static Routing Konfigürasyonu

Static Routing iki farklı Router‘ın alt ağlarını haberleştirmek için kullanılan bir yönlendirme protokoküdür. Cisco Router‘lar üzerinde Static Routing yapılandırmak basittir. Fakat Static Routing mantığını anlamak önemlidir.

2 tür yönlendirme türü vardır. Bunlar;

1. Static Routing (Statik Yönlendirme)
2. Dynamic Routing (Dinamik Yönlendirme)

Bu yazımızda, Static Routing nedir ve nasıl çalışır bahsettikten sonra küçük bir network ortamında yönlendirme yapılandıracağız.

Eğer network ortamı birkaç Router‘dan oluşuyorsa, yönlendirme için Static Routing kullanmanız önerilir. Çünkü, Router’lar Dynamic Routing ile yapılandırıldığında performans bakımından daha yavaş çalışmaktadır. Fakat, küçük bir ağ ortamında Statik Yönlendirme kullanılarak Router’ların daha performanslı çalışmasını sağlayabiliriz.

Statik Yönlendirme işleminde, herşeyi manuel yani kendiniz elle yapılandırmanız gerekmektedir. Dinamik yönlendirmelerde sadece bağlı olan ağ adresleri belirtilir ve Router’lar arasında paket alışverişi yapılarak bu ağ bilgileri kendi aralarında paylaşılır.

Büyüyen bir ağda Static Routing kullanılması zor bir işlemdir. Bunun yerine, Dinamik Routing kullanılmaktadır.

Bu yazımızda Cisco Packet Tracer üzerinde Cisco Router’larda Static Routing konfigürasyonu adımlarını gerçekleştireceğiz.

Packet Tracer’da Cisco Router’lar Üzerinde Statik Yönlendirme Yapılandırması

Cisco Packet Tracer‘da Statik Yönlendirme yapılandırması adımlarına artık geçebiliriz. Cisco yönlendiricilerde Statik yönlendirme işlemini adım adım yapılandıracağız.

   Adım 1

Cisco Packet Tracer programını açınız ve aşağıdaki görüntüdeki gibi ağ topolojisi oluşturunuz. Gerekli ayarlamaları yaptıktan sonra bilgisayarlara IP adresleri atayınız.

Basit ayarlamaları yapılandırabilmek için Cisco Packet Tracer kullanımı adlı yazıya göz atabilirsiniz.

Cisco Packet Tracer Static Routing Konfigürasyonu

   Adım 2

Cisco Router’ın GigabitEthernet ve Serial arayüzlerini yapılandırmak için R1 Router’ın CLI komut istemini açınız ve aşağıdaki komutları uygulayınız.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#
R1(config)#interface gigabitethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#
R1(config)#interface serial0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#

 
Cisco Packet Tracer Static Routing Konfigürasyonu

   Adım 3

Aynı şekilde Cisco Router R2‘nin de GigabitEthernet ve Serial arayüzlerini yapılandırınız.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#
R2(config)#interface gigabitethernet 0/0
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R2(config-if)#exit
R2(config)#
R2(config)#interface serial 0/1/0
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
R2(config-if)#end
R2#

 
Cisco Packet Tracer Static Routing Konfigürasyonu

   Adım 4

Static Routing yapılandırmadan önce, PC0‘dan varsayılan ağ geçidine ve Cisco Router R1’in Serial arayüzüne ping atınız. Ping işlemi aşağıdaki gibi başarılı bir şekilde gerçekleşecektir.

Cisco Packet Tracer Static Routing Konfigürasyonu

   Adım 5

Aynı şekilde PC1 üzerinden de varsayılan ağ geçidine ve onun bağlı olduğu Cisco Router R2 Serial arayüzüne ping attığınızda bağlantı başarılı olacaktır.

Cisco Packet Tracer Static Routing Konfigürasyonu

   Adım 6

Statik yönlendirmeyi daha iyi kavramak adına, PC0‘dan Cisco Router R2’nin Serial arayüzüne ve 192.168.5.0/24 ağındaki bir bilgisayara ping atınız. Ping işlemi aşağıdaki görüntüdeki gibi başarısız olacaktır.

Cisco Packet Tracer Static Routing Konfigürasyonu

   Adım 7

Aynı şekilde PC1‘den karşı network’e ping atınız.

Cisco Packet Tracer Static Routing Konfigürasyonu

   Adım 8

Cisco Router’lar arasındaki bağlantıyı sınamak için arayüzlerine ping atınız. Cisco Router’lar kendi arasında haberleşebileceklerdir.

Cisco Packet Tracer Static Routing Konfigürasyonu

   Adım 9

R2‘den R1‘e ping işlemi de başarılı olacaktır.

Cisco Packet Tracer Static Routing Konfigürasyonu

   Adım 10

Umarım bu adıma kadar herşey gayet iyi anlaşılmıştır. Şimdi, Cisco Router R1 üzerinde Static Routing konfigürasyonu için CLI komut istemini açınız ve aşağıdaki komutu uygulayınız.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ip route 192.168.10.0 255.255.255.0 10.1.1.2
R1(config)#exit
R1#

 
Cisco Packet Tracer Static Routing Konfigürasyonu

R1 üzerinde Static Routing konfigürasyonu yapılandırıldıktan sonra, show ip route komutunu çalıştırınız. Show komut çıktısında, S 192.168.10.0/24 [1/0] via 10.1.1.2 satırında Static Routing konfigürasyonu için kayıt eklendiğini görebilirsiniz.

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, GigabitEthernet0/0
L 192.168.5.1/32 is directly connected, GigabitEthernet0/0
S 192.168.10.0/24 [1/0] via 10.1.1.2
R1#

 
S    192.168.10.0/24 [1/0] via 10.1.1.2PC0, 192.168.10.0/24 ağ ortamına 10.1.1.2 IP adresi üzerinden ulaşacaktır.

   Adım 11

Cisco Router R2 üzerinde de Statik yönlendirmeyi etkinleştirmek için aşağıdaki komutu uygulayınız.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#ip route 192.168.5.0 255.255.255.0 10.1.1.1
R2(config)#
R2(config)#exit
R2#

 
Cisco Packet Tracer Static Routing Konfigürasyonu

R2 üzerinde show ip route komut çıktısını inceleyiniz.

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/0
L 10.1.1.2/32 is directly connected, Serial0/1/0
S 192.168.5.0/24 [1/0] via 10.1.1.1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/0
L 192.168.10.1/32 is directly connected, GigabitEthernet0/0
R2#

 
S    192.168.5.0/24 [1/0] via 10.1.1.1 ⇒ PC1, 192.168.5.0/24 ağ ortamına 10.1.1.1 IP adresi üzerinden ulaşacaktır.

   Adım 12

Cisco Packet Tracer Static Routing konfigürasyonu adımlarını tamamladıktan sonra, PC0‘dan PC1‘e ping atarak bağlantıyı test ediniz. İki farklı lokasyondaki ağlar birbirleriyle başarılı bir şekilde iletişim kuracaklardır.

Cisco Packet Tracer Static Routing Konfigürasyonu

   Adım 13

Aynı şekilde PC1‘den PC0‘a ping atıldığında ping işlemi aşağıdaki gibi başarılı olacaktır.

Cisco Packet Tracer Static Routing Konfigürasyonu

Cisco Packet Tracer Static Routing Konfigürasyonu Show Komutları
[su_tabs active=”1″]
[su_tab title=”R1#show running-config”]


R1#show running-config
Building configuration...

Current configuration : 813 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX152494BG
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.0
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.10.0 255.255.255.0 10.1.1.2
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
R1#

[/su_tab]
[su_tab title=”R2#show running-config”]


R2#show running-config
Building configuration...

Current configuration : 793 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524GA8Z
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.2 255.255.255.0
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.5.0 255.255.255.0 10.1.1.1
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

[/su_tab]
[/su_tabs]

Cisco Packet Tracer Static Routing Konfigürasyonu ⇒ Video

Cisco Packet Tracer kullanarak Cisco Router’lar üzerinde Static Routing konfigürasyonu adımlarını videoyu izleyerek gerçekleştirebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Cisco Packet Tracer Static Routing KonfigürasyonuCisco Packet Tracer‘da Cisco Router’lar üzerinde Statik Yönlendirme yaparak iki farklı konumda bulunan bilgisayarları haberleştirdik. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Packet Tracer Static Routing Konfigürasyonu İlgili Yazılar

[su_box title=”İlgili Yazılar” box_color=”#242424″ radius=”0″]
♦ Cisco Packet Tracer Basit Ağ Kurulumu
♦ Cisco Packet Tracer DHCP Konfigürasyonu
♦ Cisco Packet Tracer Telnet Konfigürasyonu
♦ Cisco Packet Tracer SSH Bağlantısı
♦ Cisco Packet Tracer Static NAT Konfigürasyonu
[/su_box]

Cisco Packet Tracer Static Routing Konfigürasyonu İlgili Dosya

[su_box title=”İlgili Dosya” box_color=”#242424″ radius=”0″]

Bu yazıda yapılandırılan ağ topolojisini aşağıdaki butondan bilgisayarınıza indirebilirsiniz…

PKT Dosyasını İndir

[/su_box]

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

two + 4 =

Show Buttons
Hide Buttons