Cisco Packet Tracer SSH Bağlantısı – SSH (Secure Shell – Güvenli Kabuk), ağ cihazlarının güvenli bir şekilde yönetimini sağlar. SSH protokolü erişim sağladığınız bir ağ cihazına güvenli bir bağlantı kurar ve bu sayede bağlantınıza kötü niyetli kişilerin erişimi engellenir.
Cisco Packet Tracer SSH Bağlantısı

Cisco Packet Tracer SSH Bağlantısı

Cisco Packet Tracer SSH Bağlantısı

Cisco Packet Tracer SSH bağlantısı işlemi, telnet bağlantısına göre çok güvenli bir protokoldür. SSH protokolü varsayılan olarak TCP 22 portu kullanır. Varsayılan port numarası isteğe göre değişebilir.

Cisco Router üzerinde SSH bağlantısı yapılandırmadan önce, SSH protokolünün iki sürümü vardır. Bu sürümler, Version 1 ve Version 2’dir. SSH V2, V1’e göre daha güvenli bir bağlantı sunmaktadır ve en yaygın kullanılan sürüm Version 2’dir. Cisco ağ aygıtları veya başka bir ağ cihazını uzaktan yönetimi için mümkün olduğunca SSH V2 sürümünü etkinleştirmeniz önerilir.

Cisco Packet Tracer SSH bağlantısı işleminde, Cisco Router IOS’ları varsayılan olarak gelmektedir ve pek çok özelliği desteklemektedir. Fakat, gerçek senaryoda Cisco Router IOS’u SSH bağlantısını desteklemesi gerekir. Aksi taktirde, Cisco Router üzerinde SSH’ı yapılandıramazsınız.

Gerçek senaryoda Cisco Router SSH etkinleştirmek için, Cisco IOS yazılımınızın dosya adında k9(crypto) ifadesinin yer aldığından emin olunuz.

Önceki yazılarımızda, Cisco Packet Tracer Telnet Bağlantısı ve Cisco Packet Tracer Konsol Bağlantısı adlı konuları açıklamıştık. Bu yazımızda, Cisco Packet Tracer SSH bağlantısı nasıl yapılır, nasıl etkinleştirilir ve Packet Tracer’da Cisco Router SSH konfigürasyonu adımlarını öğreneceğiz.

Cisco Packet Tracer’da Cisco Router Üzerinde SSH Etkinleştirme

Cisco Packet Tracer’da Cisco Router üzerinde SSH etkinleştirme adımlarına artık geçebiliriz. Öncelikle Packet Tracer programını çalıştırınız ve ardından aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz.

   Adım 1

Aşağıdaki topolojide Switch’e bağlı bir adette Cisco Router vardır. Cisco Router’ı ağ topolojisine eklememizin nedeni ise, Cisco Router üzerinden de SSH bağlantısını gerçekleştirmektir. Kısacası, Router’dan Router’da SSH bağlantısı yapacağız.

Cisco Packet Tracer SSH Bağlantısı

   Adım 2

SYSNETTECH olarak adlandırılan Cisco Router üzerine bir kez tıklayarak CLI komut istemini açınız ve ilk yapılandırmayı atlamak için No yazarak devam ediniz.

Cisco Packet Tracer SSH Bağlantısı

   Adım 3

Cisco Packet Tracer SSH konfigürasyonu için aşağıdaki gerekli komutları sırasıyla uygulayınız.

[code] Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname SYSNETTECH
SYSNETTECH(config)#interface gigabitethernet 0/0
SYSNETTECH(config-if)#ip address 192.168.1.1 255.255.255.0
SYSNETTECH(config-if)#no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
SYSNETTECH(config-if)#exit
SYSNETTECH(config)#ip domain name sysnettechsolutions.com
SYSNETTECH(config)#crypto key generate rsa
The name for the keys will be: SYSNETTECH.sysnettechsolutions.com
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.
How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable…[OK] SYSNETTECH(config)#ip ssh version 2
*Mar 1 0:6:12.698: %SSH-5-ENABLED: SSH 1.99 has been enabled

SYSNETTECH(config)#ip ssh time
SYSNETTECH(config)#ip ssh time-out 10
SYSNETTECH(config)#ip ssh authentication-retries 3
SYSNETTECH(config)#line vty 0 4
SYSNETTECH(config-line)#login local
SYSNETTECH(config-line)#privilege level 15
SYSNETTECH(config-line)#trans
SYSNETTECH(config-line)#transport input ssh
SYSNETTECH(config-line)#exit
SYSNETTECH(config)#username cisco privilege 15 password cisco123
SYSNETTECH(config)#end
SYSNETTECH#wr
Building configuration…
[OK] SYSNETTECH#
[/code]

Cisco Packet Tracer SSH Bağlantısı

   Adım 4

Router üzerinde SSH etkinleştirildikten sonra, PC1 Ip adresi ayarlarını aşağıdaki görüntüdeki gibi yapılandırınız.

Cisco Packet Tracer SSH Bağlantısı

   Adım 5

R1 adlı Router’ı arayüzünü hızlıca yapılandırmak için, Config sekmesinde GigabitEthernet0/0 arayüzü Port Status (Port Durumu) seçeneğini On (Açık) olarak yapılandırınız.

Cisco Packet Tracer SSH Bağlantısı

   Adım 6

PC1 üzerinden Komut istemini açınız ve daha sonra Cisco Router’a SSH bağlantısı yapmak için aşağıdaki komutu yazınız ve Enter tuşuna basınız.

[code]ssh -l cisco 192.168.1.1[/code]

-l : Login anlamına gelmektedir.
cisco : Router üzerine SSH bağlantısı gerçekleştirmek için kullanılacak kullanıcı adı.
192.168.1.1 : Cisco Router Ip adresi.

Cisco Packet Tracer SSH Bağlantısı

   Adım 7

Enter tuşuna basar basmaz parola sorulacaktır. Parolayı cisco123 olarak ayarlamıştık. Parolayı da girdikten sonra başarılı bir şekilde Cisco Router SSH bağlantısı gerçekleştirdik.

Cisco Packet Tracer SSH Bağlantısı

   Adım 8

Komut isteminde, show ssh komutunu uyguladıktan sonra, çalışan SSH sürümünü aşağıdaki görüntüde görebiliriz.

Cisco Packet Tracer SSH Bağlantısı

   Adım 9

Bu adımda, Cisco Router’dan Cisco Router’a SSH bağlantısı için aşağıdaki komutu uygulayınız. Bu komut PC1 ile bağlandığımız komut ile birebir aynıdır. Bu adım Router’ın da her türlü bilgisayar gibi çalıştığını göstermek içindir.

[code]ssh -l cisco 192.168.1.1[/code]

Cisco Packet Tracer SSH Bağlantısı

   Adım 10

Cisco Packet Tracer SSH bağlantısında, Router’a SSH bağlantısı için parolayı yazınız ve Enter tuşuna basınız.

Cisco Packet Tracer SSH Bağlantısı

   Adım 11

Cisco Router’dan Cisco Router’a başarılı bir şekilde SSH bağlantısı gerçekleştirildi.

Cisco Packet Tracer SSH Bağlantısı

Cisco yönlendirici üzerinde DHCP ayarları için, Cisco Packet Tracer DHCP Konfigürasyonu adlı yazıyı okuyabilirsiniz…

Cisco Packet Tracer SSH Bağlantısı Show Komutları

SYSNETTECH#show running-configSYSNETTECH#show sshSYSNETTECH#show ip ssh

SYSNETTECH#show running-config
Building configuration…

Current configuration : 799 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SYSNETTECH
!
!
!
no ip cef
no ipv6 cef
!
!
!
username cisco privilege 15 password 0 cisco123
!
!
license udi pid CISCO1941/K9 sn FTX152488GK
!
!
ip ssh version 2
ip ssh time-out 10
ip domain-name sysnettechsolutions.com
!
!
spanning-tree mode pvst
!
!
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login local
transport input ssh
privilege level 15
!
!
end
SYSNETTECH#

SYSNETTECH#show ssh
Connection Version Mode Encryption Hmac State Username
133 1.99 IN aes128-cbc hmac-sha1 Session Started cisco
133 1.99 OUT aes128-cbc hmac-sha1 Session Started cisco
133 1.99 IN aes128-cbc hmac-sha1 Session Started cisco
133 1.99 OUT aes128-cbc hmac-sha1 Session Started cisco
%No SSHv1 server connections running.
SYSNETTECH#

SYSNETTECH#show ip ssh
SSH Enabled – version 2.0
Authentication timeout: 10 secs; Authentication retries: 3
SYSNETTECH#

Cisco Packet Tracer SSH Bağlantısı ⇒ Video

Cisco Packet Tracer SSH bağlantısı ve Cisco Packet Tracer SSH kullanımı adımlarını video’yu izleyerek gerçekleştirebilir ve YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Cisco Packet Tracer SSH Bağlantısı adlı yazıyı burada noktalandırıyorum. SSH bağlantısı, Telnet bağlantısına göre her zaman güvenli bir protokoldür. Mümkün olduğunca, SSH protokolünü kullanmanızı öneririz. Ayrıca, gerçek senaryoda Cisco IOS yazımının k9(crypto) özelliğinin olduğundan emin olunuz. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Packet Tracer SSH Bağlantısı İlgili Yazılar

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir