Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı – OSI Layer 2 katmanında döngüleri (Loop) engellemek amacıyla Spanning Tree Protokolü‘nü yapılandırırken ağ topolojimiz üzerinde hangi Cisco Switch’lerin Root Bridge olacağını da konfigüre ederiz.
Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı

Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı

Ağ üzerindeki Cisco Switch’leri Root Bridge olarak seçerken genellikle Priority komutunu değiştiririz. Bir önceki yazımızda Cisco Packet Tracer Root Bridge Konfigürasyonu adımlarını incelemiştik. Bu yazımızda Root Primary komutunu kullanarak Root Bridge seçimini yapacağız.

Root Primary komutu kullanımına ek olarak, Root Bridge Switch’e ulaşılamadığı durumda yardımcı bir Root Bridge Switch yapılandıracağız. Genelde ağ dağıtım katmanında ikinci bir Root Bridge Switch’in Priority değerini değiştirerekte yapabiliriz.

Spanning Tree Root Primary ve Root Secondary Komutu Kullanımı

Cisco Packet Tracer programını kullanarak küçük bir ağ topoloji üzerinde Spanning Tree Vlan (Vlan Numarası) Root Primary komutunu uygulayarak Root Bridge olacak Switch’i seçeceğiz. Root Primary komutu ile Switch’lerin Priority değerleri otomatik olarak belirlenecektir.

   Adım 1

Cisco Packet Tracer programını açınız ve aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz.

Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı

   Adım 2

Root Bridge ve Secondary Root Bridge olacak Cisco Switch’leri belirleyiniz.

Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı

   Adım 3

Switch SW1 CLI komut istemini açınız ve config modda aşağıdaki komutu uygulayınız.

SW1>en
SW1#conf t
SW1(config)#
SW1(config)#spanning-tree vlan 1 root primary

 
Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı

   Adım 4

Switch SW1 Root Bridge olduğunu doğrulamak için privileged mod üzerinde show spanning-tree komutunu uygulayınız.

SW1#show spanning-tree
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    24577
             Address     00D0.D331.E8B1
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24577  (priority 24576 sys-id-ext 1)
             Address     00D0.D331.E8B1
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/24           Desg FWD 19        128.24   P2p
Gi0/1            Desg FWD 4         128.25   P2p
Gi0/2            Desg FWD 4         128.26   P2p

SW1#

 
Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı

Yukarıdaki show spanning-tree çıktısında gördüğünüz gibi, Cisco Switch SW1 Root Bridge olarak yapılandırıldı. Cisco Switch’in Priority değerini değiştirmeden Spanning-Tree Vlan 1 Root Primary komutu ile bu işlemi kolaylıkla gerçekleştirdik.

   Adım 5

Cisco Switch Root Secondary komutu kullanımı da oldukça basittir. Packet Tracer ağ topolojisinde belirlediğiniz Switch’i Root Secondary olarak yapılandırmak için SW2 CLI komut istemini açınız ve aşağıdaki komutu uygulayınız.

SW2>en
SW2#conf t
SW2(config)#spanning-tree vlan 1 root secondary

 
Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı

   Adım 6

Cisco Switch SW2 CLI komut isteminde show spanning-tree komutunu çalıştırınız.

SW2#show spanning-tree
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    24577
             Address     00D0.D331.E8B1
             Cost        4
             Port        25(GigabitEthernet0/1)
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    28673  (priority 28672 sys-id-ext 1)
             Address     00E0.F963.95C8
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/24           Desg FWD 19        128.24   P2p
Fa0/10           Desg FWD 19        128.10   P2p
Gi0/1            Root FWD 4         128.25   P2p
Gi0/2            Desg FWD 4         128.26   P2p

SW2#

 
Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı

Yukarıdaki görüntüden Cisco Switch SW2’nin Priority değerinin otomatik olarak ayarlandığını görebilirsiniz.

   Adım 7

Yapılandırılan her iki Cisco Switch üzerinde show running-config komutunu uyguladığınızda, Root Primary ve Root Secondary komutlarının kullanımı sonucu Switch’lerin Priority değerleri otomatik olarak değiştirildiğini görebilirsiniz.

Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı

Spanning Tree Root Primary Komutu Kullanımı İlgili Show Komutları

SW1#show running-configSW2#show running-config
SW1#show running-config
Building configuration…

Current configuration : 1109 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW1
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1 priority 24576
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
end

SW1#

SW2#show running-config
Building configuration…

Current configuration : 1109 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1 priority 28672
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
end

SW2#

Cisco Packet Tracer Root Primary ve Root Secondary Konfigürasyonu ⇒ Video

Cisco Packet Tracer programını kullanarak Cisco Switch’ler üzerinde Spanning Tree Root Primary ve Root Secondary yapılandırma adımlarını aşağıdaki videoyu izleyerek gerçekleştirebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı – Bu yazımızda Cisco Packet Tracer üzerinde manuel Cisco Switch Root Bridge yapılandırma adımlarını inceledik. Daha gelişmiş ağ topolojilerinde Switch‘lerin Priority değerlerini iyi ayarlamanız gerekir. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı

Cisco Packet Tracer Spanning Tree Root Primary Komutu Kullanımı İlgili Dosya
İlgili Dosya

Bu yazıda yapılandırılan Packet Tracer PKT dosyasını bilgisayarınıza indirebilirsiniz…

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

nine + 2 =