Cisco Packet Tracer RIP Version 2 Konfigürasyonu – RIP Routing protokolünün 2 sürümü vardır. RIP Version 1 sürümü yönlendirme tablosu güncellemelerini Broadcast (255.255.255.255) olarak yapmaktadır. RIP Version 2 sürümü ise Multicast yayın yapmaktadır.
Cisco Packet Tracer RIP Version 2 Konfigürasyonu

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

RIP Routing protokolü Version 1 sürümü yapılandırmasını, Cisco Packet Tracer RIP Konfigürasyonu adlı yazıda incelemiştik. Bu yazımızda, RIP Version 2 (V2) sürümünün yapılandırmasını gerçekleştireceğiz.

RIP Versiyon 2, RFC 2453‘te tanımlanmıştır. Ayrıca, RIP V1 konfigürasyonunu videoyu izleyerek gerçekleştirebilirsiniz…

RIP Version 2 yönlendirme tablosu güncellemelerini Multicast olarak gönderir. RIP Version 1 VLSM ve CIDR desteklemez. RIP Version 2 ise VLSM ve CIDR desteklemektedir.

Dolayısıyla RIPV1 yapılandırırken tüm cihazlar aynı ağ üzerinde olması gerekmektedir. RIP Version 2’de böyle bir zorunluluk yoktur. RIP V2 sürümü ile özel ağ adreslerini daha performanslı kullanabiliriz.

Packet Tracer’da Cisco Router RIP Versiyon 2 Konfigürasyonu

Cisco Packet Tracer’da Cisco Rotuer RIP versiyon 2 konfigürasyonu adımlarına artık geçebiliriz. İki Cisco Router arasında 192.168.5.0/24 IP bloğunu 2 farklı ağa ayırarak, RIP Version 2 konfigürasyonunu yapılandıracağız.

RIP Version 2 konfigürasyonu için aşağıdaki adımları sırasıyla takip ediniz.

   Adım 1

Cisco Packet Tracer programını açınız ve aşağıdaki görüntüdeki gibi ağ topolojisi oluşturunuz. Burada IP adresi bloklarına dikkat ediniz. IP adresleri ve subnet mask’leri iki Router arasında farklı olacaktır.

Cisco Router R1 ve R2 arasındaki Serial bağlantının IP bloğu ise, 10.1.1.0/30 – 255.255.255.252’dir.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 2

Cisco Router R1 CLI komut istemini açınız ve GigabitEthernet ve Serial arayüzlerini yapılandırınız. Bu işlemi aşağıdaki komutları uygulayarakta yapabilirsiniz.

[code] Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface gigabitethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.128
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#ex
R1(config)#interface serial 0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#end
R1#
[/code]

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 3

Cisco Router R2 arayüzlerini de yapılandırınız. Bu işlem içinde, aşağıdaki komutları uygulayabilirsiniz.

[code] Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface gigabitethernet 0/1
R2(config-if)#ip address 192.168.5.129 255.255.255.128
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R2(config-if)#exit
R2(config)#interface serial 0/1/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
R2(config-if)#end
R2#
[/code]

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 4

192.168.5.0/25 – 255.255.255.128 ağını, PC1’den Ping atarak test ediniz. PC1’den PC2 ve R1 Serial 0/1/0 arayüzüne Ping atarak bağlantıyı test ediniz.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 5

PC1’den Cisco Router R2 Serial ve GigabitEthernet arayüzlerine Ping işlemi başarısız olacaktır. Çünkü, Cisco Router’larda RIP V2 yönlendirme protokolü etkinleştirilmedi.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 6

Yukarıdaki işlemleri aynı şekilde, 192.168.5.128/25 ağındaki PC3 üzerinden de gerçekleştiriniz.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 7

PC3’ten Cisco Router R1 Serial ve GigabitEthernet arayüzlerine Ping işlemi aşağıdaki gibi başarısız olacaktır.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 8

Cisco Packet Tracer RIP Version 2 konfigürasyonu yapılandırmak için, Cisco Router R1’e tıklayınız ve CLI komut isteminde aşağıdaki komutları uygulayınız.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.1.1.0
R1(config-router)#network 192.168.5.0
R1(config-router)#end
R1#
[/code]

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 9

Cisco Router R2 üzerinde de RIP Version 2’yi etkinleştiriniz ve Router’a bağlı olan ağları tanımlayınız. Burada, network 192.168.5.128 ağına dikkat ediniz.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.5.128
R2(config-router)#end
R2#
[/code]

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 10

Cisco Packet Tracer’da RIP Version 2’yi yapılandırdıktan sonra, PC1 üzerinden başarısız olan Ping adımlarını tekrar gerçekleştiriniz. Ping işlemi bu sefer aşağıdaki gibi başarılı olacaktır.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 11

Aynı işlemleri, PC3 üzerinden de gerçekleştirerek bağlantının doğruluğunu sağlayınız.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 12

Router R1 üzerinde show ip route komutunu uygulayarak, RIP Rota kayıtlarını inceleyebilirsiniz.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 13

Router R2 RIP Rota kayıtları da aşağıdaki gibidir.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 14

Cisco yönlendirici’lerde RIP Version 2’yi doğrulamak için debug ip rip komutunu uygulayarak, yönlendirme güncelleştirmelerinin nasıl yapıldığını görebilirsiniz.

Aşağıdaki görüntüde RIP V2’nin 224.0.0.9 Multicast adresi ile güncelleme yaptığını inceleyebilirsiniz.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 15

Cisco Router R2 yönlendirme güncelleştirmeleri de aşağıdaki gibidir.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 16

RIP Versiyon 2’yi doğrulamanın diğer bir yolu da show ip protocols komutunu kullanmaktır. R1 üzerinde bu komutu çalıştırınız ve çıkan sonuçlardan RIP Versiyon 2’nin kullanıldığını görebilirsiniz.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

   Adım 17

Aynı şekide, Router R2 üzerinde de show ip protocols komutunu uygulayarak çıkan sonuçlara göz atabilirsiniz.

Cisco Packet Tracer RIP Version 2 Konfigürasyonu

Cisco Packet Tracer RIP Version 2 Konfigürasyonu Show Komutları

R1#show ip routeR2#show ip routeR1#debug ip ripR2#debug ip ripR1#show ip protocolsR2#show ip protocolsR1#show running-configR2#show running-config
R1#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 3 subnets, 3 masks
R 192.168.5.0/24 [120/1] via 10.1.1.2, 00:00:26, Serial0/1/0
C 192.168.5.0/25 is directly connected, GigabitEthernet0/0
L 192.168.5.1/32 is directly connected, GigabitEthernet0/0
R1#

R2#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/1
L 10.1.1.2/32 is directly connected, Serial0/1/1
192.168.5.0/24 is variably subnetted, 3 subnets, 3 masks
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:04, Serial0/1/1
C 192.168.5.128/25 is directly connected, GigabitEthernet0/1
L 192.168.5.129/32 is directly connected, GigabitEthernet0/1
R2#

R1#debug ip rip
RIP protocol debugging is on
R1#RIP: sending v2 update to 224.0.0.9 via Serial0/1/0 (10.1.1.1)
RIP: build update entries
192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/0 (192.168.5.1)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R1#
R2#debug ip rip
RIP protocol debugging is on
R2#RIP: sending v2 update to 224.0.0.9 via Serial0/1/1 (10.1.1.2)
RIP: build update entries
192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/1 (192.168.5.129)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R2#
R1#show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 13 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/1/0 2 2
GigabitEthernet0/0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.2 120 00:00:02
Distance: (default is 120)
R1#
R2#show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 27 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/1/1 2 2
GigabitEthernet0/1 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.1 120 00:00:14
Distance: (default is 120)
R2#
R1#show running-config
Building configuration…
Current configuration : 834 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524GC61
!
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.128
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R1#
R2#show running-config
Building configuration…
Current configuration : 816 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX15241561
!
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.5.129 255.255.255.128
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 10.1.1.2 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

Cisco Packet Tracer RIP Version 2 Konfigürasyonu ⇒ Video

Cisco Packet Tracer RIP Versiyon 2 yapılandırma ve konfigürasyonu adımlarını videoyu izleyerek gerçekleştirebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Cisco Packet Tracer RIP Version 2 Konfigürasyonu – Bu yazımızda, RIP Version 2 konfigürasyonu adımlarını gerçekleştirdik. RIP Versiyon 2’nin Multicast (224.0.0.9) yayın yaptığını inceledik. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Packet Tracer RIP Version 2 Konfigürasyonu İlgili Yazılar

Cisco Packet Tracer RIP Version 2 Konfigürasyonu İlgili Dosya
İlgili Dosya

Bu yazıda yapılandırılan RIP projesini, PKT dosyası olarak aşağıdaki butondan bilgisayarınıza indirebilirsiniz…

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

18 + nineteen =