Cisco Packet Tracer RIP Konfigürasyonu – RIP protokolü Router’larda kullanılan bir yönlendirme protokolüdür. Router’lar üzerinde RIP yönlendirme protokolünü yapılandırmak basit ve kolaydır.
Cisco Packet Tracer RIP Konfigürasyonu

Cisco Packet Tracer RIP Konfigürasyonu

Cisco Packet Tracer RIP Konfigürasyonu

RIP (Routing Information Protocol – Yönlendirme Bilgisi Protokolü) yaygın olarak kullanılan ve çoğu yönlendiricinin desteklediği bir uzaklık vektörü yönlendirme protokolüdür. Diğer bir deyişle, RIP bir Dinamik Yönlendirme protokolüdür.

Önceki yazımızda, RIP Yönlendirme Protokolü hakkında bilgiler vermiştik. Bu yazımızda, Cisco Packet Tracer üzerinde RIP konfigürasyonu adımlarını gerçekleştireceğiz.

Cisco Router’lar üzerinde RIP yapılandırmak için, küresel yapılandırma modunda Router Rip komutu uygulanır. Daha sonra, RIP config modunda Cisco Router’a bağlı olan ağ adresleri tanımlanır.

Cisco Packet Tracer’da RIP Routing Konfigürasyonu

Bu yazımızda, RIP Version 1 sürümünü yapılandıracağız. Cisco Packet Tracer’da Cisco Router üzerinde RIP Routing konfigürasyonu için aşağıdaki adımları sırasıyla takip ediniz.

   Adım 1

Cisco Packet Tracer programını açınız ve aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz. Çalışma alanına eklediğiniz bilgisayarlara IP adresi veriniz ve ardından tüm aygıtları kablolayınız.

Cisco Packet Tracer basit kullanım adımlarını buradan gerçekleştirebilirsiniz…

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 2

Cisco Router R1, seri arayüzü ve gigabitethernet arayüzlerine IP adresi atayınız.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface serial 0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#exit
R1(config)#interface gigabitethernet 0/1
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R1(config-if)#end
R1#
[/code]

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 3

Cisco Router R2 komut istemini açınız ve arayüzlerine IP adresi veriniz.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface serial 0/1/1
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
R2(config-if)#exit
R2(config)#interface gigabitethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R2(config-if)#end
R2#
[/code]

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 4

Cisco Packet Tracer RIP konfigürasyonu yapılandırmadan önce, bilgisayarlar üzerinden arayüzlere Ping atarak bağlantıyı test ediniz. PC1 üzerinden R1 FastEthernet ve Serial arayüzlere Ping işlemi başarılı olacaktır.

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 5

R2 Router’ın Serial arayüzüne Ping işlemi başarısız olacaktır. Çünkü, herhangi bir yönlendirme protokolünü yapılandırılmadı.

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 6

Cisco Router R1 üzerinde RIP konfigürasyonu için aşağıdaki komutları uygulayınız.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#network 192.168.5.0
R1(config-router)#network 10.1.1.0
R1(config-router)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#
[/code]

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 7

Cisco Router R2 üzerinde de RIP konfigürasyonu için aşağıdaki komutları uygulayınız.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#network 192.168.10.0
R2(config-router)#network 10.1.1.0
R2(config-router)#end
R2#
%SYS-5-CONFIG_I: Configured from console by console
R2#
[/code]

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 8

Cisco Packet Tracer RIP konfigürasyonu adımlarını tamamladıktan sonra, Cisco Router’lar üzerinde show ip route komutunu uygulayınız ve aşağıdaki görüntüdeki gibi çıktıları kontrol ediniz.

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 9

Aynı şekilde, Cisco Router R2 üzerinde de yönlendirme rotalarını öğrenmek için show ip route komutunu uygulayınız.

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 10

Cisco Router’lar üzerinde RIP’i etkinleştirdikten sonra, PC1 üzerinden R2 Serial arayüzüne ve alt ağındaki PC3 ve PC4 bilgisayarlara Ping işlemi aşağıdaki gibi başarılı olacaktır.

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 11

192.168.10.0/24 ağından, 192.168.5.0/24 ağına da Ping işlemi başarılı bir şekilde gerçekleşecektir.

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 12

Cisco Router RIP konfigürasyonundan sonra, Router’lar üzerinde show ip protocols komutu ile RIP yönlendirme protokolünü kontrol edebilirsiniz.

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 13

Cisco Router R2 üzerinde show ip protocols komutu çıktısı aşağıdaki gibidir.

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 14

Cisco Router R1 üzerinde RIP konfigürasyonu ile ilgili diğer show komutunu inceleyebilirsiniz.

Cisco Packet Tracer RIP Konfigürasyonu

   Adım 15

Aynı şekilde, R2 üzerinde de aynı komutu uygulayarak inceleyebilirsiniz.

Cisco Packet Tracer RIP Konfigürasyonu

Cisco Packet Tracer RIP Konfigürasyonu Show Komutları

R1#show ip routeR2#show ip routeR1#show ip protocolsR2#show ip protocolsR1#show running-configR2#show running-configR1#show ip rip dtbseR2#show ip rip dtbse
R1#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, GigabitEthernet0/1
L 192.168.5.1/32 is directly connected, GigabitEthernet0/1
R 192.168.10.0/24 [120/1] via 10.1.1.2, 00:00:14, Serial0/1/0

R1#

R2#show ip route
Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/1
L 10.1.1.2/32 is directly connected, Serial0/1/1
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:09, Serial0/1/1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/1
L 192.168.10.1/32 is directly connected, GigabitEthernet0/1

R2#

R1#show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 7 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
GigabitEthernet0/1 1 2 1
Serial0/1/0 1 2 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.2 120 00:00:00
Distance: (default is 120)
R1#
R2#show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 14 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
GigabitEthernet0/1 1 2 1
Serial0/1/1 1 2 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.10.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.1 120 00:00:01
Distance: (default is 120)
R2#
R1#show running-config
Building configuration…

Current configuration : 823 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524N07E
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.0
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
network 192.168.5.0
!
ip classless
!
ip flow-export version 9
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R1#

R2#show running-config
Building configuration…

Current configuration : 805 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15248JFW
!
!
spanning-tree mode pvst
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 10.1.1.2 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
network 192.168.10.0
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

R1#show ip rip dtbse
10.1.1.0/24 auto-summary
10.1.1.0/24 directly connected, Serial0/1/0
192.168.5.0/24 auto-summary
192.168.5.0/24 directly connected, GigabitEthernet0/1
192.168.10.0/24 auto-summary
192.168.10.0/24
[1] via 10.1.1.2, 00:00:15, Serial0/1/0
R1#
R2#show ip rip dtbse
10.1.1.0/24 auto-summary
10.1.1.0/24 directly connected, Serial0/1/1
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.1, 00:00:03, Serial0/1/1
192.168.10.0/24 auto-summary
192.168.10.0/24 directly connected, GigabitEthernet0/1
R2#

Cisco Packet Tracer RIP Konfigürasyonu ⇒ Video

Cisco Packet Tracer RIP konfigürasyonu ve yapılandırmasını videoyu izleyerek gerçekleştirebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Cisco Packet Tracer RIP Konfigürasyonu – Bu yazımızda, Packet Tracer’da Cisco Router’lar üzerinde dinamik yönlendirme protokolü olan RIP Version 1’i yapılandırdık. RIP konfigürasyonu görüldüğü gibi basit ve kolaydır. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Packet Tracer RIP Konfigürasyonu İlgili Yazılar

Cisco Packet Tracer RIP Konfigürasyonu İlgili Dosya
İlgili Dosya

Cisco Packet Tracer RIP konfigürasyonu PKT dosyasını bilgisayarınıza aşağıdaki butona tıklayarak indirebilirsiniz…

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

five × 2 =