Cisco Packet Tracer Port Security Konfigürasyonu – Önceki yazımızda Cisco Switch’lerde Port Güvenliği hakkında kısaca bilgi vermiştik. Bu yazımızda Cisco Packet Tracer kullanarak Cisco Switch üzerinde Port Security yapılandıracağız.
Cisco Packet Tracer Port Security Konfigürasyonu

Cisco Packet Tracer Port Security Konfigürasyonu

Cisco Packet Tracer Port Security Konfigürasyonu

Cisco Switch’lerde Port Güvenliği konfigürasyonu çok basit bir işlemdir. Cisco Switch üzerinde Port Security etkinleştirmek için öncelikle arayüz üzerinde Switchport Mode Access komutu uygulanarak, arayüz erişim portu olarak yapılandırılır.

Aksi taktirde, bu port Dynamic bir port uyarısı verecektir. Komut sıralaması önem taşımaktadır. Bu sebeple herhangi bir arayüzü yapılandırmadan önce erişim portuna çevirmeniz gerekir.

Switch üzerinde Port Security etkinleştirildikten sonra, arayüz üzerinde Violation (İhlal) durumunu belirtmemiz gerekir. Violation durumu 3 türden oluşur. Bu yazımızda yalnızca ihlale uğrayan arayüzü Shutdown (Kapat) aksiyonunu uygulayacağız. Violation Shutdown seçeneği, Cisco Switch’lerde Port Güvenliği için en sağlam yöntemdir.

Restrict ve Protect seçeneklerini videoyu izleyerek gerçekleştirebilirsiniz.

Önceki yazımızda Port Security Nedir? konusundan bahsetmiştik. Bu yazımızda Cisco Packet Tracer üzerinde Port Security konfigürasyonu adımlarını gerçekleştirelim.

Packet Tracer’da Cisco Switch Port Security Etkinleştirme

Cisco Packet Tracer’da Cisco Switch Port Security etkinleştirme ve test etme adımlarına artık geçebiliriz.

   Adım 1

Cisco Packet Tracer programını çalıştırınız ve aşağıdaki görüntüdeki gibi bir topoloji oluşturunuz. Cisco Router’a IP adresi atayınız ve ardından bilgisayarlara IP adresi atayınız.

Eğer bu işlemleri bilmiyorsanız, Cisco Packet Tracer Kullanımı adlı yazıya göz atabilirsiniz…

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 2

Cisco Switch üzerinde Port Security etkinleştirmeden önce, aygıtlar arasında ağ bağlantısı testi yapınız. PC0’dan Cisco Router arayüzüne ve PC1’e Ping atarak bağlantıyı test ediniz.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 3

Aynı şekilde, PC1’den diğer aygıtlara Ping atarak bağlantıyı test ediniz. Bağlantı sınamasından sonra, Cisco Switch üzerine tıklayınız.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 4

Cisco Switch CLI sekmesine tıklayınız. Cisco Packet Tracer Port Securtiy konfigürasyonu komutlarını sırasıyla uygulayınız.

Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface fastethernet0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport port-security
Switch(config-if)#switchport port-security mac-address sticky
Switch(config-if)#switchport port-security maximum 1
Switch(config-if)#switchport port-security violation shutdown
Switch(config-if)#
Switch(config-if)#exit
Switch(config)#
Switch(config)#interface fastethernet0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport port-security
Switch(config-if)#switchport port-security mac-address sticky
Switch(config-if)#switchport port-security maximum 1
Switch(config-if)#switchport port-security violation shutdown
Switch(config-if)#
Switch(config-if)#end
Switch#

Yukarıdaki konfigürasyon komutlarını açıklayacak olursak, Cisco Switch üzerinde FastEthernet0/1 ve FastEthernet0/2 arayüzlerinde Port Security aktif hale getirildi. Switchport Mode Access komutu ile arayüz access moda ayarlandı. Mac-address sticky komutu ise, Cisco Switch arayüzlerine bağlı bilgisayarların MAC adresleri otomatik olarak hafızaya alındı.

Maksimum 1 komutu ile yalnızca 1 adet MAC adresi hafızaya alınarak Port Güvenliği sağlanacaktır.

Bu arayüzlere uygulanacak herhangi bir ihlal durumunda, Fa0/1 veya Fa0/2 arayüzleri shutdown olacaktır.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 5

Cisco Switch privileged modda show port-security komutunu uygulayınız. Şuan arayüzler üzerinde ihlal oluşmadığından dolayı, SecurityViolation (Count) kısmı 0’dır.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 6

Show mac address-table komutunu uyguladığımızda, Cisco Switch’e bağlı bilgisayarların MAC adreslerinin tabloya kaydedildiğini görebiliriz. Buradaki MAC adresleri ihlal durumunda kıyaslanacaktır.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 7

Show port-security interface fa0/1 komutunu uygulayarak, Cisco Switch FastEthernet0/1 arayüzünün detaylı bilgilerini görebiliriz.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 8

Cisco Packet Tracer Port Security konfigürasyonu adımlarını tamamladık. Şimdi, Port Security özelliğinin çalışıp çalışmadığını test edelim.

Packet Tracer çalışma alanına bir adet daha bilgisayar ekleyiniz ve bu bilgisayarın IP ayarlarını yapılandırınız. Daha sonra, PC0 ve Switch0 arasındaki kabloyu çıkarınız.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 9

PC2 bilgisayarı yapılandırdıktan sonra, Switch0 üzerinde Fa0/1 arayüzüne bağlayınız.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 10

PC2’den PC1’e Ping attığımızda işlemin başarısız olduğunu görebiliriz. Ve hemen ardından, Cisco Switch Fa0/1 arayüzünde bir ihlal algılayarak, hafızasındaki MAC adresini eşleştirdi ve tablosundaki MAC adresi ile farklı olduğunu anlayınca Portu hemen kapattı.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 11

Switch üzerinde oluşan ihlalden sonra, CLI komut isteminde show ip interface brief komutunu çalıştırarak arayüz durumlarını kontrol edelim.

Aşağıdaki görüntüde gördüğünüz gibi, FastEthernet0/1 arayü Down (Kapalı) duruma geçmiştir.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 12

Aynı şekilde, show port-security komutunu uyguladığımızda ise Violation Count (İhlal Sayacı) bölümünde 1 artış olduğunu görebiliriz.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 13

Cisco Packet Tracer Port Security konfigürasyonu başarıyla tamamlandı. Fakat, kapatılan portu bir sistem yöneticisinin manuel olarak açması gereklidir.

Önce shutdown komutunu çalıştırınız ve ardından no shutdown diyerek Fa0/1 portunu Up duruma getiriniz.

Cisco Packet Tracer Port Security Konfigürasyonu

   Adım 14

FastEthernet0/1 arayüzü aktif hale geldikten sonra, tekrar PC0’ı Switch’e bağlayınız ve Ping testi yapınız.

Aşağıdaki görüntüde gördüğünüz gibi, PC0 ağ üzerinde diğer aygıtlar ile başarıyla bağlantı kurmuştur.

Cisco Packet Tracer Port Security Konfigürasyonu

Cisco Packet Tracer Port Security Konfigürasyonu Show Komutları

Switch#show runRouter#show running-configSwitch#show port-securitySwitch#show mac address-tableSwitch#show port-security interface fa0/1
Switch#show run
Building configuration…

Current configuration : 1357 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 0001.43EC.7639
!
interface FastEthernet0/2
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 0007.EC9C.8167
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
Switch#

Router#show running-config
Building configuration…

Current configuration : 620 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524837C
!
!
!
spanning-tree mode pvst
!
!
!
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

Switch#show port-security
Secure Port MaxSecureAddr CurrentAddr SecurityViolation Security Action
(Count) (Count) (Count)
——————————————————————–
Fa0/1 1 0 0 Shutdown
Fa0/2 1 0 0 Shutdown
———————————————————————-
Switch#
Switch#show mac address-table
Mac Address Table
——————————————-

Vlan Mac Address Type Ports
—- ———– ——– —–

1 0001.43ec.7639 STATIC Fa0/1
1 0001.c7a9.d501 DYNAMIC Gig0/1
1 0007.ec9c.8167 STATIC Fa0/2
Switch#

Switch#show port-security interface fa0/1
Port Security : Enabled
Port Status : Secure-up
Violation Mode : Shutdown
Aging Time : 0 mins
Aging Type : Absolute
SecureStatic Address Aging : Disabled
Maximum MAC Addresses : 1
Total MAC Addresses : 1
Configured MAC Addresses : 0
Sticky MAC Addresses : 1
Last Source Address:Vlan : 0001.43EC.7639:1
Security Violation Count : 0
Switch#

Cisco Packet Tracer Port Security Konfigürasyonu ⇒ Video

Cisco Packet Tracer Port Security konfigürasyonu adımlarını aşağıdaki videoyu izleyerek gerçekleştirebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Cisco Packet Tracer Port Security Konfigürasyonu – Cisco Switch üzerinde Port Security adımlarını gerçekleştirdik. Port Güvenliği hakkında daha fazla bilgi almak için sitemizdeki makaleleri okuyabilirsiniz. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Packet Tracer Port Security Konfigürasyonu İlgili Yazılar
Cisco Packet Tracer Port Security Konfigürasyonu İlgili Dosya
İlgili Dosya

Cisco Packet Tracer’da yapılandırılan topolojiyi PKT dosyası olarak aşağıdaki butondan bilgisayarınıza indirebilirsiniz.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir