Cisco Packet Tracer Üzerinde DHCP Relay Agent Konfigürasyonu

“Broadcast” trafiğinin, yönlendiricilerden geçmediğini biliyoruz. Ancak, bir bilgisayarın IP adresi alma isteği için ağ kesimi üzerinden yayın yaparak DHCP’yi arar. Bu trafik yönlendiricilerden geçmediği için aynı segmentte bir DHCP bulamazsa, bir adres elde edemeyecektir.

Cisco Packet Tracer Üzerinde DHCP Relay Agent Konfigürasyonu

Cisco Router Üzerinde DHCP Relay Agent Etkinleştirme

Şimdi, iki küçük ağ olduğunu varsayalım. Bir ofis Merkez’de diğeri ise yakın veya uzak lokasyondaki Şube ofis olarak adlandırılan konumda.

Yönlendiricilerdeki yayın trafiğinin bu DHCP isteklerinin çalışmasını sağlamak için bir yol var. Diğer bir deyişle, bir adres elde etmek için bir DHCP sunucusunu bulmak çok önemli bir hizmet olduğundan, bu geniş kitle trafiğinin bir DHCP sunucusunu bulmasına izin vermek, diğer ofislerden bu bilgisayarları bulabilmek için bir istisna vardır.

Çok az sayıda bilgisayar var ve adreslerini belirtmek için özel bir sunucu koymakta fayda yok, bu yüzden iki seçenek var; bu bilgisayarlara sabit bir IP adresi koymak veya bir DHCP aktarım hizmeti yapılandırmak.

DHCP Relay Agent, bu nedenle DHCP istemcilerinden DHCP yayınlarını dinleyecek ve bu mesajları farklı alt ağlardaki DHCP sunucularına iletecek şekilde yapılandırılmış bir sunucu veya yönlendiricidir. Röle aracıları DHCP standartlarının bir parçasıdır ve protokol tasarımını ve ilgili davranışı tanımlayan standart dokümanlara (RFC’ler) göre çalışır. Bu yüzden “RFC 1542 Uyumlu Yönlendirici”, DHCP yayın trafiğinin iletilmesini destekleyen bir yönlendiricidir.

DHCP istemcilerinin, DHCP sunucusundan IP adresi almak için yayın kullandıklarını biliyoruz. Yönlendiriciler, normal olarak, izin verecek şekilde yapılandırılmadıkça yayınları geçirmez. Bu nedenle, ek yapılandırma olmadan, DHCP sunucuları yalnızca yerel ağınızdaki istemcilere IP adresleri atamakla görevlidir. Diğer segmentlerdeki istemcilere IP adresleri atayabilmek için, ağı DHCP yayınlarının istemciden DHCP sunucusuna ulaşabileceği şekilde yapılandırmak gerekir.

DHCP Relay Agent farklı lokasyonlara IP adresi dağıtımı yapmak için kullanılır. Agent olarak yapılandırılmış bir ağ bağdaştırıcısı kendi ağ ortamındaki DHCP Broadcast‘leri alır ve Unicast olarak ilgili DHCP sunucusuna gönderir.

DHCP Aktarım Aracı yapılandırılan aygıt bir Router veya Sunucu olabilir. Ayrıca bu görevi gerçekleştiren 3. parti yazılımlar da mevcuttur.

DHCP Relay Agent Yapılandırma

Cisco yönlendirici üzerinde DHCP Agent kurulumu için aşağıdaki adımları sırasıyla takip ediniz.

   Adım 1

Packet Tracer programını açınız ve DHCP Aktarım hizmeti için aşağıdaki gibi bir ağ topolojisi oluşturunuz.

Bir Cisco Router'a Bağlı İki Switch

   Adım 2

Cisco Router R1 CLI komut istemini açınız ve Router’ın GigabitEthernet arayüzlerini aşağıdaki gibi yapılandırınız.

R1# conf t
R1(config)# interface gigabitethernet 0/0
R1(config-if)# ip address 192.168.5.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface gigabitethernet 0/1
R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

 
GigabitEthernet 0/1 Arayüzüne IP Adresi Atama

   Adım 3

Router üzerinde DHCP sunucusunu aşağıdaki gibi yapılandırınız.

Burada DHCP’yi etkinleştirmenin amacı Relay Agent ile arasındaki farkı görmektir. Daha sonra DHCP’yi iptal ederek farklı lokasyondan IP adresi almaya çalışacağız.

R1# conf t
R1(config)# ip dhcp pool LAN
R1(dhcp-config)# network 192.168.5.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.5.1
R1(dhcp-config)# dns-server 192.168.5.1

 
Cisco Router'da DHCP Havuzu Oluşturma

   Adım 4

PC1 komut isteminden varsayılan ağ geçidine Ping atarak bağlantıyı test ediniz.

PC'den Router Arayüzüne Ping Atma

   Adım 5

PC1 IP adresi yapılandırmasını DHCP olarak yapılandırınız.

PC'de DHCP Etkinleştirme

   Adım 6

PC1, DHCP Broadcast mesajı yolladı ve ağ üzerindeki DHCP sunucusundan IP adresi almak için beklemektedir.

Requesting IP Address

   Adım 7

PC1, Router üzerinde yapılandırılan DHCP sunucusundan TCP/IP bilgilerini başarıyla aldı.

DHCP Request Successful

   Adım 8

192.168.10.0/24 ağına eklediğiniz sunucuyu aşağıdaki gibi yapılandırınız ve Add (Ekle) butonuna tıklayarak konfigürasyonu listeye ekleyiniz.

DHCP Sunucu Yapılandırma

   Adım 9

DHCPRELAY havuzunun listeye eklendiğinden emin olduktan sonra bir sonraki adıma devam ediniz.

DHCP Havuzu Yapılandırma

   Adım 10

DHCP havuzunu no ip dhcp pool LAN komutu ile siliniz ve ardından AGENT görevini yapacak arayüz üzerinde ip helper-address (DHCP Sunucu IP Adresi) komutunu uygulayınız.

R1# conf t
R1(config)# no ip dhcp pool LAN
R1(config)# interface gigabitethernet0/0
R1(config-if)# ip helper-address 192.168.10.10

 
DHCP Ayarlarını Silme

   Adım 11

PC1’in IP yapılandırması için önce Statik’i seçiniz ve hemen ardından DHCP seçeneğini seçiniz.

Tekrar DHCP Etkinleştirme

   Adım 12

IP adresi alınırken bekleyiniz.

IP Adresi Alınıyor

   Adım 13

Aşağıdaki görüntüde gördüğünüz gibi PC1, TCP/IP ayarlarını 192.168.10.10 IP adresli DHCP Sunucusundan aldı. Ayrıca, Agent olarak yapılandırılan DHCP havuzundaki 192.168.5.150 – 192.168.5.200 bloğundan IP adresini aldığını görebilirsiniz.

Farklı Ağdaki DHCP Sunucudan IP Adresi Alma

   Video

Cisco Router üzerinde DHCP aktarım hizmetini etkinleştirmek için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


DHCP aktarım aracı ile farklı segmentlere kolaylıkla IP adresi dağıtabilirsiniz. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


Packet Tracer RIP
Packet Tracer RIP Version 2
Packet Tracer EIGRP
Packet Tracer OSPF
TFTP IOS Kopyalama

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

shares
error: