Trunk Port Nedir? Trunk Port Ne İşe Yarar? – Trunk Port, Trunk Bağlantı olarak da ifade edilir. Switch’ler arasında VLAN bilgilerini taşımak için Trunk Bağlantı yapılması gereklidir.
Trunk Port Nedir? Trunk Port Ne İşe Yarar?

Trunk Port Nedir? Trunk Port Ne İşe Yarar?

Trunk Port Nedir? Trunk Port Ne İşe Yarar?

Önceki yazımızda Access Port Nedir? konusunu anlatmıştık. Access Port’lar tek bir VLAN’a aittir ve Switch’ler arasında taşınan VLAN bilgisi için herhangi bir frame değişikliği sağlamaz. Access Port’lar sadece Switch üzerinde porta tanımlanmış VLAN’dan gelen trafiği geçirir.

İki Cisco Switch üzerinde tanımlanan Trunk Port Bağlantısı, yapılandırılan tüm VLAN’ları geçirir. VLAN bilgisi Trunk Port üzerinden geçmeden önce kapsülleme işlemine uğrar. Bu kapsülleme (Encapsulation) ISL ya da 802.1Q’dur.

Trunk Port bağlantısı diğer bir adıyla Trunking olarak da bilinir. Birbirine bağlanan iki Switch’te, VLAN’ları geçirebilmesi için iki interface (arayüz) üzerinde Trunk bağlantısının yapılandırılması gerekir.

Cisco Trunk Nedir?

Cisco Trunk Port hakkında birkaç terim duymuşsunuzdur. Cisco Switch’ler üzerinde sadece Cisco ürünlerine ait kapsülleme yöntemi bulunmaktadır. Eğer bir ağ ortamında Cisco Switch aygıtlarını kullanıyorsanız, kapsülleme durumunu ISL olarak ayarlayabilirsiniz.

802.1Q kapsülleme tüm Switch’lerin birbiri ile uyumlu çalışabilmesi için geliştirilmiştir.

802.1Q = Frame içinde kaynak adresinden sonra 4 bayt’lık tag (etiket) ekler.

ISL  (Inter-Switch Link) = Sadece Cisco’ya özgüdür. Frame içine 26 bayt’lık header başlığı ve 4 bayt’lık trailer (bitiş kaydı) ekler.

Cisco Switch Trunk Bağlantısı

Cisco Switch Trunk bağlantısı yapmak için, Cisco Packet Tracer programını kullanacağız. Cisco Packet Tracer programını çalıştırdıktan sonra, aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz.

   Adım 1

Cisco Switch Trunk bağlantısı yapmadan önce, Cisco Switch VLAN oluşturma işlemini uygulamanız gerekmektedir. VLAN oluşturduktan sonra, iki Cisco Switch arasında Trunk bağlantısı yapabilirsiniz.

Cisco Switch Trunk bağlantısı için Cisco Switch0 üzerine tıklayınız.

Trunk Port Nedir? Trunk Port Ne İşe Yarar?

   Adım 2

Açılan pencerede CLI sekmesine tıklayınız ve ardından aşağıdaki komutları uygulayınız.

[code] Switch# conf t
Switch(config)# interface gigabitethernet 0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# end
Switch# wr
[/code]

Trunk Port Nedir? Trunk Port Ne İşe Yarar?

   Adım 3

Cisco Switch Trunk bağlantısı iki Switch arasında yapılandırılması gerekmektedir. Cisco Switch1 üzerine tıklayınız ve aşağıdaki komutları uygulayarak karşı Switch’e bağlı arayüzü Trunk olarak yapılandırınız.

[code] Switch# conf t
Switch(config)# interface gigabitethernet 0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# end
Switch# wr
[/code]

Trunk Port Nedir? Trunk Port Ne İşe Yarar?

   Adım 4

Cisco Packet Tracer çalışma alanındaki PC1 komut isteminden, VLAN5’e üye olan PC2’ye ping atınız. Ping işleminin başarılı olduğunu aşağıdaki görüntüden görebilirsiniz.

Eğer iki Cisco Switch arasında Trunk Bağlantısı yapılandırılmasaydı, VLAN5’teki bilgisayarlar birbirleriyle iletişim kuramayacaklardı…

Trunk Port’lar üzerinde Trunk kapsülleme yöntemi kullanarak farklı lokasyondaki VLAN’lar birbirleriyle haberleşebilecektir.

Trunk Port Nedir? Trunk Port Ne İşe Yarar?

   Adım 5

Cisco Switch0 üzerinde show interfaces switchport komutunu uyguladıktan sonra, gigabitethernet 0/1 arayüzünün Trunk olarak ayarlandığını görebilirsiniz.

Trunk Port Nedir? Trunk Port Ne İşe Yarar?

   Adım 6

Cisco Switch1 üzerinde de show interfaces switchport komutunu uyguladıktan sonra, gigabitethernet 0/2 arayüzünün Trunk olarak ayarlandığını görebilirsiniz.

Trunk Port Nedir? Trunk Port Ne İşe Yarar?

Cisco Router nasıl çalışır? Sorunun cevabını Cisco Router Önyükleme Süreci adlı yazıda bulabilirsiniz…

Cisco Switch Trunk Bağlantısı Show Komutları

Switch0#show running-configSwitch0#show vlan briefSwitch0#show interfaces trunkSwitch1#show running-configSwitch1#show vlan briefSwitch1#show interfaces trunkSwitch0# show interfaces switchportSwitch1# show interfaces switchport

Switch0#show running-config
Building configuration…

Current configuration : 1118 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport access vlan 5
switchport mode access
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
Switch#

Switch0#show vlan brief

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/1, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24, Gig0/2
5 IT active Fa0/2
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
Switch#

Switch0#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Gig0/1 on 802.1q trunking 1

Port Vlans allowed on trunk
Gig0/1 1-1005

Port Vlans allowed and active in management domain
Gig0/1 1,5

Port Vlans in spanning tree forwarding state and not pruned
Gig0/1 1,5

Switch#

Switch1#show running-config
Building configuration…

Current configuration : 1118 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 5
switchport mode access
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
end
Switch#

Switch1#show vlan brief

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24, Gig0/1
5 IT active Fa0/1
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
Switch#

Switch1#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Gig0/2 on 802.1q trunking 1

Port Vlans allowed on trunk
Gig0/2 1-1005

Port Vlans allowed and active in management domain
Gig0/2 1,5

Port Vlans in spanning tree forwarding state and not pruned
Gig0/2 1,5

Switch#

Switch0# show interfaces switchport

Name: Gig0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Switch1# show interfaces switchport

Name: Gig0/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Cisco yönlendiricilerde Statik NAT Nedir? Sorunun cevabını Static NAT Nedir? Static NAT Nasıl Çalışır? adlı yazıda bulabilirsiniz…

Trunk Port Nedir? Trunk Port Ne İşe Yarar? ⇒ Video

Trunk Port çalışma mantığını ve Cisco Switch Trunk bağlantısı konfigürasyonu için aşağıdaki videoyu izleyebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Trunk Port Nedir? Trunk Port Ne İşe Yarar? – Trunk Port hakkında kısaca bahsettikten sonra, Cisco Switch Trunk bağlantısı adımlarını gerçekleştirdik. Ayıca Switch üzerinde Show komutları ile arayüzleri inceledik. Sonuç olarak, Trunk bağlantısı iki veya daha fazla Switch arasında VLAN’ları taşımak için yapılandırılır. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Trunk Port Nedir? Trunk Port Ne İşe Yarar? İlgili Yazılar

Trunk Port Nedir? Trunk Port Ne İşe Yarar? İlgili Dosya
İlgili Dosya
Cisco Packet Tracer’da Cisco Switch Trunk bağlantısı için PKT dosyasını aşağıdaki butondan bilgisayarınıza indirebilirsiniz…

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

17 − one =