What is Trunk Port in Cisco Switches? – Trunk Port is also referred to as Trunk Link. Trunk Linking is required to move VLAN information between switches.
What is Trunk Port in Cisco Switches?

What is Trunk Port in Cisco Switches?

What is Trunk Port in Cisco Switches?

In our previous article, we talked about what is Access Port in Switch. Access Ports belong to a single VLAN and do not provide any frame changes for the VLAN information carried between the Switches. Access Ports only pass traffic from the port-defined VLAN on the switch.

The Trunk Port Connection defined on the two Cisco switches passes all configured VLANs. The VLAN information is encapsulated before passing through the Trunk Port. This encapsulation is ISL or 802.1Q.

Trunk Port connection is also known as Trunking. In the two switches connected to each other, the trunk connection must be configured on the two interfaces so that they can pass VLANs.

Our Recommendation; You can purchase the CISCO SYSTEMS 24-Port Gigabit Switch.

Understanding Trunk Port in Networking

You’ve heard a few terms about the Cisco Trunk Port. Only, the encapsulation methods are available in Cisco Switches of Cisco products. If you are using Cisco Switch devices in a network environment, you can set the encapsulation state to ISL.

802.1Q encapsulation has developed to allow all Switches to work together.

802.1Q = Adds a 4-byte tag after from the source address within the Frame.

ISL (Inter-Switch Link) = Only Cisco-specific. Adds a 26-byte header and 4-byte trailer into the frame.

How to Configure Trunk Connection Between Cisco Switches?

To make the Cisco Switch Trunk connection, we will use the Cisco Packet Tracer program. After running the Cisco Packet Tracer program, create a network topology as shown in the following image.

   Step 1

Before configuring Trunk connection between Cisco Switches, you need to implement the Cisco Switch VLAN creation process. Once you created a VLAN, you can make a trunk connection between the two Cisco Switches.

For Cisco Switch Trunk connection, click on Cisco Switch0.

What is Trunk Port in Cisco Switches?

   Step 2

In the window that opens, click on the CLI tab, and then execute the following commands.

Switch# conf t
Switch(config)# interface gigabitethernet 0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# end
Switch# wr

What is Trunk Port in Cisco Switches?

   Step 3

Cisco Switch Trunk connection must be configured between two Switches. Click on Cisco Switch1 and configure the interface connected to the opposite Switch as a Trunk by executing the following commands.

Switch# conf t
Switch(config)# interface gigabitethernet 0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# end
Switch# wr

What is Trunk Port in Cisco Switches?

   Step 4

From the PC1 command prompt in the Cisco Packet Tracer workspace, ping the PC2 that is a member of VLAN5. You can see that the ping process is successful from the following image.

If was not configured Trunk connection between Cisco Switches, the computers in VLAN 5 would not be able to communicate with each other…

By using trunk encapsulation on Trunk Ports, VLANs in different locations will be able to communicate with each other.

What is Trunk Port in Cisco Switches?

   Step 5

After applying the show interfaces switchport command on the Cisco Switch0, you can see that the GigabitEthernet 0/1 interface is set to Trunk.

What is Trunk Port in Cisco Switches?

   Step 6

After applying the show interfaces switchport command on the Cisco Switch1 as well, you can see that the GigabitEthernet 0/2 interface is set as Trunk.

What is Trunk Port in Cisco Switches?

How does the Cisco Router work? You can find the answer to the question in the article called “Cisco Router Boot Process Steps“.

Show Commands Related to What is Trunk Port in Cisco Switches

Switch0#show running-configSwitch0#show vlan briefSwitch0#show interfaces trunkSwitch1#show running-configSwitch1#show vlan briefSwitch1#show interfaces trunkSwitch0# show interfaces switchportSwitch1# show interfaces switchport

Switch0#show running-config
Building configuration…

Current configuration : 1118 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport access vlan 5
switchport mode access
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
Switch#

Switch0#show vlan brief

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/1, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24, Gig0/2
5 IT active Fa0/2
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
Switch#

Switch0#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Gig0/1 on 802.1q trunking 1

Port Vlans allowed on trunk
Gig0/1 1-1005

Port Vlans allowed and active in management domain
Gig0/1 1,5

Port Vlans in spanning tree forwarding state and not pruned
Gig0/1 1,5

Switch#

Switch1#show running-config
Building configuration…

Current configuration : 1118 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 5
switchport mode access
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
end
Switch#

Switch1#show vlan brief

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24, Gig0/1
5 IT active Fa0/1
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
Switch#

Switch1#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Gig0/2 on 802.1q trunking 1

Port Vlans allowed on trunk
Gig0/2 1-1005

Port Vlans allowed and active in management domain
Gig0/2 1,5

Port Vlans in spanning tree forwarding state and not pruned
Gig0/2 1,5

Switch#

Switch0# show interfaces switchport

Name: Gig0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Switch1# show interfaces switchport

Name: Gig0/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

What is Static NAT on Cisco Routers? You can find the answer to the question in the article called “What is Static NAT on Cisco Router?“.

Configuring Trunk Connection Between Cisco Switches? ⇒ Video

You can view the following video for Trunk Port working logic and Cisco Switch Trunk link configuration and you can also subscribe to our YouTube channel …

  Final Word

What is Trunk Port in Cisco Switches? – After briefly discussing Trunk Port, we have implemented the Cisco Switch Trunk connection steps. We have examined the interfaces with Show commands on the Switch. As a result, the trunk link is configured to transport VLANs between two or more Switches.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!


Articles Related to What is Trunk Port in Cisco Switches;


Products Related to What is Trunk Port in Cisco Switches;


Download the PKT File Related to What is Trunk Port in Cisco Switches;

You can download the PKT file related to how to configure Trunk connection between Cisco Switches…


Leave a Reply

Your email address will not be published. Required fields are marked *

thirteen − 1 =